Τώρα είναι Κυρ 21 Απρ 2019 07:59 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 12 Απρ 2007 03:29 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΗΜΕΡΗΣΙΟ - ΙΟΥΛΙΟΣ 2004 - ΘΕΜΑ 2
! ===============================================================================================
! Δίνεται ο παρακάτω αλγόριθμος :
!
!    Αλγόριθμος Αριθμοί_ΜΕΡΣΕΝ
!     ΔΙΑΒΑΣΕ a
!     b <-- 4
!     c <-- 2
!     ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
!        b <-- b^2-2
!        ΓΡΑΨΕ b
!        c <-- c + 1
!     ΜΕΧΡΙΣ_ΟΤΟΥ c > a-1
!     d <-- 2^a-1
!     e <-- b - Α_Μ(b/d)*d
!     ΓΡΑΨΕ d
!     ΑΝ e = 0 ΤΟΤΕ
!        f <-- 2^(c-1)*d
!        ΓΡΑΨΕ 'TELEIOS ARIUMOS : ',f
!        g <-- 0
!        ΟΣΟ f>0 ΕΠΑΝΑΛΑΒΕ
!           g <-- G +1
!           f <-- Α_Μ(f/10)
!        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!        ΓΡΑΨΕ g
!    ΤΕΛΟΣ_ΑΝ
!   Τέλος Αριθμοί_ΜΕΡΣΕΝ
!
! Να γράψετε στο τετράδιο σας τις τιμές που τυπώνει ο παραπάνω αλγόριθμος, αν του δώσουμε τιμές
! εισόδου : α. 3  και β. 4
!
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ ΗΜ_2004_07_2
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: a,b,c,d,f,g,e
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε την τιμή του Α'
  ΔΙΑΒΑΣΕ a
  b <-- 4
  c <-- 2
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    b <-- b^2-2
    ΓΡΑΨΕ b
    c <-- c + 1
  ΜΕΧΡΙΣ_ΟΤΟΥ c > a-1
  d <-- 2^a-1
  e <-- b - Α_Μ(b/d)*d
  ΓΡΑΨΕ d
  ΑΝ e = 0 ΤΟΤΕ
    f <-- 2^(c-1)*d
    ΓΡΑΨΕ 'Τέλειος αριθμός : ',f
    g <-- 0
    ΟΣΟ f>0 ΕΠΑΝΑΛΑΒΕ
      g <-- G +1
      f <-- Α_Μ(f/10)        
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ g
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters