Τώρα είναι Δευτ 24 Ιουν 2019 06:23 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 12 Απρ 2007 03:29 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΗΜΕΡΗΣΙΟ - ΙΟΥΛΙΟΣ 2004 - ΘΕΜΑ 3
! ===============================================================================================
! Σε κάποια εξεταστική δοκιμασία κάθε γραπτό αξιολογείται αρχικά από δυο βαθμολογητές και
! υπάρχει περίπτωση το γραπτό να χρειάζεται αναβαθμολόγηση από τρίτο βαθμολογητή.
! Στην περίπτωση αναβαθμολόγησης ο τελικός βαθμός υπολογίζεται ως εξής:
!   i. Αν ο βαθμός του τρίτου βαθμολογητή είναι ίσος με το μέσο όρο (Μ.Ο.) των βαθμών των δυο
!      πρώτων βαθμολογητών, τότε ο τελικός βαθμός είναι ο Μ.Ο.
!  ii. Αν ο βαθμός του τρίτου βαθμολογητή είναι μικρότερος από το μικρότερο βαθμό (ΜΙΝ) των δυο
!      πρώτων βαθμολογητών, τότε ο τελικός βαθμός είναι ο ΜΙΝ.
! iii. Διαφορετικά, ο τελικός βαθμός είναι ο μέσος όρος του βαθμού του τρίτου βαθμολογητή με
!      τον πλησιέστερο προς αυτόν βαθμό των δυο πρώτων βαθμολογητών.
! Να αναπτύξετε αλγόριθμο υπολογισμού του τελικού βαθμού ενός γραπτού με αναβαθμολόγηση, ο οποίος
!   α. να διαβάζει τους βαθμούς του πρώτου, του δευτέρου και του τρίτου βαθμολογητή ενός γραπτού.
!   β. να υπολογίζει και να εκτυπώνει το μεγαλύτερο (MAX) και το μικρότερο (ΜΙΝ) από τους βαθμούς
!      του πρώτου και του δευτέρου βαθμολογητή.
!   γ. να υπολογίζει και να εκτυπώνει τον τελικό βαθμό του γραπτού συμφωνά με την παραπάνω
!      διαδικασία.
!
! Παρατήρηση: Θεωρήστε ότι και οι τρεις βαθμοί είναι θετικοί ακέραιοι αριθμοί και δεν απαιτείται
!             έλεγχος των δεδομένων.
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ ΗΜ_2004_07_3
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ : x1 , x2 , x3 , min , max , TB
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε τους βαθμούς των τριών βαθμολογητών'
  ΔΙΑΒΑΣΕ x1 , x2 , x3
  ΑΝ x1 < x2 ΤΟΤΕ
    min <-- x1
    max <-- x2
  ΑΛΛΙΩΣ
    min <-- x2    ! Δεν υπάρχει περίπτωση οι δύο βαθμοί να είναι ίσοι
    max <-- x1    ! αφού το γραπτό χρειάζεται αναβαθμολόγηση.
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ 'Μεγαλύτερος βαθμός =' , max                                          
  ΓΡΑΨΕ 'Μικρότερος βαθμός =' , min
  ΑΝ x3 = (x1 + x2)/2 ΤΟΤΕ
    TB <-- x3
  ΑΛΛΙΩΣ_ΑΝ x3 < min ΤΟΤΕ
    TB <-- min
  ΑΛΛΙΩΣ
    ΑΝ x3 - min < Α_Τ(max - x3) ΤΟΤΕ
      TB <-- (x3 + min)/2
    ΑΛΛΙΩΣ
      TB <-- (x3 + max)/2
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ 'Τελικός Βαθμός =' , TB
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters