Τώρα είναι Δευτ 18 Φεβ 2019 10:44 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Εσπερινό - Θέμα 1
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 12 Απρ 2007 03:21 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΕΣΠΕΡΙΝΟ - ΙΟΥΝΙΟΣ 2004 - ΘΕΜΑ 1
! ===============================================================================================
! Δίνεται το παρακάτω τμήμα αλγορίθμου :
!     x <-- 50
!     ΟΣΟ x > 0 ΕΠΑΝΑΛΑΒΕ
!        ΓΙΑ y ΑΠΟ 2 ΜΕΧΡΙ 6 ΜΕ_ΒΗΜΑ 2
!           x <-- x - 10
!        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!        ΓΡΑΨΕ x
!     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!
! 1. Πόσες φορές θα εκτελεστεί η εντολή ΓΡΑΨΕ x;
! 2. Πόσες φορές θα εκτελεστεί η εντολή εκχώρησης :  x <-- x - 10 ;
! 3. Ποιες είναι οι διαδοχικές τιμές των μεταβλητών x και y σε όλες τις επαναλήψεις;
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ ΕΣ_2004_06_1
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : x , y , n , k
ΑΡΧΗ
  x <-- 50
  n <-- 0             ! αριθμός επαναλήψεων εντολής x <-- x - 10
  k <-- 0             ! αριθμός επαναλήψεων εντολής ΓΡΑΨΕ x
  ΓΡΑΨΕ ' Χ    Υ'
  ΓΡΑΨΕ '--------'
  ΟΣΟ x > 0 ΕΠΑΝΑΛΑΒΕ
    ΓΙΑ y ΑΠΟ 2 ΜΕΧΡΙ 6 ΜΕ ΒΗΜΑ 2
      x <-- x - 10
      n <-- n + 1
      ΓΡΑΨΕ x , '  ' ,  y
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ x                                
    k <-- k + 1
    ΓΡΑΨΕ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'η εντολή ΓΡΑΨΕ x εκτελέστηκε', k , 'φορές.'
  ΓΡΑΨΕ 'η εντολή εκχώρησης x <-- x - 10 εκτελέστηκε', n , 'φορές.'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters