Τώρα είναι Κυρ 21 Απρ 2019 07:55 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Εσπερινό - Θέμα 3
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 12 Απρ 2007 03:19 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΕΣΠΕΡΙΝΟ - ΙΟΥΝΙΟΣ 2004 - ΘΕΜΑ 3
! ===============================================================================================
! Σε έναν αγώνα δισκοβολίας συμμετέχουν 20 αθλητές. Κάθε αθλητής έκανε μόνο μία έγκυρη ρίψη που
! καταχωρείται ως επίδοση του αθλητή και εκφράζεται σε μέτρα.
! Να αναπτύξετε αλγόριθμο που
!  α. να διαβάζει για κάθε αθλητή το όνομα καιτην επίδοση του,
!  β. να ταξινομεί τους αθλητές ως προς την επίδοση τους,
!  γ. να εμφανίζει τα ονόματα και τις επιδόσεις των τριών πρώτων αθλητών, αρχίζοντας από εκείνον
!     με την καλύτερη επίδοση,
!  δ. να εμφανίζει τα ονόματα και τις επιδόσεις των πέντε τελευταίων αθλητών, αρχίζοντας από
!     εκείνο με την καλύτερη επίδοση.
!
! Σημείωση: Να θεωρήσετε ότι δεν υπάρχουν αθλητές με την ίδια ακριβώς επίδοση.
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ ΕΣ_2004_06_3
ΜΕΤΑΒΛΗΤΕΣ                    
  ΑΚΕΡΑΙΕΣ : i , j
  ΠΡΑΓΜΑΤΙΚΕΣ : y[20] , temp
  ΧΑΡΑΚΤΗΡΕΣ : name[20] , temp1
ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
    ΓΡΑΨΕ 'Δώσε το όνομα του αθλητή' , i
    ΔΙΑΒΑΣΕ name[i]
    ΓΡΑΨΕ 'Δώσε την επίδοσή του'
    ΔΙΑΒΑΣΕ y[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 20
    ΓΙΑ j ΑΠΟ 20 ΜΕΧΡΙ i ΜΕ ΒΗΜΑ -1
      ΑΝ y[j-1] < y[j] ΤΟΤΕ
        temp <-- y[j-1]
        y[j-1] <-- y[j]
        y[j] <-- temp
        temp1 <-- name[j-1]
        name[j-1] <-- name[j]
        name[j] <-- temp1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Οι τρεις καλύτεροι αθλητές είναι :'
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 3
    ΓΡΑΨΕ i , 'ος ' , name[i] , 'με επίδοση' , y[i] , 'μέτρα'
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Οι πέντε τελευταίοι αθλητές είναι :'
  ΓΙΑ i ΑΠΟ 16 ΜΕΧΡΙ 20
  ΓΡΑΨΕ i , 'ος ' , name[i] , 'με επίδοση' , y[i] , 'μέτρα'
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters