Τώρα είναι Δευτ 26 Αύγ 2019 08:36 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Ημερήσιο - Θέμα 2
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 12 Απρ 2007 03:11 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΗΜΕΡΗΣΙΟ - ΙΟΥΝΙΟΣ 2004 - ΘΕΜΑ 2
! ===============================================================================================
! Δίνεται  ο   μονοδιάστατος  πίνακας  C  με  έξι  στοιχεία   που έχουν αντίστοιχα τις
! παρακάτω τιμές :
!                    C
! -----------------------------------------
! |  2  |  5  |  15  |  -1  |  32  |  14  |
! -----------------------------------------
!
! και το παρακάτω τμήμα αλγορίθμου:
!    MIN <-- 100
!    MAX <-- -100
!    ΓΙΑ I ΑΠΟ 1 ΜΕΧΡΙ 6 ΜΕ ΒΗΜΑ 2
!       A <-- C[I]
!       B <-- C[I+1]
!       ΑΝ A <B ΤΟΤΕ
!          LMIN <-- A
!          LMAX <-- B
!       ΑΛΛΙΩΣ
!          LMIN <-- B
!          LMAX <-- A
!       ΤΕΛΟΣ_ΑΝ
!       ΑΝ LMIN < MIN ΤΟΤΕ
!          MIN <-- LMIN
!       ΤΕΛΟΣ_ΑΝ
!       ΑΝ LMAX > MAX ΤΟΤΕ
!          MAX <-- LMAX
!       ΤΕΛΟΣ_ΑΝ
!       ΓΡΑΨΕ A , B , LMIN , LMAX , MIN , MAX
!    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!    D <-- MAX*MIN
!    ΓΡΑΨΕ D
!
! Να εκτελέσετε το παραπάνω τμήμα αλγορίθμου και να γράψετε στο τετράδιο σας :
!   α. Τις τιμές των μεταβλητών Α, Β, Lmin, Lmax, min και max, όπως αυτές εκτυπώνονται σε κάθε
!      επανάληψη.
!   β. Την τιμή της μεταβλητής D που εκτυπώνεται.
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ ΗΜ_2004_06_2
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ :D,i,A,B,LMIN,LMAX,MIN,MAX,C[6]
ΑΡΧΗ
  C[1] <-- 2
  C[2] <-- 5
  C[3] <-- 15
  C[4] <-- -1
  C[5] <-- 32
  C[6] <-- 14
  MIN <-- 100
  MAX <-- -100

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 6 ΜΕ ΒΗΜΑ 2
    ΓΡΑΨΕ '------------'
    A <-- C[i]
    B <-- C[i+1]
    ΑΝ A <B ΤΟΤΕ
      LMIN <-- A
      LMAX <-- B
    ΑΛΛΙΩΣ
      LMIN <-- B
      LMAX <-- A
    ΤΕΛΟΣ_ΑΝ
    ΑΝ LMIN < MIN ΤΟΤΕ
      MIN <-- LMIN
    ΤΕΛΟΣ_ΑΝ
    ΑΝ LMAX > MAX ΤΟΤΕ
      MAX <-- LMAX
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ '    A =' , A
    ΓΡΑΨΕ '    B =' , B
    ΓΡΑΨΕ ' LMIN =' , LMIN
    ΓΡΑΨΕ ' LMAX =' , LMAX
    ΓΡΑΨΕ '  MIN =' , MIN

    ΓΡΑΨΕ '  MAX =' , MAX
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ '------------'
  D <-- MAX*MIN
  ΓΡΑΨΕ '    D =' , D
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters