Τώρα είναι Δευτ 26 Αύγ 2019 07:36 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Ημερήσιο - Θέμα 3
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 12 Απρ 2007 03:09 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΗΜΕΡΗΣΙΟ - ΙΟΥΝΙΟΣ 2004 - ΘΕΜΑ 3
! ===============================================================================================
! Μία εταιρεία ταχυδρομικών υπηρεσιών εφαρμόζει για τα έξοδα αποστολής ταχυδρομικών επιστολών
! εσωτερικού και εξωτερικού, χρέωση συμφωνά με τον παρακάτω πίνακα:
!
!   ---------------------------------------------------------------
!      Βάρος επιστολής       Χρέωση εσωτερικού   Χρέωση εξωτερικού
!       σε γραμμάρια              σε Ευρώ            σε Ευρώ
!   ---------------------------------------------------------------
!    από    0 έως και 500           2,0                4,8
!    από  500 έως και 1000          3,5                7,2
!    από 1000 έως και 2000          4,6               11,5
!   ---------------------------------------------------------------
!
! Για παράδειγμα τα έξοδα αποστολής μιας επιστολής βάρους 800 γραμμαρίων και προορισμού εσωτερικού
! είναι 3,5 Ευρώ.
! Να γράψετε αλγόριθμο ο οποίος :
!   α. Να διαβάζει το βάρος της επιστολής.
!   β. Να διαβάζει τον προορισμό της επιστολής. Η τιμή ΕΣ δηλώνει προορισμό εσωτερικού και η τιμή
!      ΕΞ δηλώνει προορισμό εξωτερικού.
!   γ. Να υπολογίζει τα έξοδα αποστολής ανάλογα με τον προορισμό και το βάρος της επιστολής.
!   δ. Να εκτυπώνει τα έξοδα αποστολής.
! Παρατήρηση.
! Θεωρήστε ότι ο αλγόριθμος δέχεται τιμές για το βάρος μεταξύ του 0 και του 2000 και για τον
! προορισμό μόνο τις τιμές "ΕΣ" και "ΕΞ".
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ ΗΜ_2004_06_3
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: w , τιμη
  ΧΑΡΑΚΤΗΡΕΣ: π
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε βάρος επιστολής.'
  ΔΙΑΒΑΣΕ w
  ΟΣΟ w <= 0 ή w > 2000 ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ 'Λάθος. Ξαναδώσε'
    ΔΙΑΒΑΣΕ w
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Δώσε προορισμό ΕΣ ή ΕΞ'
  ΔΙΑΒΑΣΕ π
  ΟΣΟ π <> 'ΕΣ' ΚΑΙ π <> 'ΕΞ' ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ 'Λάθος. Ξαναδώσε'
    ΔΙΑΒΑΣΕ π
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ π = 'ΕΣ' ΤΟΤΕ
    ΑΝ w <= 500 ΤΟΤΕ
      τιμη <-- 2
    ΑΛΛΙΩΣ_ΑΝ w <= 1000 ΤΟΤΕ
      τιμη <-- 3.5
    ΑΛΛΙΩΣ
      τιμη <-- 4.6
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ
    ΑΝ w <= 500 ΤΟΤΕ
      τιμη <-- 4.8
    ΑΛΛΙΩΣ_ΑΝ w <= 1000 ΤΟΤΕ
      τιμη <-- 7.2
    ΑΛΛΙΩΣ
      τιμη <-- 11.5    
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ 'Έξοδα αποστολής =' , τιμη
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters