Τώρα είναι Δευτ 16 Σεπ 2019 11:15 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 12 Απρ 2007 03:33 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΕΣΠΕΡΙΝΟ - ΙΟΥΛΙΟΣ 2004 - ΘΕΜΑ 3
! ===============================================================================================
! Μια εταιρεία δημοσκοπήσεων θέτει σε ένα δείγμα 2000 πολιτών ένα ερώτημα. Για την επεξεργασία
! των δεδομένων να αναπτύξετε αλγόριθμο που:
!  1. να διαβάζει το φύλο του πολίτη (Α = Άνδρας, Γ = Γυναίκα) και να ελέγχει την ορθή εισαγωγή
!  2. να διαβάζει την απάντηση στο ερώτημα, η οποία μπορεί να είναι "ΝΑΙ", "ΟΧΙ", "ΔΕΝ ΞΕΡΩ" και
!     να ελέγχει την ορθή εισαγωγή
!  3. να υπολογίζει και να εμφανίζει το πλήθος των ατόμων που απάντησαν "ΝΑΙ"
!  4. στο σύνολο των ατόμων που απάντησαν "ΝΑΙ" να υπολογίζει και να εμφανίζει το ποσοστό των
!     ανδρών και το ποσοστό των γυναικών.
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ ΕΣ_2004_07_3
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : i , n , a
  ΠΡΑΓΜΑΤΙΚΕΣ: pa , pg
  ΧΑΡΑΚΤΗΡΕΣ: f[2000] , απάντηση[2000]
ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 2000
    ΓΡΑΨΕ 'Δώσε το φύλλο (A για άνδρα ή Γ για γυναίκα) του/της :',i
    ΔΙΑΒΑΣΕ f[i]
    ΟΣΟ f[i] <> 'Α' ΚΑΙ f[i] <> 'Γ' ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ 'Λάθος. Ξαναδώσε'                                                                                                
      ΔΙΑΒΑΣΕ f[i]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Τί απαντάτε στο ερώτημα ; (ΝΑΙ , ΟΧΙ , ΔΕΝ ΞΕΡΩ με κεφαλαία ελληνικά)'
    ΔΙΑΒΑΣΕ απάντηση[i]
    ΟΣΟ απάντηση[i] <> 'NΑI' ΚΑΙ απάντηση[i] <> 'OXI' ΚΑΙ απάντηση[i] <> 'ΔΕΝ ΞΕΡΩ' ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ 'Λάθος. Ξαναδώσε'
      ΔΙΑΒΑΣΕ απάντηση[i]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  n <-- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 2000
    ΑΝ απάντηση[i] = 'NAI' ΤΟΤΕ
      n <-- n + 1
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Στην έρευνα απάντησαν ΝΑΙ', n ,'άτομα.'
  a <-- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 2000
    ΑΝ απάντηση[i] = 'NAI' ΚΑΙ f[i] = 'A' ΤΟΤΕ
      a <-- a + 1
    ΤΕΛΟΣ_ΑΝ
    pa <-- A*100/n
    pg <-- 100 - pa
    ΓΡΑΨΕ pa,'% είναι άνδρες και'
    ΓΡΑΨΕ pg,'% είναι γυναίκες.'
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 27 Ιαν 2008 10:40 pm 
Χωρίς σύνδεση

Εγγραφή: Δευτ 21 Ιαν 2008 12:51 am
Δημοσιεύσεις: 3
Η παρακάτω λύση είναι σωστή?

Syntax: [ Download ] [ Hide ]
Αλγοριθμος Ασκηση
 για ι απο 1 μέχρι 2000
    αρχή_επανάληψης
      διάβασε χ
    μέχρις_ότου χ=α η χ=γ
    αρχή_επανάληψης
      διάβασε χ1
    μέχρις_ότου χ1='ναι' η χ2='οχι' η χ3='δεν ξερω'
    μ <-- 0
    αν χ1=ναι τότε
      μ <-- μ+1
    τέλος_αν
    γράψε μ
    μ1 <-- 0
    μ2 <-- 0
    αν χ1=ναι και χ=α τότε
      μ1 <-- μ1+1
    αλλιώς
      μ2 <-- μ2+1
    τέλος_αν
    γράψε μ1,μ2
  τελος_επαναληψης
Τελος Ασκηση


Κορυφή
 Προφίλ  
 
ΔημοσίευσηΔημοσιεύτηκε: Τετ 30 Ιαν 2008 01:31 am 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
1. Οι εντολές γράψε μ, γράψε μ1, γράψε μ2 πρέπει να είναι έξω από την επαναληπτική δομή έτσι ώστε να βγει ένα τελικό νούμερο και όχι οι τιμές των μ , μ1 , μ2 κατά τις επαναλήψεις.

2. Η άσκηση ζητάει ποσοστό ανδρών και ποσοστό γυναικών ανάμεσα σε αυτούς που απάντησαν ΝΑΙ και όχι το πλήθος.

3. Καλό είναι να μην ανακατεύουμε τη λήψη των δεδομένων με την επεξεργασία τους όταν χρησιμοποιούμε πίνακες. Εξ άλλου γιαυτό τα βάζουν στις εξετάσεις σε διαφορετικά ερωτήματα και βαθμολογούνται χωριστά.


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters