Τώρα είναι Κυρ 21 Απρ 2019 07:18 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Τρί 10 Απρ 2007 03:02 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΗΜΕΡΗΣΙΟ - ΙΟΥΛΙΟΣ 2003 - ΘΕΜΑ 4
! ===============================================================================================
! Κατά τη διάρκεια του πρωταθλήματοςμπάσκετ μια ομάδα που αποτελείται από δώδεκα (12) παίκτες
! έδωσε είκοσι (20) αγώνες, στους οποίους συμμετείχαν όλοι οι παίκτες.
! Να αναπτύξετε στο τετράδιό σας αλγόριθμο ο οποίος :
!  α. Να διαβάζει τα ονόματα των παικτών και να τα αποθηκεύει σε μονοδιάστατο πίνακα.
!  β. Να διαβάζει τους πόντους που σημείωσε κάθε παίκτης σε κάθε αγώνα και να τους αποθηκεύει σε
!     πίνακα δύο διαστάσεων.
!  γ. Να υπολογίζει για κάθε παίκτη το συνολικό αριθμό πόντων του σε όλους τους αγώνες και το
!     μέσο όρο πόντων ανά αγώνα.
!  δ. Να εκτυπώνει τα ονόματα των παικτών της ομάδας και το μέσο όρο πόντων του κάθε παίκτη
!     ταξινομημένα με βάση το μέσο όρο τους κατά φθίνουσα σειρά.
!  Παρατήρηση: Σε περίπτωση ισοβαθμίας δε μας ενδιαφέρει η σχετική σειρά των παικτών.
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ HM_2003_07_4
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i , j
  ΠΡΑΓΜΑΤΙΚΕΣ: point[12,21] , sum , temp
  ΧΑΡΑΚΤΗΡΕΣ: name[12] , tempname
ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 12
    ΓΡΑΨΕ 'Δώσε το όνομα του παίκτη Νο: ', i    
    ΔΙΑΒΑΣΕ name[i]
    ΓΙΑ j ΑΠΟ 1 μέχρι 20
      ΓΡΑΨΕ 'Δώσε τους πόντους του παίκτη ' , name[i],' στον αγώνα ', j
      ΔΙΑΒΑΣΕ point[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 12
    sum <-- 0
    ΓΙΑ j ΑΠΟ 1 μέχρι 20
      sum <-- sum + point[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    point[i,21] <-- sum/20
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 12
    ΓΙΑ j ΑΠΟ 12 μέχρι i με βήμα -1
      ΑΝ point[j-1,21] > point[j,21] ΤΟΤΕ
        temp <-- point[j,21]
        point[j,21] <-- point[j-1,21]
        point[j-1,21] <-- temp
        tempname <-- name[j]
        name[j] <-- name[j-1]
        name[j-1] <-- tempname
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 12
    ΓΡΑΨΕ point[i,21] , name[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters