Τώρα είναι Σάβ 29 Φεβ 2020 12:31 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Εσπερινό - Θέμα 1Γ
ΔημοσίευσηΔημοσιεύτηκε: Τρί 10 Απρ 2007 02:57 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΕΣΠΕΡΙΝΟ - ΙΟΥΝΙΟΣ 2003 - ΘΕΜΑ 1Γ
! ===============================================================================================
! Δίνεται ο αλγόριθμος :
!
!    ΔΙΑΓΡΑΜΜΑ ΡΟΗΣ
!
! 1. Ποιον τύπο δεδομένων θα επιλέγατε για τη δήλωση κάθε μεταβλητής;
! 2. Ποιες είναι οι διαδοχικές τιμές των i και sum;
! 3. Ποιες τιμές θα εκτυπωθούν;
! 4. Ποια αριθμητική παράσταση υπολογίζει ο αλγόριθμος;
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ ES_2003_06_1Γ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i , sum
ΑΡΧΗ
  i <-- 10
  sum <-- 0
  ΓΡΑΨΕ ' i   sum '
  ΓΡΑΨΕ '-----------'
  ΓΡΑΨΕ i ,'  ', sum
  ΓΡΑΨΕ '=========== ΑΡΧΗ ΕΠΑΝΑΛΗΠΤΙΚΗΣ ΔΟΜΗΣ'
  ΟΣΟ i <= 100 ΕΠΑΝΑΛΑΒΕ
    i <-- i + 20
    sum <-- sum + i
    ΓΡΑΨΕ i , '  ' , sum
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ '=========== ΤΕΛΟΣ ΕΠΑΝΑΛΗΠΤΙΚΗΣ ΔΟΜΗΣ'
  ΓΡΑΨΕ i , '  ' , sum
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters