Τώρα είναι Δευτ 26 Αύγ 2019 08:40 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 09 Απρ 2007 11:22 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΗΜΕΡΗΣΙΟ - ΙΟΥΛΙΟΣ 2003 - ΘΕΜΑ 2
! ===============================================================================================
! Δίνεται ο παρακάτω αλγόριθμος :
!
!   Αλγόριθμος Αριθμοί
!    Διάβασε Α
!    Εκτύπωσε Α
!    S <-- 1
!    K <-- 2                  
!    Αρχή_επανάληψης
!      Αν Α MOD K = 0 τότε
!         Β <-- Α DIV K
!         Αν Κ <> Β τότε
!            S <-- S + K + B                        
!            Εκτύπωσε Κ, Β
!         Αλλιώς
!            S <-- S + K
!            Εκτύπωσε Κ
!         Τέλος_αν
!      Τέλος_αν
!      Κ <-- Κ + 1
!    Μέχρις_ότου Κ > Ρίζα (Α)
!    Αν Α = S τότε
!       Εκτύπωσε S
!    Τέλος_αν
!   Τέλος Αριθμοί
!
! Η συνάρτηση Ρίζα (Α) επιστρέφει την τετραγωνική ρίζα του Α.
!
! Να γράψετε στο τετράδιό σας τις τιμές που τυπώνει ο παραπάνω αλγόριθμος, αν του δώσουμε τιμές
! εισόδου :   α. 36  και   β. 28
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ ΗΜ_2003_07_2
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: A,S,K,B
ΑΡΧΗ
  ΔΙΑΒΑΣΕ A                    
  ΓΡΑΨΕ A
  S <-- 1
  K <-- 2
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ A MOD K = 0 ΤΟΤΕ
      B <-- A DIV K
      ΑΝ K <> B ΤΟΤΕ
        S <-- S + K  + B
        ΓΡΑΨΕ K , B
      ΑΛΛΙΩΣ
        S <-- S + K
        ΓΡΑΨΕ K
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    K <-- K + 1
  ΜΕΧΡΙΣ_ΟΤΟΥ K > Τ_Ρ(A)
  ΑΝ A = S ΤΟΤΕ
    ΓΡΑΨΕ S
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters