Τώρα είναι Δευτ 24 Ιουν 2019 06:19 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Ημερήσιο - Θέμα 4
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 09 Απρ 2007 11:18 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΗΜΕΡΗΣΙΟ - ΙΟΥΝΙΟΣ 2003 - ΘΕΜΑ 4
! ===============================================================================================
! Μια αλυσίδα κινηματογράφων έχει δέκα αίθουσες. Τα ονόματα των αιθουσών καταχωρούνται σε ένα
! μονοδιάστατο πίνακα και οι μηνιαίες εισπράξεις κάθε αίθουσας για ένα έτος καταχωρούνται σε
! πίνακα δύο διαστάσεων.
! Να γράψετε αλγόριθμο ο οποίος:
!  α. να διαβάζει τα ονόματα των αιθουσών
!  β. να διαβάζει τις μηνιαίες εισπράξεις των αιθουσών αυτού του έτους
!  γ. να υπολογίζει τη μέση μηνιαία τιμή των εισπράξεων για κάθε αίθουσα
!  δ. να βρίσκει και να εμφανίζει τη μικρότερη μέση μηνιαία τιμή
!  ε. να βρίσκει και να εμφανίζει το όνομα ή τα ονόματα των αιθουσών που έχουν την ανωτέρω
!     μικρότερη μέση μηνιαία τιμή.
!  Παρατήρηση : Θεωρήστε ότι οι μηνιαίες εισπράξεις είναι θετικοί αριθμοί.
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ HM_2003_06_4
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i,j
  ΠΡΑΓΜΑΤΙΚΕΣ: Εισπράξεις[10,12],s,mo[10],min
  ΧΑΡΑΚΤΗΡΕΣ: Αίθουσα[10],name
ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10
    ΓΡΑΨΕ 'Δώσε το όνομα της αίθουσας',i
    ΔΙΑΒΑΣΕ Αίθουσα[i]                                        
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 12
      ΓΡΑΨΕ 'Δώσε την είσπραξη για τον',j,'ο μήνα.'
      ΔΙΑΒΑΣΕ Εισπράξεις[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10
    s <-- 0
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 12
      s <-- s + Εισπράξεις[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    mo[i] <-- s/12
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  min <-- mo[1]
  ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 10
    ΑΝ mo[i] < min ΤΟΤΕ
      min <-- mo[i]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'H μικρότερη μέση μηνιαία είσπραξη είναι',min
  ΓΡΑΨΕ 'Tην είσπραξη αυτή είχαν οι εξής αίθουσες'
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10
    ΑΝ mo[i] = min ΤΟΤΕ
      ΓΡΑΨΕ Αίθουσα[i]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters