Τώρα είναι Παρ 18 Οκτ 2019 09:45 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Ημερήσιο - Θέμα 2
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 09 Απρ 2007 11:14 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΗΜΕΡΗΣΙΟ - ΙΟΥΝΙΟΣ 2003 - ΘΕΜΑ 2
! ===============================================================================================
! Να γράψετε στο τετράδιό σας τις τιμές των μεταβλητών Ν, Μ και Β, όπως αυτές τυπώνονται σε κάθε
! επανάληψη, και την τιμή της μεταβλητής Χ που τυπώνεται μετά το τέλος της επανάληψης, κατά την
! εκτέλεση του παρακάτω αλγόριθμου.
!
!  Αλγόριθμος Αριθμοί
!   Α <-- 1
!   Β <-- 1
!   Ν <-- 0
!   Μ <-- 2
!   Όσο Β < 6 επανάλαβε
!      Χ <-- Α + Β
!      Αν Χ MOD 2 = 0 τότε
!         Ν <-- Ν + 1
!      αλλιώς
!         Μ <-- Μ + 1
!      Τέλος_αν
!      Α <-- Β
!      Β <-- Χ
!      Εμφάνισε Ν, Μ, Β
!   Τέλος_επανάληψης
!   Εμφάνισε Χ
!  Τέλος Αριθμοί
!
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ ΗΜ_2003_06_2
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: A,N,M,B,X
ΑΡΧΗ
  A <-- 1
  B <-- 1
  N <-- 0
  M <-- 2
  ΓΡΑΨΕ 'N   M   B'
  ΓΡΑΨΕ '---------'
  ΟΣΟ B < 6 ΕΠΑΝΑΛΑΒΕ
    X <-- A + B
    ΑΝ X MOD 2 = 0 ΤΟΤΕ
      N <-- N + 1
    ΑΛΛΙΩΣ
      M <-- M + 1
    ΤΕΛΟΣ_ΑΝ
    A <-- B
    B <-- X
    ΓΡΑΨΕ N ,' ', M ,' ', B
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ '---------'
  ΓΡΑΨΕ 'Χ =',X
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters