Τώρα είναι Δευτ 18 Φεβ 2019 11:39 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Εσπερινό - Θέμα 4
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 09 Απρ 2007 11:12 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΕΣΠΕΡΙΝΟ - ΙΟΥΝΙΟΣ 2003 - ΘΕΜΑ 4
! ===============================================================================================
! Για κάθε μαθητή δίνονται τα στοιχεία ονοματεπώνυμο, προφορικός και γραπτός βαθμός ενός μαθήματος.
! Να γραφεί αλγόριθμος, ο οποίος εκτελεί τις ακόλουθες λειτουργίες :
!   α. Διαβάζει τα στοιχεία πολλών μαθητών και σταματά όταν δοθεί ως ονοματεπώνυμο το κενό.
!   β. Ελέγχει αν ο προφορικός και ο γραπτός βαθμός είναι από 0 μέχρι και 20.
!   γ. Υπολογίζει τον τελικό βαθμό του μαθήματος, ο οποίος είναι το άθροισμα του 30% του
!      προφορικού βαθμού και του 70% του γραπτού βαθμού. Επίσης, τυπώνει το ονοματεπώνυμο του
!      μαθητή και τον τελικό βαθμό του μαθήματος.
!   δ. Υπολογίζει και τυπώνει το ποσοστό των μαθητών που έχουν βαθμό μεγαλύτερο του 18.
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ ES_2003_06_4
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ν , Κ
  ΠΡΑΓΜΑΤΙΚΕΣ: π , γ , τ
  ΧΑΡΑΚΤΗΡΕΣ: ονομα
ΑΡΧΗ
  Ν <-- 0 ! Πλήθος των μαθητών με βαθμό πάνω από 18
  Κ <-- 0 ! Πλήθος όλων των μαθητών
  ΓΡΑΨΕ 'Δώσε όνομα.'
  ΔΙΑΒΑΣΕ ονομα
  ΟΣΟ ονομα <> '' ΕΠΑΝΑΛΑΒΕ
    Κ <-- Κ + 1
    ΓΡΑΨΕ 'Δώσε προφορικό και γραπτό βαθμό'
    ΔΙΑΒΑΣΕ π , γ
    ΟΣΟ π < 0 ή π > 20 ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ 'Λάθος. Ξαναδώσε προφορικό βαθμό'
      ΔΙΑΒΑΣΕ π
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΟΣΟ γ < 0 ή γ > 20 ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ 'Λάθος. Ξαναδώσε γραπτό βαθμό'
      ΔΙΑΒΑΣΕ γ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    τ <-- π*30/100 + γ*70/100
    ΑΝ τ > 18 ΤΟΤΕ
      Ν <-- Ν + 1
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ ονομα,'ΤΕΛΙΚΟΣ ΒΑΘΜΟΣ ='
    ΓΡΑΨΕ 'Δώσε όνομα.'
    ΔΙΑΒΑΣΕ ονομα
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  π <-- Ν*100/Κ
  ΓΡΑΨΕ 'Ποσοστό μαθητών με βαθμό πάνω από 18 =',π,'%.'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters