Τώρα είναι Δευτ 23 Σεπ 2019 04:49 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Εσπερινό - Θέμα 3
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 09 Απρ 2007 11:10 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΕΣΠΕΡΙΝΟ - ΙΟΥΝΙΟΣ 2003 - ΘΕΜΑ 3
! ===============================================================================================
! Για κάθε υπάλληλο δίνονται: ο μηνιαίος βασικός μισθός και ο αριθμός των παιδιών του.
! Δεχόμαστε ότι ο υπάλληλος μπορεί να έχει μέχρι και 20 παιδιά και ότι ο μηνιαίος βασικός μισθός
! του κυμαίνεται από 500 μέχρι και 1000 ευρώ.
! Οι συνολικές αποδοχές του υπολογίζονται ως το άθροισμα του μηνιαίου βασικού  μισθού και
! του οικογενειακού επιδόματός του. Το οικογενειακό επίδομα υπολογίζεται ως εξής :
! 30 ευρώ για κάθε παιδί μέχρι και τρία παιδιά, και
! 40 ευρώ για κάθε παιδί πέραν των τριών (4ο, 5ο, 6ο κ.τ.λ.).
!  α. Να προσδιορίσετε τις μεταβλητές που θα χρησιμοποιήσετε και να δηλώσετε τον τύπο  των
!     δεδομένων που αντιστοιχούν σε αυτές.
!  β. Να γράψετε αλγόριθμο, ο οποίος :
!      1. εισάγει τα κατάλληλα δεδομένα και ελέγχει την ορθή καταχώρισή τους,
!      2. υπολογίζει και εμφανίζει το οικογενειακό επίδομα και
!      3. υπολογίζει και εμφανίζει τις συνολικές αποδοχές του υπαλλήλου.
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ ES_2003_06_3
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: N , επ
  ΠΡΑΓΜΑΤΙΚΕΣ: m
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε το βασικό μισθό'
  ΔΙΑΒΑΣΕ m
  ΟΣΟ m < 500 ή m > 1000 ΕΠΑΝΑΛΑΒΕ        
    ΓΡΑΨΕ 'Λάθος. Ξαναδώσε'
    ΔΙΑΒΑΣΕ m
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Δώσε το αριθμό των παιδιών'
  ΔΙΑΒΑΣΕ N
  ΟΣΟ N < 0 ή N > 20 ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ 'Λάθος. Ξαναδώσε'
    ΔΙΑΒΑΣΕ N
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ N <= 3 ΤΟΤΕ
    επ <-- N*30
  ΑΛΛΙΩΣ
    επ <-- 3*30 + (N -3)*40
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ 'Οικογενειακό Επίδομα =',επ
  ΓΡΑΨΕ 'Συνολικές Αποδοχές =',επ + m
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ  
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters