Τώρα είναι Δευτ 16 Σεπ 2019 11:42 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Προσομοίωση - Θέμα 3
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 09 Απρ 2007 10:55 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΠΡΟΣΟΜΟΙΩΣΗ - ΑΠΡΙΛΙΟΣ 2002 - ΘΕΜΑ 3
! ===============================================================================================
! Δίνεται πίνακας Π δύο διαστάσεων, που τα στοιχεία του είναι ακέραιοι αριθμοί με Ν γραμμές και
! Μ στήλες.
! Να αναπτύξετε αλγόριθμο που να υπολογίζει πόσα από τα στοιχεία του πίνακα είναι θετικοί και
! πόσα αρνητικοί αριθμοί. Στο τέλος να εμφανίζει το αποτέλεσμα.
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ ΠΡ_2002_05_3
ΣΤΑΘΕΡΕΣ
  N = 5
  M = 5
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : i , j , k , l
  ΠΡΑΓΜΑΤΙΚΕΣ: Π[N,M] , min
ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ N
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ M
      ΓΡΑΨΕ 'Δώσε αριθμό για το κελι' , i , ',' , j
      ΔΙΑΒΑΣΕ Π[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  k <-- 0   ! ΠΛΗΘΟΣ ΘΕΤΙΚΩΝ
  l <-- 0   ! ΠΛΗΘΟΣ ΑΡΝΗΤΙΚΩΝ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ N
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ M
      ΑΝ Π[i,j] > 0 ΤΟΤΕ
        k <-- k + 1
      ΑΛΛΙΩΣ_ΑΝ Π[i,j] < 0 ΤΟΤΕ
        l <-- l + 1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'O πίνακας περιέχει,' , k , ' θετικούς και' , l , 'αρνητικούς αριθμούς.'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters