Τώρα είναι Δευτ 23 Σεπ 2019 04:12 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Προσομοίωση - Θέμα 2
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 09 Απρ 2007 10:53 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΠΡΟΣΟΜΟΙΩΣΗ 2002 - ΘΕΜΑ 2
! ===============================================================================================
! Δίνεται το παρακάτω τμήμα αλγορίθμου.
!    x <-- 1
!    i <-- 1
!    Αρχή_Επανάληψης
!       y <-- x * i
!       Av y MOD 2 = 0 τότε
!          x <-- x + 2
!          z <-- x + y
!       αλλιώς
!          x <-- x + 1
!          z <-- x * y
!       τέλος_αν                          
!       Γράψε z
!       i <-- i + 1
!    Μέχρι x > 7
! Ποιες είναι οι τιμές της μεταβλητής z που θα εμφανιστούν κατά την εκτέλεση του παραπάνω
! τμήματος αλγορίθμου;
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ PR_2002_2
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : i, x , y, z
ΑΡΧΗ
  x <-- 1
  i <-- 1
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    y <-- x * i
    ΑΝ y MOD 2 = 0 ΤΟΤΕ
      x <-- x + 2
      z <-- x + y
    ΑΛΛΙΩΣ
      x <-- x + 1
      z <-- x * y
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ z
    i <-- i + 1
  ΜΕΧΡΙΣ_ΟΤΟΥ  x > 7
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ                
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters