Τώρα είναι Πέμ 27 Ιουν 2019 04:06 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Εσπερινό - Θέμα 4
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 06 Απρ 2003 01:29 pm 
Χωρίς σύνδεση
Διαχειριστής

Εγγραφή: Παρ 28 Φεβ 2003 06:10 pm
Δημοσιεύσεις: 84
Syntax: [ Download ] [ Hide ]
! ============================================================================
! Στο πλαίσιο προγράμματος προληπτικής ιατρικής για την αντιμετώπιση του
! νεανικού διαβήτη έγιναν αιματολογικές εξετάσεις στους 90 μαθητές (αγόρια και
! κορίτσια) ενός Γυμνασίου. Για κάθε παιδί καταχωρίστηκαν τα ακόλουθα
! στοιχεία:
!   1. Ονοματεπώνυμο μαθητή.
!   2. Κωδικός φύλου ("Α" για τα αγόρια και "Κ" για τα κορίτσια).
!   3. Περιεκτικότητα σακχάρου στο αίμα.
! Οι φυσιολογικές τιμές σακχάρου στο αίμα κυμαίνονται από 70 έως 110 mg/dl
! (συμπεριλαμβανομένων και των ακραίων τιμών). Να γίνει πρόγραμμα που:
! Α) Θα διαβάζει τα παραπάνω στοιχεία (ονοματεπώνυμο, φύλο, περιεκτικότητα
!    σακχάρου στο αίμα) και θα ελέγχει την αξιόπιστη καταχώρισή τους (δηλαδή
!    το φύλο να είναι μόνο "Α" ή "Κ" και η περιεκτικότητα σακχάρου στο αίμα να
!    είναι θετικός αριθμός).
! Β) Θα εμφανίζει για κάθε παιδί του οποίου η περιεκτικότητα σακχάρου στο αίμα
!    είναι εκτός φυσιολογικών τιμών, το ονοματεπώνυμο, το φύλο και την
!    περιεκτικότητα του σακχάρου.
! Γ) Θα εμφανίζει το συνολικό αριθμό των αγοριών των οποίων η περιεκτικότητα
!    σακχάρου στο αίμα δεν είναι φυσιολογική.
! Δ) Θα εμφανίζει το συνολικό αριθμό των κοριτσιών των οποίων η περιεκτικότητα
!    σακχάρου στο αίμα δεν είναι φυσιολογική.
! ============================================================================


ΠΡΟΓΡΑΜΜΑ Πανελλήνιες_2002_Εσπερινά__Θέμα_4ο

ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: ονοματεπώνυμο[90], φύλο[90]
  ΑΚΕΡΑΙΕΣ: σάκχαρο[90], αγόρια_εκτός_ορίων, κορίτσια_εκτός_ορίων, i

ΑΡΧΗ

  αγόρια_εκτός_ορίων <-- 0
  κορίτσια_εκτός_ορίων <0>0)
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'Οι μαθητές που έχουν σάκχαρο εκτός φυσιολογικών τιμών είναι οι εξής:'

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 90
    ΑΝ (σάκχαρο[i]<70>110) ΤΟΤΕ
      ΓΡΑΨΕ 'Ονοματεπώνυμο: ', ονοματεπώνυμο[i]
      ΓΡΑΨΕ 'Φύλο: ', φύλο[i]
      ΓΡΑΨΕ 'Περιεκτικότητα σακχάρου: ', σάκχαρο[i]
      ΑΝ φύλο[i]='A' ΤΟΤΕ
        αγόρια_εκτός_ορίων <-- αγόρια_εκτός_ορίων + 1
      ΑΛΛΙΩΣ
        κορίτσια_εκτός_ορίων <-- κορίτσια_εκτός_ορίων + 1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'Πλήθος αγοριών εκτός ορίων: ', αγόρια_εκτός_ορίων
  ΓΡΑΨΕ 'Πλήθος κοριτσιών εκτός ορίων: ', κορίτσια_εκτός_ορίων

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Πανελλήνιες_2002_Εσπερινά__Θέμα_4ο

 


Τελευταία επεξεργασία από SpiN και Δευτ 09 Απρ 2007 09:04 pm, έχει επεξεργασθεί 2 φορά/ες συνολικά

Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 07 Απρ 2003 09:57 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 27 Μαρ 2003 10:42 am
Δημοσιεύσεις: 1
Πριν αναφέρω κάποιες παρατηρήσεις για την άσκηση θα πρέπει να ευχαριστήσω τον κύριο Νικολαΐδη γιατί μέσω της γλωσσομάθειας οι μαθητές μου κατάφεραν να προσεγγίσουν το μάθημα αυτό πολύ πιο αποτελεσματικά και τελικά αποδείχτηκε ένα πολύτιμο εργαλείο στα χέρια τους.
Το θέμα αυτό νομίζω πως δεν θα έπρεπε να λυθεί με την χρήση πινάκων. Οι πίνακες θα πρέπει να χρησιμοποιηθούν αν είναι απαραίτητοι και σε αυτό το πρόγραμμα δεν είναι. Βέβαια πολλές φορές οι μαθητές (επειδή μαθαίνουν τους πίνακες προς το τέλος της χρονιάς) χρησιμοποιούν πίνακες χωρίς να είναι απαραίτητο αλλά ίσως έτσι να είναι πιο κατανοητή η άσκηση σε αυτούς. Επίσης όταν τους ζητούν άσκηση με εγκυρότητα τιμής καλό θα ήταν να γίνεται έλεγχος για κάθε μεταβλητή ξεχωριστά και όχι για όλες μαζί. Επομένως μια άλλη αλγοριθμική προσέγγιση θα μπορούσε να ήταν:

Syntax: [ Download ] [ Hide ]
! ============================================================================
! Στο πλαίσιο προγράμματος προληπτικής ιατρικής για την αντιμετώπιση του
! νεανικού διαβήτη έγιναν αιματολογικές εξετάσεις στους 90 μαθητές (αγόρια και
! κορίτσια) ενός Γυμνασίου. Για κάθε παιδί καταχωρίστηκαν τα ακόλουθα
! στοιχεία:
!   1. Ονοματεπώνυμο μαθητή.
!   2. Κωδικός φύλου ("Α" για τα αγόρια και "Κ" για τα κορίτσια).
!   3. Περιεκτικότητα σακχάρου στο αίμα.
! Οι φυσιολογικές τιμές σακχάρου στο αίμα κυμαίνονται από 70 έως 110 mg/dl
! (συμπεριλαμβανομένων και των ακραίων τιμών). Να γίνει πρόγραμμα που:
! Α) Θα διαβάζει τα παραπάνω στοιχεία (ονοματεπώνυμο, φύλο, περιεκτικότητα
!    σακχάρου στο αίμα) και θα ελέγχει την αξιόπιστη καταχώρισή τους (δηλαδή
!    το φύλο να είναι μόνο "Α" ή "Κ" και η περιεκτικότητα σακχάρου στο αίμα να
!    είναι θετικός αριθμός).
! Β) Θα εμφανίζει για κάθε παιδί του οποίου η περιεκτικότητα σακχάρου στο αίμα
!    είναι εκτός φυσιολογικών τιμών, το ονοματεπώνυμο, το φύλο και την
!    περιεκτικότητα του σακχάρου.
! Γ) Θα εμφανίζει το συνολικό αριθμό των αγοριών των οποίων η περιεκτικότητα
!    σακχάρου στο αίμα δεν είναι φυσιολογική.
! Δ) Θα εμφανίζει το συνολικό αριθμό των κοριτσιών των οποίων η περιεκτικότητα
!    σακχάρου στο αίμα δεν είναι φυσιολογική.
! ============================================================================


ΠΡΟΓΡΑΜΜΑ Πανελλήνιες_2002_Εσπερινά__Θέμα_4ο

ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: ονομα, φύλο
  ΑΚΕΡΑΙΕΣ: σάκχαρο, αγόρια_εκτός_ορίων, κορίτσια_εκτός_ορίων, i

ΑΡΧΗ

  αγόρια_εκτός_ορίων <-- 0
  κορίτσια_εκτός_ορίων <-- 0

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 4
!===========Εισαγωγή στοιχείων μαθητή====================
    ΓΡΑΨΕ 'Δώστε το όνομα του ', i, 'ου μαθητή:'
    ΔΙΑΒΑΣΕ ονομα

    ΓΡΑΨΕ 'Δώσε το φύλο του ', i, 'ου μαθητή (Α για αγόρι και Κ για κορίτσι): '
    ΔΙΑΒΑΣΕ φύλο
    ΟΣΟ (φύλο <>'Α') και (φύλο <> 'Κ') ΕΠΑΝΑΛΑΒΕ
      Γράψε 'Δώσατε λάθος τιμή. Ξαναδώστε Α για αγόρι και Κ για κορίτσι: '
      ΔΙΑΒΑΣΕ φύλο
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

    ΓΡΑΨΕ 'Δώσε το σάκχαρο του ', i, 'ου μαθητή:'
    ΔΙΑΒΑΣΕ σάκχαρο
    ΟΣΟ σάκχαρο <0 ΕΠΑΝΑΛΑΒΕ
      Γράψε 'Δώσατε λάθος τιμή. Ξαναδώστε θετικό αριθμό: '
      ΔΙΑΒΑΣΕ σάκχαρο
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

!=============Υπολογισμός φυσιολογικών τιμών σακχάρου=======
    ΑΝ (σάκχαρο<70) Ή (σάκχαρο>110) ΤΟΤΕ
      ΑΝ φύλο='Α' ΤΟΤΕ
        ΓΡΑΨΕ 'Ο ', Ονομα, ' που είναι αγόρι '
        ΓΡΑΨΕ 'έχει περιεκτικότητα σακχάρου ', σάκχαρο, ' και είναι εκτός ορίων'
        αγόρια_εκτός_ορίων <-- αγόρια_εκτός_ορίων + 1
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ 'Ο ', Ονομα, ' που είναι κορίτσι '
        ΓΡΑΨΕ 'έχει περιεκτικότητα σακχάρου ', σάκχαρο, ' και είναι εκτός ορίων'
        κορίτσια_εκτός_ορίων <-- κορίτσια_εκτός_ορίων + 1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ

  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'Πλήθος αγοριών εκτός ορίων: ', αγόρια_εκτός_ορίων
  ΓΡΑΨΕ 'Πλήθος κοριτσιών εκτός ορίων: ', κορίτσια_εκτός_ορίων

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Πανελλήνιες_2002_Εσπερινά__Θέμα_4ο

 

_________________
Πύρζα Φανή
Μηχανικός Η/Υ συστημάτων
Εκπαιδευτικός ΔΕ


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 07 Απρ 2003 11:22 pm 
Χωρίς σύνδεση
Διαχειριστής

Εγγραφή: Παρ 28 Φεβ 2003 06:10 pm
Δημοσιεύσεις: 84
Αγαπητή Φανή συμφωνώ απόλυτα ότι οι πίνακες πρέπει να χρησιμοποιούνται μόνο εκεί που είναι απαραίτητοι. Αυτή η φράση είναι ένα είδος "νόμου" που μπορεί να μας γλιτώσει από πολλά παρόμοια διλήμματα. Η αλήθεια είναι ότι τη συγκεκριμένη άσκηση ξεκίνησα να τη λύνω χωρίς πίνακες αλλά κάπου στη μέση άλλαξα γνώμη. Ο λόγος ήταν ο τρόπος με τον οποίο είναι οργανωμένα τα ερωτήματα του προβλήματος. Ήθελα δηλαδή κάθε ερώτημα να απαντιέται σε όσο το δυνατό πιο διακριτό τμήμα του προγράμματος, ώστε να είναι -έστω και λίγο- πιο κατανοητό στους μαθητές. Χωρίς πίνακες τα πάντα γίνονται "ταυτόχρονα" μέσα σε μία δομή επανάληψης.
Όσον αφορά την επισήμανσή σου για τον έλεγχο της εγκυρότητας των δεδομένων, σίγουρα ο τρόπος που επιλέγεις είναι πιο "χρηστικός", δηλαδή πιο κοντά στις απαιτήσεις ενός *πραγματικού* χρήστη από ένα *πραγματικό* πρόγραμμα. Εγώ "χάριν εκπαιδεύσεως" διάλεξα τη λύση με τη μία μόνο επαναληπτική δομή ελέγχου, ώστε το πρόγραμμα να γίνει κάπως μικρότερο, αλλά και για να υπάρξει μια ευκαιρία επίδειξης και επεξήγησης της σύνθεσης και της προτεραιότητας των λογικών τελεστών. Θα συμφωνείς κι εσύ ότι όλοι όσοι διδάσκουμε αυτό το μάθημα βλέπουμε πως υπάρχει μια νοητή ζυγαριά ανάμεσα στη χρηστικότητα και την κατανοησιμότητα. Η διδασκαλία του μαθήματος είναι ένας συνεχής αγώνας εξισορρόπησης αυτής της ζυγαριάς.
Κατά τη γνώμη μου και οι δύο τρόποι είναι εκπαιδευτικά άρτιοι και -θέλω να- πιστεύω ότι κανένας διορθωτής δε θα έκοβε μονάδες σε κάποιο από αυτά τα προγράμματα.
Επίσης να προσθέσω ότι πολλές φορές είναι εξαιρετικά χρήσιμο να εξηγούμε στα παιδιά δύο ή περισσότερους διαφορετικούς τρόπους επίλυσης της ίδιας άσκησης. Κατά τη γνώμη μου κάτι τέτοιο όχι μόνο δεν τα μπερδεύει, αλλά τα βοηθάει να αποκτήσουν μια βαθύτερη και πιο σφαιρική εικόνα του προγραμματισμού.
Σε ευχαριστώ για τις επισημάνσεις σου.


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters