Τώρα είναι Δευτ 23 Σεπ 2019 04:14 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Προσομοίωση - Θέμα 1Β
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 09 Απρ 2007 10:40 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΠΡΟΣΟΜΟΙΩΣΗ 2002 - ΘΕΜΑ 1Β
! ===============================================================================================
! Δίνεται το παρακάτω τμήμα αλγορίθμου.
!      
!   Αν x = 0 τότε
!      Γράψε "μηδέν"
!   Αλλιώς αν x = 1 ή x = 3 ή x = 5 τότε
!      Γράψε "Μονός"
!   Αλλιώς αν x = 2 ή x = 4 ή x = 6 τότε
!      Γράψε "Ζυγός"
!   Αλλιώς
!      Γράψε "Ο αριθμός είναι < 0 ή > 6"
!   Τέλος_αν
!
! Να μετατρέψετε την παραπάνω δομή σε ισοδύναμη δομή επιλογής Επίλεξε &#8230; Τέλος_επιλογών
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ PR_2002_1Β
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: x
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε έναν ακέραιο αριθμό.'
  ΔΙΑΒΑΣΕ x
  ΕΠΙΛΕΞΕ x
    ΠΕΡΙΠΤΩΣΗ 0
      ΓΡΑΨΕ 'μηδέν'
    ΠΕΡΙΠΤΩΣΗ 1 , 3, 5
      ΓΡΑΨΕ 'μονός'
    ΠΕΡΙΠΤΩΣΗ 2 , 4, 6
      ΓΡΑΨΕ 'ζυγός'
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Ο αριθμός είναι μικρότερος του μηδενός ή μεγαλύτερος του 6'
  ΤΕΛΟΣ_ΕΠΙΛΟΓΩΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ                  
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters