Τώρα είναι Δευτ 23 Σεπ 2019 08:23 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 09 Απρ 2007 10:36 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΗΜΕΡΗΣΙΟ - ΙΟΥΛΙΟΣ 2002 - ΘΕΜΑ 3
! ===============================================================================================
! Σε ένα κέντρο νεοσύλλεκτων υπάρχει η πρόθεση να δημιουργηθούν δύο ειδικές διμοιρίες. Η διμοιρία
! Α θα αποτελείται από νεοσύλλεκτους πτυχιούχους τριτοβάθμιας εκπαίδευσης, ηλικίας από 24 έως και
! 28 χρόνων. Η διμοιρία Β θα αποτελείται από νεοσύλλεκτους απόφοιτους δευτεροβάθμιας εκπαίδευσης,
! ηλικίας από 18 έως και 24 χρόνων. Οι υπόλοιποι νεοσύλλεκτοι δεν κατατάσσονται σε καμία από αυτές
! τις διμοιρίες.
! Να αναπτύξετε αλγόριθμο ο οποίος :
!   α. διαβάζει το ονοματεπώνυμο, την ηλικία και έναν αριθμό που καθορίζει το επίπεδο σπουδών του
!      νεοσύλλεκτου και παίρνει τιμές από 1 έως 3
!            (1: τριτοβάθμια εκπαίδευση 2: δευτεροβάθμια εκπαίδευση 3: κάθε άλλη περίπτωση)
!   β. εκτυπώνει:
!      i) το ονοματεπώνυμο του νεοσύλλεκτου
!     ii) το όνομα της διμοιρίας (Α ή Β), εφόσον ο νεοσύλλεκτος κατατάσσεται σε μία από αυτές.
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ ΗΜ_2002_07_3
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: age , x
  ΧΑΡΑΚΤΗΡΕΣ: name
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε ονοματεπώνυμο νεοσυλλέκτου'
  ΔΙΑΒΑΣΕ name
  ΓΡΑΨΕ 'Δώσε την ηλικία του'
  ΔΙΑΒΑΣΕ age
  ΓΡΑΨΕ 'Δώσε το επίπεδο των σπουδών του'
  ΓΡΑΨΕ '    1. Τριτοβάθμια εκπαίδευση'                          
  ΓΡΑΨΕ '    2. Δευτεροβάθμια εκπαίδευση'
  ΓΡΑΨΕ '    3. Κάθε άλλη περίπτωση'
  ΔΙΑΒΑΣΕ x
  ΟΣΟ x < 1 ή x > 3 ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ 'Λάθος. Ξαναδώσε'
    ΔΙΑΒΑΣΕ x
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ age >= 24 ΚΑΙ age <= 28 ΚΑΙ x = 1 ΤΟΤΕ
    ΓΡΑΨΕ name,' ΔΙΜΟΙΡΙΑ Α'
  ΑΛΛΙΩΣ_ΑΝ age >= 18 ΚΑΙ age <= 24 ΚΑΙ x = 2 ΤΟΤΕ
    ΓΡΑΨΕ name,' ΔΙΜΟΙΡΙΑ Β'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters