Τώρα είναι Δευτ 23 Σεπ 2019 08:48 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 09 Απρ 2007 10:34 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
!===============================================================================================
! ΗΜΕΡΗΣΙΟ - ΙΟΥΛΙΟΣ 2002 - ΘΕΜΑ 2
! ===============================================================================================
! Δίνεται μονοδιάστατος πίνακας Α, 10 θέσεων, ο οποίος στις θέσεις 1 έως 10 περιέχει αντίστοιχα
! τους αριθμούς : 15 , 3 , 0 , 5 , 16 , 2 , 17 , 8 , 19 , 1 και τμήμα αλγορίθμου :
!
! Για i από 1 μέχρι 9 με_βήμα 2
!    K < ((i+10) mod 10)+1
!    Α[i] < Α[k]
!    εκτύπωσε i, k, A[i], A[k]
! Τέλος_επανάληψης
!
! Ποιές τιμές τυπώνονται με την εντολή εκτύπωσε i, k, A[i], A[k] καθώς εκτελείται το παραπάνω
! τμήμα αλγορίθμου;
! ===============================================================================================
ΠΡΟΓΡΑΜΜΑ ΗΜ_2002_07_2
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i,k,A[10]
ΑΡΧΗ
  A[1] <-- 15
  A[2] <-- 3
  A[3] <-- 0
  A[4] <-- 5
  A[5] <-- 16
  A[6] <-- 2
  A[7] <-- 17
  A[8] <-- 8
  A[9] <-- 19
  A[10] <-- 1
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 9 ΜΕ ΒΗΜΑ 2
    k <-- ((i+10) MOD 10) + 1
    A[i] <-- A[k]
    ΓΡΑΨΕ i , '  ' , k , '  ' , A[i] , '  ' , A[k]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters