Τώρα είναι Κυρ 21 Απρ 2019 07:04 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Ημερήσιο - Θέμα 3
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 09 Απρ 2007 10:25 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΗΜΕΡΗΣΙΟ - ΙΟΥΝΙΟΣ 2002 - ΘΕΜΑ 3
! ===============================================================================================
! Με το νέο σύστημα πληρωμής των διοδίων, οι οδηγοί των τροχοφόρων έχουν τη δυνατότητα να
! πληρώνουν το αντίτιμο των διοδίων με ειδική μαγνητική κάρτα. Υποθέστε ότι υπάρχει μηχάνημα
! το οποίο διαθέτει είσοδο για την κάρτα και φωτοκύτταρο. Το μηχάνημα διαβάζει από την κάρτα το
! υπόλοιπο των χρημάτων και το αποθηκεύει σε μία μεταβλητή Υ και, με το φωτοκύτταρο, αναγνωρίζει
! τον τύπο του τροχοφόρου και το αποθηκεύει σε μία μεταβλητή Τ. Υπάρχουν τρεις τύποι τροχοφόρων :
! δίκυκλα (Δ), επιβατικά (Ε) και φορτηγά (Φ), με αντίτιμο διοδίων 1, 2 και 3 ευρώ αντίστοιχα.
!
! Να αναπτύξετε αλγόριθμο, ο οποίος:
!  α. ελέγχει τον τύπο του τροχοφόρου και εκχωρεί στη μεταβλητή Α το αντίτιμο των διοδίων,
!     ανάλογα με τον τύπο του τροχοφόρου
!  β. ελέγχει την πληρωμή των διοδίων με τον παρακάτω τρόπο.
!       * Αν το υπόλοιπο της κάρτας επαρκεί για την πληρωμή του αντιτίμου των διοδίων,
!         αφαιρεί το ποσό αυτό από την κάρτα.
!       * Αν η κάρτα δεν έχει υπόλοιπο, το μηχάνημα ειδοποιεί με μήνυμα για το ποσό που πρέπει
!         να πληρωθεί.
!       * Αν το υπόλοιπο δεν επαρκεί, μηδενίζεται η κάρτα και δίνεται με μήνυμα το ποσό που
!         απομένει να πληρωθεί.
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ HM_2002_06_3
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: Υ , Α
  ΧΑΡΑΚΤΗΡΕΣ: T
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε υπολοιπο κάρτας.'
  ΔΙΑΒΑΣΕ Υ
  ΓΡΑΨΕ 'Δώσε τύπο τροχοφόρου'
  ΔΙΑΒΑΣΕ T
  ΑΝ T = 'Δ' ή T = 'D' ή T = 'δ' ή T = 'd' ΤΟΤΕ
    Α <-- 1
  ΑΛΛΙΩΣ_ΑΝ T = 'Ε' ή Τ = 'E' ή T = 'e' ή T = 'ε' ΤΟΤΕ
    Α <-- 2
  ΑΛΛΙΩΣ
    Α <-- 3
  ΤΕΛΟΣ_ΑΝ
  ΑΝ Α <= Υ ΤΟΤΕ
    Υ <-- Υ - Α
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'Οφείλετε', Α - Υ ,'EURO.'
    Υ <-- 0
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ 'Ευχαριστούμε πολύ. ΚΑΛΟ ΤΑΞΙΔΙ.'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

! Δε χρειάζεται να κάνουμε έλεγχο κατά την είσοδο δεδομένων στις μεταβλητές Τ και Υ αφού το
! δεδομένο το δίνει αντίστοιχα το φωτοκύτταρο και ο αναγνώστης κάρτας.
! Αν έδινε π.χ. ο χρήστης τον τύπο του τροχοφόρου και για να καλύψουμε την περίπτωση που δίνει
! αγγλικά ή ελληνικά πεζά ή κεφαλαία βάζουμε στο ΑΝ όλα τα ενδεχόμενα.
! (AYTO BEBAIA ΔΕΝ ΕΙΝΑΙ ΑΠΑΡΑΙΤΗΤΟ - είναι εξεζητημένη λύση).
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters