Τώρα είναι Δευτ 26 Αύγ 2019 08:10 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Ημερήσιο - Θέμα 2
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 09 Απρ 2007 10:22 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΗΜΕΡΗΣΙΟ - ΙΟΥΝΙΟΣ 2002 - ΘΕΜΑ 2
! ===============================================================================================
! Να εκτελέσετε το παρακάτω  τμήμα  αλγορίθμου, για Κ = 24 και L = 40.
! Να γράψετε στο τετράδιό σας τις τιμές των μεταβλητών Χ, Υ καθώς αυτές τυπώνονται με την εντολή
! Εμφάνισε Χ, Υ (τόσο μέσα στη δομή επανάληψης όσο και στο τέλος του αλγορίθμου).
!
!   Χ <-- Κ
!   Y <-- L
!   Αν Χ < Υ τότε
!      ΤΕΜΡ <-- Χ
!      Χ <-- Υ                
!      Υ <-- ΤΕΜΡ
!   Τέλος_αν
!   Όσο Υ<>0 επανάλαβε
!      ΤΕΜΡ <- Υ
!      Υ <-- Χ ΜOD Y
!      Χ <-- TEMP
!     Εμφάνισε Χ, Υ
!   Τέλος_επανάληψης
!   Υ <-- (Κ * L) DIV X
!   Εμφάνισε Χ, Υ
!
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ HM_2002_06_2
ΣΤΑΘΕΡΕΣ
  k = 24
  l = 40
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: x , y , temp
ΑΡΧΗ
  x <-- k
  y <-- l
  ΑΝ x < y ΤΟΤΕ
    temp <-- x
    x <-- y
    y <-- temp
  ΤΕΛΟΣ_ΑΝ
  ΟΣΟ y <>0 ΕΠΑΝΑΛΑΒΕ
    temp <-- y
    y <-- x MOD y
    x <-- temp
    ΓΡΑΨΕ x , y
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  y <-- (k * l) DIV x
  ΓΡΑΨΕ x , y
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters