Τώρα είναι Δευτ 23 Σεπ 2019 08:23 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Εσπερινό - Θέμα 3
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 09 Απρ 2007 10:17 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΕΣΠΕΡΙΝΟ - ΙΟΥΝΙΟΣ 2002 - ΘΕΜΑ 3
! ===============================================================================================
! Δίνονται η έκταση, ο πληθυσμός και το όνομα καθεμιάς από τις 15 χώρες της Ευρωπαϊκής Ένωσης
! Να αναπτύξετε αλγόριθμο που :
!   α) θα διαβάζει τα παραπάνω δεδομένα,
!   β) θα εμφανίζει τη χώρα με τη μεγαλύτερη έκταση,
!   γ) θα εμφανίζει τη χώρα με το μικρότερο πληθυσμό  και
!   δ) θα εμφανίζει το μέσο όρο του πληθυσμού των 15 χωρών της Ευρωπαϊκής Ένωσης.
! ===============================================================================================  

ΠΡΟΓΡΑΜΜΑ ES_2002_06_3
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : i,ar ,min , pop
  ΠΡΑΓΜΑΤΙΚΕΣ: max , s ,mo
  ΧΑΡΑΚΤΗΡΕΣ: name, name1, name2
ΑΡΧΗ
  S <-- 0
  min <-- 0
  max <-- 10^9
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 15
    ΓΡΑΨΕ 'Δώσε το όνομα της χώρας ',i
    ΔΙΑΒΑΣΕ name
    ΓΡΑΨΕ 'Δώσε την έκταση της ',name
    ΔΙΑΒΑΣΕ ar
    ΓΡΑΨΕ 'Δώσε και τον πληθυσμό της'
    ΔΙΑΒΑΣΕ pop                                      
    s <-- S + pop
    ΑΝ ar > max ΤΟΤΕ
      max <-- ar
      name1 <-- name                              
    ΤΕΛΟΣ_ΑΝ
    ΑΝ pop < min ΤΟΤΕ
      min <-- pop
      name2 <-- name
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  mo <-- s /15  
  ΓΡΑΨΕ 'Η χώρα με τη μεγαλύτερη έκταση είναι ή ',name1
  ΓΡΑΨΕ 'Η χώρα με το μκρότερο πληθυσμό είναι ή ',name2
  ΓΡΑΨΕ 'Ο μέσος όρος του πληθυσμού όλων των χωρών είναι ',mo
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters