Τώρα είναι Πέμ 27 Ιουν 2019 03:26 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Εσπερινό - Θέμα 2
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 09 Απρ 2007 10:15 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! =========================================================================================
! ΕΣΠΕΡΙΝΟ ΙΟΥΝΙΟΣ 2002 - ΘΕΜΑ 2
! =========================================================================================
! Ο μονοδιάστατος αριθμητικός πίνακας Table έχει τα ακόλουθα στοιχεία :
!
!      ---------------------------------------------
!       1η θέση  2η θέση  3η θέση  4η θέση  5η θέση
!      ---------------------------------------------
!          43       72       -4       63       56
!      ---------------------------------------------
! Δίνεται το παρακάτω τμήμα αλγορίθμου :
!
!    Για  Ι από 2 μέχρι 5
!       Για J από 5 μέχρι Ι με_βήμα -1
!          Αν Table[J-1] < Table[J] τότε
!             Αντιμετάθεσε Table[J-1], Table[J]
!          Τέλος_αν                                  
!       Τέλος_επανάληψης
!    Τέλος_επανάληψης
!
! Να μεταφερθεί στο τετράδιό σας ο πίνακας και να συμπληρωθεί για όλες τις τιμές του J,
! που αντιστοιχούν σε I = 2 και Ι = 3.
!
! =========================================================================================

ΠΡΟΓΡΑΜΜΑ ES_2002_06_2
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i , j , Table[5], temp
ΑΡΧΗ
  Table[1] <-- 43
  Table[2] <-- 72
  Table[3] <-- -4
  Table[4] <-- 63
  Table[5] <-- 56
  ΓΡΑΨΕ '==============================='
  ΓΡΑΨΕ '|  i    j   |     Πίνακας     |'
  ΓΡΑΨΕ '==============================='
  ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 3
    ΓΙΑ j ΑΠΟ 5 ΜΕΧΡΙ i ΜΕ ΒΗΜΑ -1
      ΑΝ Table[j-1] < Table[j] ΤΟΤΕ
        temp <-- Table[j-1]
        Table[j-1] <-- Table[j]
        Table[j] <-- temp
      ΤΕΛΟΣ_ΑΝ
      ΓΡΑΨΕ '| ' , i , '  ' , j , '  |' , Table[1] ,  Table[2]  , Table[3]  , Table[4] , Table[5] , ' |'
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ '===================================='
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters