Τώρα είναι Πέμ 27 Ιουν 2019 03:12 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Εσπερινό - Θέμα 1Δ
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 09 Απρ 2007 10:11 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! =========================================================================================
! ΕΣΠΕΡΙΝΟ ΙΟΥΝΙΟΣ 2002 - ΘΕΜΑ 1Δ
! =========================================================================================
! Να γράψετε τα τμήματα αλγορίθμου, που αντιστοιχούν στα τμήματα των διαγραμμάτων ροής
! (α) και (β), που ακολουθούν.
!
! =========================================================================================

ΠΡΟΓΡΑΜΜΑ ES_2002_06_1Δ
ΜΕΤΑΒΛΗΤΕΣ                                  
  ΠΡΑΓΜΑΤΙΚΕΣ: m1 , x , Α , Β
ΑΡΧΗ
  ΓΡΑΨΕ '===== (α) ====='
  m1 <-- 0
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Δώσε αριθμό'
    ΔΙΑΒΑΣΕ x
    ΑΝ x >= 0 ΤΟΤΕ
      m1 <-- m1 + 1
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ x < 0
  ΓΡΑΨΕ m1

  ΓΡΑΨΕ '===== (β) ====='

  Α <-- 20
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    Β <-- Α^2
    ΓΡΑΨΕ Β
    Α <-- Α -3
  ΜΕΧΡΙΣ_ΟΤΟΥ Α < 0
  ΓΡΑΨΕ Α , Β

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters