Τώρα είναι Πέμ 27 Ιουν 2019 03:47 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Ημερήσιο - Θέμα 4
ΔημοσίευσηΔημοσιεύτηκε: Παρ 20 Φεβ 2004 11:29 am 
Χωρίς σύνδεση

Εγγραφή: Παρ 14 Μαρ 2003 06:19 pm
Δημοσιεύσεις: 13
Syntax: [ Download ] [ Hide ]
!=============================================================
! ΘΕΜΑ 4ο (Γ ΤΑΞΗΣ ΕΝΙΑΙΟΥ ΛΥΚΕΙΟΥ 2002)
! Μια εταιρεία αποθηκεύει είκοσι (20) προϊόντα σε δέκα (10)
! αποθήκες. Να γράψετε πρόγραμμα στη γλώσσα προγραμματισμού
! "ΓΛΩΣΣΑ", το οποίο:
! α. περιέχει τμήμα δήλωσης των μεταβλητών του προγράμματος
!                                                (Μονάδες 3)
! β. εισάγει σε μονοδιάστατο πίνακα τα ονόματα των είκοσι
! προϊόντων                                      (Μονάδες 3)
! γ. εισάγει σε πίνακα δύο διαστάσεων Π[20,10] την πληροφορία
! που αφορά στην παρουσία ενός προϊόντος σε μια αποθήκη
! (καταχωρούμε την τιμή 1 στην περίπτωση που υπάρχει το προϊόν
! στην αποθήκη και την τιμή 0, αν το προϊόν δεν υπάρχει στην
! αποθήκη).                                      (Μονάδες 4)
! δ. υπολογίζει σε πόσες αποθήκες βρίσκεται το κάθε προϊόν
!                                                (Μονάδες 6)
! ε. τυπώνει το όνομα κάθε προϊόντος και το πλήθος των
! αποθηκών στις οποίες υπάρχει το προϊόν.        (Μονάδες 4)
!=============================================================
! (panos giannakopoulos)
!=============================================================
ΠΡΟΓΡΑΜΜΑ Διαχείριση_Αποθήκης_ΕΚΔ_01
! Τμήμα δήλωσης των μεταβλητών του προγράμματος.

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : i, j, Π[20,10], Σύνολο[20]
  ΧΑΡΑΚΤΗΡΕΣ: Ονομα_Προιόντος[20]

ΑΡΧΗ
  ! εισαγωγή στον μονοδιάστατο πίνακα Ονομα_Προιόντος τα
  ! ονόματα των είκοσι προϊόντων.
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
    ΓΡΑΨΕ 'Δώσε το όνομα του ', i, 'ου προϊόντος από τα 20: '
    ΔΙΑΒΑΣΕ Ονομα_Προιόντος[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ! Εισαγωγή σε πίνακα δύο διαστάσεων Π[20,10] της πληροφορίας
  ! που αφορά στην παρουσία ενός προϊόντος σε μια αποθήκη.
  ! Καταχωρούμε την τιμή 1 στην περίπτωση που υπάρχει το προϊόν
  ! στην αποθήκη και την τιμή 0, αν το προϊόν δεν υπάρχει στην
  ! αποθήκη).
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10
      ΓΡΑΨΕ  'Στην αποθήκη ', j, ' υπάρχει το ', Ονομα_Προιόντος[i],'? (1=υπάρχει, 0=δεν υπάρχει):'
      ΔΙΑΒΑΣΕ Π[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ! Υπολογισμός σε πόσες αποθήκες βρίσκεται το κάθε προϊόν.
  ! Για να γίνει αυτό βρίσκουμε το σύνολο  των εμφανίσεων
  ! του αριθμού 1 σε κάθε γραμμή.
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
    Σύνολο[i] <-- 0
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10
      Σύνολο[i] <-- Σύνολο[i] + Π[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ! Εμφάνιση του ονόματος κάθε προϊόντος και του πλήθους των
  ! αποθηκών στις οποίες υπάρχει το προϊόν.
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
    ΓΡΑΨΕ  'Το προϊόν: ', Ονομα_Προιόντος[i], ', υπάρχει σε Αποθήκες: ', Σύνολο[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Διαχείριση_Αποθήκης_ΕΚΔ_01


Τελευταία επεξεργασία από panos giannakopoulos και Σάβ 21 Φεβ 2004 01:28 am, έχει επεξεργασθεί 1 φορά/ες συνολικά

Κορυφή
 Προφίλ  
 
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 21 Φεβ 2004 01:27 am 
Χωρίς σύνδεση

Εγγραφή: Παρ 14 Μαρ 2003 06:19 pm
Δημοσιεύσεις: 13
Επανέρχομαι με μία δεύτερη έκδοση του προγράμματος στην οποία έχουν αντικατασταθεί οι διαστάσεις των πινάκων με σταθερές και οι μεταβλητές i και j με τις "Πλήθος_Προιόντων" και "Πλήθος_Αποθηκών" οι οποίες είναι περισσότερο περιγραφικές. Προσωπικά προτιμώ την εντολή:
    ΓΙΑ Προιόν ΑΠΟ 1 ΜΕΧΡΙ Πλήθος_Προιόντων
    αντί για την
    ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20

Θα ήθελα πάντως τις παρατηρήσεις σας για το συγκεκριμένο θέμα.
Syntax: [ Download ] [ Hide ]
!=============================================================
! ΘΕΜΑ 4ο (Γ ΤΑΞΗΣ ΕΝΙΑΙΟΥ ΛΥΚΕΙΟΥ 2002)
! Μια εταιρεία αποθηκεύει είκοσι (20) προϊόντα σε δέκα (10)
! αποθήκες. Να γράψετε πρόγραμμα στη γλώσσα προγραμματισμού
! "ΓΛΩΣΣΑ", το οποίο:
! α. περιέχει τμήμα δήλωσης των μεταβλητών του προγράμματος
!                                                (Μονάδες 3)
! β. εισάγει σε μονοδιάστατο πίνακα τα ονόματα των είκοσι
! προϊόντων                                      (Μονάδες 3)
! γ. εισάγει σε πίνακα δύο διαστάσεων Π[20,10] την πληροφορία
! που αφορά στην παρουσία ενός προϊόντος σε μια αποθήκη
! (καταχωρούμε την τιμή 1 στην περίπτωση που υπάρχει το προϊόν
! στην αποθήκη και την τιμή 0, αν το προϊόν δεν υπάρχει στην
! αποθήκη).                                      (Μονάδες 4)
! δ. υπολογίζει σε πόσες αποθήκες βρίσκεται το κάθε προϊόν
!                                                (Μονάδες 6)
! ε. τυπώνει το όνομα κάθε προϊόντος και το πλήθος των
! αποθηκών στις οποίες υπάρχει το προϊόν.        (Μονάδες 4)
!=============================================================
! (panos giannakopoulos)
!=============================================================
ΠΡΟΓΡΑΜΜΑ Διαχείριση_Αποθήκης_ΕΚΔ02
! Τμήμα δήλωσης των μεταβλητών του προγράμματος.

ΣΤΑΘΕΡΕΣ
  Πλήθος_Προιόντων=20
  Πλήθος_Αποθηκών=10
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : Προιόν, Αποθήκη, Π[Πλήθος_Προιόντων,Πλήθος_Αποθηκών], Σύνολο[Πλήθος_Προιόντων]
  ΧΑΡΑΚΤΗΡΕΣ: Ονομα_Προιόντος[Πλήθος_Προιόντων]

ΑΡΧΗ
  ! εισαγωγή στον μονοδιάστατο πίνακα Ονομα_Προιόντος τα
  ! ονόματα των είκοσι προϊόντων.
  ΓΙΑ Προιόν ΑΠΟ 1 ΜΕΧΡΙ Πλήθος_Προιόντων
    ΓΡΑΨΕ 'Δώσε το όνομα του ', Προιόν, 'ου προϊόντος από τα 20: '
    ΔΙΑΒΑΣΕ Ονομα_Προιόντος[Προιόν]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ! Εισαγωγή σε πίνακα δύο διαστάσεων Π[20,10] της πληροφορίας
  ! που αφορά στην παρουσία ενός προϊόντος σε μια αποθήκη.
  ! Καταχωρούμε την τιμή 1 στην περίπτωση που υπάρχει το προϊόν
  ! στην αποθήκη και την τιμή 0, αν το προϊόν δεν υπάρχει στην
  ! αποθήκη).
  ΓΙΑ Προιόν ΑΠΟ 1 ΜΕΧΡΙ Πλήθος_Προιόντων
    ΓΙΑ Αποθήκη ΑΠΟ 1 ΜΕΧΡΙ Πλήθος_Αποθηκών
      ΓΡΑΨΕ  'Στην αποθήκη ', Αποθήκη, ' υπάρχει το ', Ονομα_Προιόντος[Προιόν],'? (1=υπάρχει, 0=δεν υπάρχει):'
      ΔΙΑΒΑΣΕ Π[Προιόν,Αποθήκη]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ! Υπολογισμός σε πόσες αποθήκες βρίσκεται το κάθε προϊόν.
  ! Για να γίνει αυτό βρίσκουμε το σύνολο  των εμφανίσεων
  ! του αριθμού 1 σε κάθε γραμμή.
  ΓΙΑ Προιόν ΑΠΟ 1 ΜΕΧΡΙ Πλήθος_Προιόντων
    Σύνολο[Προιόν] <-- 0
    ΓΙΑ Αποθήκη ΑΠΟ 1 ΜΕΧΡΙ Πλήθος_Αποθηκών
      Σύνολο[Προιόν] <-- Σύνολο[Προιόν] + Π[Προιόν,Αποθήκη]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ! Εμφάνιση του ονόματος κάθε προϊόντος και του πλήθους των
  ! αποθηκών στις οποίες υπάρχει το προϊόν.
  ΓΙΑ Προιόν ΑΠΟ 1 ΜΕΧΡΙ Πλήθος_Προιόντων
    ΓΡΑΨΕ  'Το προϊόν: ', Ονομα_Προιόντος[Προιόν], ', υπάρχει σε Αποθήκες: ', Σύνολο[Προιόν]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Διαχείριση_Αποθήκης_ΕΚΔ02
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters