Τώρα είναι Τρί 28 Ιαν 2020 11:58 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Προσομoίωση - Θέμα 2Α
ΔημοσίευσηΔημοσιεύτηκε: Τρί 10 Απρ 2007 02:17 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΠΡΟΣΟΜΟΙΩΣΗ 2001 - ΘΕΜΑ 2Α
! ===============================================================================================
!Δίνεται το παρακάτω τμήμα αλγορίθμου:
!
!   Ν <-- 5
!   ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ν
!      ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ Ν
!         ΑΝ j=i  Ή j=N+1-i  ΤΟΤΕ
!            Α[i,j]=1
!         ΑΛΛΙΩΣ
!            Α[i,j]=0
!         ΤΕΛΟΣ_ΑΝ
!      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!
!
! Να σχεδιάσετε στο τετράδιό σας τον πίνακα Α συμπληρωμένο,
! όπως θα είναι μετά την εκτέλεση αυτού του τμήματος αλγορίθμου.
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ PR_2001_2Α
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ν , i , j , A[5,5]
ΑΡΧΗ
  Ν <-- 5
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ν
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ Ν
      ΑΝ j = i  Ή j = Ν + 1 - i  ΤΟΤΕ
        A[i,j] <-- 1
      ΑΛΛΙΩΣ
        A[i,j] <-- 0
      ΤΕΛΟΣ_ΑΝ
      ΓΡΑΨΕ_ '  ' , A[i,j]   ! Για να εμφανιστεί σωστά ο πίνακας στην οθόνη χρησιμοποιήθηκε η
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ         ! εντολή ΓΡΑΨΕ_ η οποία δεν υποστηρίζεται από τη ΓΛΩΣΣΑ
    ΓΡΑΨΕ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters