Τώρα είναι Σάβ 29 Φεβ 2020 12:25 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Προσομοίωση - Θέμα 4
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 09 Απρ 2007 10:07 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΠΡΟΣΟΜΟΙΩΣΗ 2001 - ΘΕΜΑ 4
! ===============================================================================================
! Σε ένα λύκειο η Γ τάξη έχει 120 μαθητές. Οι μέσοι όροι βαθμολογίας και τα ονόματα
! καταχωρούνται σε δύο πίνακες.
! Στον έναν πίνακα με όνομα Ονόματα καταχωρούνται τα ονοματεπώνυμα των μαθητών και στον άλλο με
! όνομα Βαθμολογίες και κατ αντιστοιχία θέσεων οι μέσοι όροι της βαθμολογίας των μαθητών. Έτσι
! αν στη θέση i του πίνακα Ονόματα υπάρχει το ονοματεπώνυμο κάποιου μαθητή στην αντίστοιχη θέση
! του πίνακα Βαθμολογίες υπάρχει ο μέσος όρος της βαθμολογίας του ίδιου μαθητή.
! Να αναπτυχθεί αλγόριθμος που :
! Α) να διαβάζει τα στοιχεία των δύο πινάκων.
! Β) να βρίσκει και να εμφανίζει το μεγαλύτερο μέσο όρο βαθμολογίας.
! Γ) να εμφανίζει το ονοματεπώνυμο των μαθητών που έχουν το βαθμό που βρήκατε στο ερώτημα Β.
! Δ) να εμφανίζει πόσοι μαθητές έχουν το βαθμό που βρήκατε στο ερώτημα Β.
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ PR_2001_4
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : i ,n
  ΠΡΑΓΜΑΤΙΚΕΣ: max, μο[5]
  ΧΑΡΑΚΤΗΡΕΣ: ονομα[5]                    
ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5
    ΓΡΑΨΕ 'Δώσε το όνομα του μαθητή ',i
    ΔΙΑΒΑΣΕ ονομα[i]
    ΓΡΑΨΕ 'Δώσε το βαθμό του'
    ΔΙΑΒΑΣΕ μο[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  max <-- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5
    ΑΝ μο[i] > max ΤΟΤΕ
      max <-- μο[i]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Ο μεγαλύτερος μέσος όρος είναι : ',max
  ΓΡΑΨΕ 'το βαθμό αυτό έχουν οι :'
  n <-- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5
    ΑΝ μο[i] = max ΤΟΤΕ
      n <-- n + 1
      ΓΡΑΨΕ ονομα[i]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'ΣΥΝΟΛΟ : ', n , ' μαθητές.'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters