Τώρα είναι Σάβ 29 Φεβ 2020 12:08 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Προσομοίωση - Θέμα 2Β
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 09 Απρ 2007 10:02 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΠΡΟΣΟΜΟΙΩΣΗ 2001 - ΘΕΜΑ 2Β
! ===============================================================================================
! Βρείτε ποιες θα είναι οι τελικές τιμές των μεταβλητών Α , Β , Γ , Δ , Ε μετά την εκτέλεση του
! παρακάτω τμήματος αλγορίθμου :
!
!   Α <-- 0; Β <-- 0; Γ <-- 0; Δ <-- 0; Ε <-- 0
!   ΓΙΑ κ ΑΠΟ 1 ΜΕΧΡΙ 5
!       Α <-- Α+1
!       Ψ < κ
!       ΑΝ (Ψ MOD 2)=0 ΤΟΤΕ
!          Α <-- Α+1
!          ΕΜΦΑΝΙΣΕ "ΖΥΓΟΣ ΑΡΙΘΜΟΣ"
!       ΑΛΛΙΩΣ
!          Β <-- Β+1
!          ΕΜΦΑΝΙΣΕ "ΜΟΝΟΣ ΑΡΙΘΜΟΣ"
!          ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 10 ME_BHMA 3
!              Γ <-- Γ+1
!          ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!       ΤΕΛΟΣ_ΑΝ
!       Δ <-- Δ+1
!       ΕΜΦΑΝΙΣΕ Ψ
!   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!   Ε <-- Ε+1
!   ΕΜΦΑΝΙΣΕ κ
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ PR_2001_2Β
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: A,B,G,D,R,Y,K ,J
ΑΡΧΗ
  A <-- 0
  B <-- 0                    
  G <-- 0
  D <-- 0
  R <-- 0
  ΓΙΑ K ΑΠΟ 1 μέχρι 5
    A <-- A + 1
    Y <-- K
    ΑΝ (Y MOD 2) = 0 τότε
      a <-- a +1
      γράψε 'ZYGOS ARITHMOS'
    ΑΛΛΙΩΣ
      B <-- B + 1
      ΓΡΑΨΕ 'MONOS ARITHMOS'
      ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 10 ΜΕ ΒΗΜΑ 3
        G <-- G + 1
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΑΝ
    D <-- D + 1
    ΓΡΑΨΕ Y
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  R <-- R + 1
  ΓΡΑΨΕ K
  ΓΡΑΨΕ '---------------'
  ΓΡΑΨΕ
  ΓΡΑΨΕ
  ΓΡΑΨΕ A,' ', B,' ',G,' ',D,' ',R
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters