Τώρα είναι Δευτ 18 Φεβ 2019 11:23 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 09 Απρ 2007 09:56 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΗΜΕΡΗΣΙΟ - ΙΟΥΛΙΟΣ 2001 - ΘΕΜΑ 2
! ===============================================================================================
! Δίνεται το παρακάτω τμήμα αλγορίθμου :
!
! Κ = 4
! Όσο Κ >= 1 επανάλαβε
!   Α <-- 1
!   Αν Κ <> 2 τότε
!     Για i από 1 μέχρι K
!       Α <-- 2*Α
!       Tύπωσε i , A
!     Τέλος_επανάληψης
!   Τέλος_αν
!   Κ <-- Κ/2
! Τέλος_επανάληψης
!
! Καθώς εκτελείται το παραπάνω τμήμα αλγορίθμου, ποιες τιμές τυπώνονται με την εντολή Τύπωσε i,Α ;
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ HM_2001_07_2
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: a
  ΠΡΑΓΜΑΤΙΚΕΣ: i , k
ΑΡΧΗ
  k <-- 4
  ΟΣΟ k >= 1 ΕΠΑΝΑΛΑΒΕ
    a <-- 1
    ΑΝ k <> 2 ΤΟΤΕ
      ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ k
        a <-- 2*a
        ΓΡΑΨΕ i , ' ', a
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΑΝ
    k <-- k/2
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters