Τώρα είναι Δευτ 18 Φεβ 2019 10:45 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 09 Απρ 2007 09:53 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]

! ===============================================================================================
! ΗΜΕΡΗΣΙΟ - ΙΟΥΛΙΟΣ 2001 - ΘΕΜΑ 1Δ
! ===============================================================================================
! Δίνεται το παρακάτω τμήμα αλγορίθμου.
!
! Χ <-- Α
! ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
!   Χ <-- Χ + 2
! ΓΡΑΨΕ Χ
! Χ <-- Χ + 2
! ΜΕΧΡΙΣ_ΟΤΟΥ χ >= Μ
!
! α. Να δώσετε τη δομή επανάληψης "Για ... από ... μέχρι ... βήμα" η οποία τυπώνει ακριβώς τις
!    ίδιες τιμές με το πιο πάνω τμήμα αλγορίθμου.
! β. Τι θα τυπωθεί, αν Α = 4 και Μ = 9;
! γ. Τι θα τυπωθεί, αν Α = -5 και Μ = 0 ;
!
! ===============================================================================================                                

ΠΡΟΓΡΑΜΜΑ HM_2001_07_1Δ
ΣΤΑΘΕΡΕΣ
  Α = 4     ! Αλλάξτε τις τιμές
  Μ = 9     ! για το ερώτημα γ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: x
ΑΡΧΗ
  ΓΡΑΨΕ 'Ο αλγόριθμος που δίνεται τυπώνει :'
  ΓΡΑΨΕ '----------------------------------'
  Χ <-- Α
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    x <-- x + 2
    ΓΡΑΨΕ Χ
  ΜΕΧΡΙΣ_ΟΤΟΥ x >= Μ
  ΓΡΑΨΕ 'Τελική τιμή του x =',x
  ΓΡΑΨΕ '===================================='
  ΓΡΑΨΕ 'Ο αλγόριθμος που φτιάχνουμε τυπώνει :'
  ΓΡΑΨΕ '-------------------------------------'
  ΓΙΑ x ΑΠΟ A ΜΕΧΡΙ M ΜΕ ΒΗΜΑ 2
    ΓΡΑΨΕ x + 2
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Τελική τιμή του x =',x
  ΓΡΑΨΕ '===================================='
! Tα δύο τμήματα του προγράμματος τυπώνουν τα ίδια και είναι ισοδύναμα αφού η τελική τιμή του x
! είναι ίδια.
! ==============================================================================================
  ΓΡΑΨΕ
  ΓΡΑΨΕ '      ***** ΑΛΛΗ ΛΥΣΗ *****'
  ΓΡΑΨΕ '===================================='
  ΓΡΑΨΕ 'Ο αλγόριθμος που φτιάχνουμε τυπώνει :'
  ΓΡΑΨΕ '-------------------------------------'
  ΓΙΑ x ΑΠΟ A+2 ΜΕΧΡΙ M+1 ΜΕ ΒΗΜΑ 2
    ΓΡΑΨΕ x
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Τελική τιμή του x =',x
  ΓΡΑΨΕ '===================================='
!  Tα δύο τμήματα του προγράμματος τυπώνουν τα ίδια αλλά δεν είναι ισοδύναμα αφού η τελική τιμή
!  του x διαφέρει. Αν ήθελε ισοδύναμα προγράμματα θα έπρεπε μετά το τέλος της ΓΙΑ ... να βάλουμε
!  την εντολή x <-- x - 2. Και πάλι όμως θα υπήρχε πρόβλημα αφού τα προγράμματα θα τύπωναν
!  διαφορετικά αν δίναμε ίσες τιμές στα Α και Μ.
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters