Τώρα είναι Πέμ 16 Ιούλ 2020 04:39 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Ημερήσιο - Θέμα 4
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 09 Απρ 2007 09:51 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΗΜΕΡΗΣΙΟ - ΙΟΥΝΙΟΣ 2001 - ΘΕΜΑ 4
! ===============================================================================================
! Σε ένα πρόγραμμα περιβαλλοντικής εκπαίδευσης συμμετέχουν 20 σχολεία. Στα πλαίσια αυτού του
! προγράμματος, εθελοντές μαθητές των σχολείων, που συμμετέχουν στο πρόγραμμα, μαζεύουν ποσότητες
! τριών υλικών (γυαλί, χαρτί και αλουμίνιο).
! Να αναπτύξετε έναν αλγόριθμο, ο οποίος :
!  α. να διαβάζει τις ποσότητες σε κιλά των υλικών που μάζεψαν οι μαθητές σε κάθε σχολείο.
!  β. να υπολογίζει τη συνολική ποσότητα σε κιλά του κάθε υλικού που μάζεψαν οι μαθητές σε όλα
!     τα σχολεία.
!  γ. αν η συνολική ποσότητα του χαρτιού που μαζεύτηκε από όλα τα σχολεία είναι λιγότερη των 1000
!     κιλών, να εμφανίζεται το μήνυμα "Συγχαρητήρια". Αν η ποσότητα είναι από 1000 κιλά και πάνω,
!     αλλά λιγότερο από 2000, να εμφανίζεται το μήνυμα "Δίνεται έπαινος" και τέλος αν η ποσότητα
!     είναι από 2000 κιλά και πάνω να εμφανίζεται το μήνυμα "Δίνεται βραβείο".
!
! Παρατήρηση: Να θεωρήσετε ότι όλες οι ποσότητες είναι θετικοί αριθμοί.
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ HM_2001_06_4
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:i ,α ,γ,χ,sγ,sχ,sα
ΑΡΧΗ
  sγ <-- 0  ! Άθροισμα κιλών γυαλιού
  sχ <-- 0  ! Άθροισμα κιλών χαρτιού
  sα <-- 0  ! Άθροισμα κιλών αλουμινίου
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
    ΓΡΑΨΕ 'Πόσα κιλά γυαλί μαζεύτηκε στο σχολείο; ',i
    ΔΙΑΒΑΣΕ γ
    ΓΡΑΨΕ 'Πόσα κιλά χαρτί μαζεύτηκε στο σχολείο; ',i
    ΔΙΑΒΑΣΕ χ
    ΓΡΑΨΕ 'Πόσα κιλά αλουμίνιο μαζεύτηκε στο σχολείο; ',i
    ΔΙΑΒΑΣΕ α
    sγ <--+ γ
    sχ <--+ χ
    sα <--+α
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ< 1000 ΤΟΤΕ
    ΓΡΑΨΕ 'ΣΥΓΧΑΡΗΤΗΡΙΑ'
  ΑΛΛΙΩΣ_ΑΝ< 2000 ΤΟΤΕ
    ΓΡΑΨΕ 'ΔΙΝΕΤΑΙ ΕΠΑΙΝΟΣ'
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'ΔΙΝΕΤΑΙ ΒΡΑΒΕΙΟ'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters