Τώρα είναι Κυρ 21 Απρ 2019 07:43 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Εσπερινό - Θέμα 4
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 09 Απρ 2007 09:44 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΕΣΠΕΡΙΝΟ - ΙΟΥΝΙΟΣ 2001 - ΘΕΜΑ 4
! ===============================================================================================
! Σε κάποια εξεταστική δοκιμασία ένα γραπτό αξιολογείται από δύο βαθμολογητές στη βαθμολογική
! κλίμακα [0, 100].
! Αν η διαφορά μεταξύ των βαθμολογιών του α' και του β' βαθμολογητή είναι μικρότερη ή ίση των 20
! μονάδων της παραπάνω κλίμακας, ο τελικός βαθμός είναιο μέσος όρος των δύο βαθμολογιών.
! Αν η διαφορά μεταξύ των βαθμολογιών του α' και του β' βαθμολογητή είναι μεγαλύτερη από 20
! μονάδες, το γραπτό δίνεται για αναβαθμολόγηση σε τρίτο βαθμολογητή.
! Ο τελικός βαθμός του γραπτού προκύπτει τότε από το μέσο όρο των τριών βαθμολογιών.
! Να αναπτύξετε αλγόριθμο ο οποίος,
!   αφού ελέγξει την εγκυρότητα των βαθμών στη βαθμολογική κλίμακα [0, 100],
!   να υλοποιεί την παραπάνω διαδικασία εξαγωγής τελικού βαθμού και
!   να εμφανίζει τον τελικό βαθμό του γραπτού στην εικοσαβάθμια κλίμακα.
! Παρατήρηση : Να θεωρήσετε ότι όλες οι ποσότητες εκφράζονται ως πραγματικοί αριθμοί.
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ ES_2001_06_4
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ:β1 , β2 , β3 , μ
ΑΡΧΗ
  ΓΡΑΨΕ 'ΔΩΣΕ ΤO ΒΑΘΜΟ ΤΟΥ ΠΡΩΤΟΥ ΒΑΘΜΟΛΟΓΗΤΗ'
  ΔΙΑΒΑΣΕ β1
  ΟΣΟ β1 < 0 ή β1 > 100 ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ 'Λάθος. Ξαναδώσε'
    ΔΙΑΒΑΣΕ β1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'ΔΩΣΕ ΤO ΒΑΘΜΟ ΤΟΥ ΔΕΥΤΕΡΟΥ ΒΑΘΜΟΛΟΓΗΤΗ'
  ΔΙΑΒΑΣΕ β2
  ΟΣΟ β2 < 0 ή β2 > 100 ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ 'Λάθος. Ξαναδώσε'
    ΔΙΑΒΑΣΕ β2
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ Α_Τ(β1 - β2) <= 20 ΤΟΤΕ
    μ <-- (β1 + β2)/2
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'Δώσε το βαθμό του τρίτου βαθμολογητή'
    ΔΙΑΒΑΣΕ β3
    ΟΣΟ β3 < 0 ή β3 > 100 ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ 'Λάθος. Ξαναδώσε'
      ΔΙΑΒΑΣΕ β3
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    Μ <-- (β1 + β2 + β3)/3
  ΤΕΛΟΣ_ΑΝ
  μ <-- μ / 5
  ΓΡΑΨΕ 'Τελικός βαθμός :'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters