Τώρα είναι Δευτ 24 Ιουν 2019 06:13 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Εσπερινό - Θέμα 3
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 09 Απρ 2007 09:42 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΕΣΠΕΡΙΝΟ - ΙΟΥΝΙΟΣ 2001 - ΘΕΜΑ 3
! ===============================================================================================
! Ένας μαθητής που τελείωσε το γυμνάσιο με άριστα ζήτησε από τους γονείς του να του αγοράσουν ένα
! υπολογιστικό σύστημα αξίας 600.000 δραχμών. Οι γονείς του δήλωσαν ότι μπορούν να του διαθέσουν
! σταδιακά το ποσό, δίνοντάς του κάθε εβδομάδα ποσό διπλάσιο από την προηγούμενη, αρχίζοντας την
! πρώτη εβδομάδα με 5.000 δραχμές.
! Να αναπτύξετε αλγόριθμο που :
!   1. να υπολογίζει και να εμφανίζει μετά από πόσες εβδομάδες θα μπορέσει να αγοράσει το
!      υπολογιστικό σύστημα,
!   2. να υπολογίζει, να ελέγχει και να εμφανίζει πιθανό περίσσευμα χρημάτων.
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ ES_2001_09_3
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: S , X , N
ΑΡΧΗ
  S <-- 5000
  X <-- 5000
  N <-- 1
  ΟΣΟ S < 600000 ΕΠΑΝΑΛΑΒΕ
    X <-- X * 2
    S <-- S + X
    N <-- N + 1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'O υπολογιστής θα αγοραστεί μετά από',N,'εβδομάδες'
  ΑΝ S > 600000 ΤΟΤΕ
    ΓΡΑΨΕ 'και θα περισσέψουν' , S - 600000 , 'δραχμές.'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters