Τώρα είναι Δευτ 18 Φεβ 2019 11:20 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Εσπερινό - Θέμα 2
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 09 Απρ 2007 09:41 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΕΣΠΕΡΙΝΟ - ΙΟΥΝΙΟΣ 2001 - ΘΕΜΑ 2
! ===============================================================================================
! Υποψήφιος αγοραστής οικοπέδου μετά από επίσκεψη σε μεσιτικό γραφείο πώλησης ακινήτων πήρε τις
! εξής πληροφορίες : Ένα οικόπεδο θεωρείται "ακριβό", όταν η τιμή πώλησης ανά τετραγωνικό μέτρο
! είναι μεγαλύτερη των 140.000 δραχμών, "φτηνό" όταν η τιμή πώλησης είναι μικρότερη των 50.000
! δραχμών και σε οποιαδήποτε άλλη περίπτωση η τιμή θεωρείται "κανονική".
! Να αναπτύξετε αλγόριθμο που για καθένα από 50 οικόπεδα :
!  1. να διαβάζει την τιμή πώλησης ολόκληρου του οικοπέδου και τον αριθμό των τετραγωνικών μέτρων
!     του,
!  2. να υπολογίζει την κατηγορία κόστους στην οποία ανήκει και να εμφανίζει το μήνυμα:
!     "ακριβή τιμή" ή "φτηνή τιμή" ή "κανονική τιμή".
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ ES_2001_09_2
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i
  ΠΡΑΓΜΑΤΙΚΕΣ: x , y , z
ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 50
    ΓΡΑΨΕ 'Δώσε τιμή και επιφάνεια οικοπέδου Νο :',i
    ΔΙΑΒΑΣΕ x , y   ! Υποθέτουμε ότι ο χρήστης δε θα δώσει αρνητικές ή μηδενικές τιμές.
    z <-- x / y     ! Τιμή ανά τετραγωνικό μέτρο.
    ΑΝ z < 50000 ΤΟΤΕ
      ΓΡΑΨΕ 'φτηνή τιμή'
    ΑΛΛΙΩΣ_ΑΝ z <= 140000 ΤΟΤΕ
      ΓΡΑΨΕ 'κανονική τιμή'
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'ακριβή τιμή'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters