Τώρα είναι Δευτ 16 Σεπ 2019 11:35 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Ημερήσιο - Θέμα 2
ΔημοσίευσηΔημοσιεύτηκε: Τρί 10 Απρ 2007 02:26 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΗΜΕΡΗΣΙΟ - ΙΟΥΝΙΟΣ 2001 - ΘΕΜΑ 2
! ===============================================================================================
! Δίνεται το παρακάτω τμήμα αλγορίθμου.
! Χ <--  1
! Όσο Χ < 5 επανάλαβε
!   Α <-- Χ + 2
!   Β <-- 3*Α - 4
!   C <-- Β - Α + 4
!   Αν Α > Β τότε
!      Αν Α > C τότε
!          MAX  A
!      αλλιώς
!          MAX  C
!      Τέλος_αν
!   αλλιώς
!      Αν Β > C τότε
!         MAX <-- Β
!      αλλιώς
!         MAX <-- C
!      Τέλος_αν
!   Τέλος αν
! Εμφάνισε Χ, Α, Β, C, MAX
! Χ <-- Χ + 2
! Τέλος_επανάληψης
!
! Ποιες είναι οι τιμές των μεταβλητών Χ, Α, Β, C, MAX που θα εμφανιστούν κατλα την εκτέλεση του
! παραπάνω τμήματος αλγορίθμου ;
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ HM_2001_06_2
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : x , a , b , c , max
  ΠΡΑΓΜΑΤΙΚΕΣ: k
ΑΡΧΗ
  x <-- 1
  ΟΣΟ x < 5 ΕΠΑΝΑΛΑΒΕ
    a <-- x + 2
    b <-- 3*a - 4
    c <-- b - a + 4
    ΑΝ a > b ΤΟΤΕ
      ΑΝ a > c ΤΟΤΕ
        max <-- a
      ΑΛΛΙΩΣ
        max <-- c
      ΤΕΛΟΣ_ΑΝ
    ΑΛΛΙΩΣ
      ΑΝ b > c ΤΟΤΕ
        max <-- b
      ΑΛΛΙΩΣ
        max <-- c
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ x , a , b , c , max
    x <-- x + 2
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters