Τώρα είναι Δευτ 24 Ιουν 2019 07:22 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Ημερήσιο - Θέμα 2
ΔημοσίευσηΔημοσιεύτηκε: Τρί 10 Απρ 2007 09:41 am 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! =========================================================================================
! ΗΜΕΡΗΣΙΟ - ΙΟΥΝΙΟΣ 2000 - ΘΕΜΑ 2
! =========================================================================================
! Έστω τμήμα αλγορίθμου με μεταβλητές A , B , C , D , X και Υ.
!
!  D := 2;
!  για Χ := 2 μέχρι 5 μεταβολή 2 κάνε
!  Α := 10*Χ;
!  Β := 5*Χ+ 10;
!  C := Α + Β - (5*Χ);
!  D := 3*D - 5;
!  Υ := Α + Β - C + D;
!  Τέλοςγια
!
! Να βρείτε τις τιμές των μεταβλητών A , B , C , D , X και Υ σε όλες τις επαναλήψεις.
! =========================================================================================

ΠΡΟΓΡΑΜΜΑ HM_2000_06_2
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Χ , Α , Β , C , D , Υ , κ
ΑΡΧΗ
  D <-- 2
  κ <-- 1
  ΓΙΑ Χ ΑΠΟ 2 ΜΕΧΡΙ 5 ΜΕ ΒΗΜΑ 2
    ΓΡΑΨΕ κ ,'η ΕΠΑΝΑΛΗΨΗ'
    ΓΡΑΨΕ '=============='
    Α <-- 10*Χ
    Β <-- 5*Χ + 10
    C <-- Α + Β - (5*Χ)
    D <-- 3*D - 5
    Υ <-- Α + Β - C + D
    ΓΡΑΨΕ 'Α =' , Α
    ΓΡΑΨΕ 'Β =' , Β
    ΓΡΑΨΕ 'C =' , C
    ΓΡΑΨΕ 'D =' , D
    ΓΡΑΨΕ 'X =' , Χ
    ΓΡΑΨΕ 'Y =' , Υ
    κ <-- κ + 1
    ΓΡΑΨΕ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'ΤΕΛΙΚΕΣ ΤΙΜΕΣ'
  ΓΡΑΨΕ '============='
  ΓΡΑΨΕ 'Α =' , Α
  ΓΡΑΨΕ 'Β =' , Β
  ΓΡΑΨΕ 'C =' , C
  ΓΡΑΨΕ 'D =' , D
  ΓΡΑΨΕ 'X =' , Χ
  ΓΡΑΨΕ 'Y =' , Υ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters