Τώρα είναι Κυρ 21 Απρ 2019 07:04 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Εσπερινό - Θέμα 2
ΔημοσίευσηΔημοσιεύτηκε: Τρί 10 Απρ 2007 09:31 am 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! =========================================================================================
! ΕΣΠΕΡΙΝΟ ΙΟΥΝΙΟΣ 2000 - ΘΕΜΑ 2
! =========================================================================================
! Δίνεται το παρακάτω τμήμα αλγόριθμου.

!   ΔΙΑΒΑΣΕ a
!   b := 2*α + 1
!   c := α + b
!   ΑΝ c > b ΤΟΤΕ
!     b := c
!   ΑΛΛΙΩΣ
!     c := b
!   ΤΕΛΟΣ ΑΝ
!   ΕΜΦΑΝΙΣΕ α, b, c

! Μετά την εκτέλεση του παραπάνω τμήματος αλγορίθμου, ποιες θα είναι οι τιμές των μεταβλητών
! α, b και c που θα εμφανιστούν, όταν :  (i) α = 10   και   (ii) α = -10
! =========================================================================================

ΠΡΟΓΡΑΜΜΑ ES_2000_06_2
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: a,b,c
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε τιμή για το a'
  ΔΙΑΒΑΣΕ a
  b <-- 2*a + 1
  c <-- a + b
  ΑΝ c > b ΤΟΤΕ
    b <-- c
  ΑΛΛΙΩΣ
    c <-- b
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ 'a =',a
  ΓΡΑΨΕ 'b =',b
  ΓΡΑΨΕ 'c =', c
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters