Τώρα είναι Δευτ 26 Αύγ 2019 07:47 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Τρί 10 Απρ 2007 09:25 am 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΗΜΕΡΗΣΙΟ - ΣΕΠΤΕΜΒΡΙΟΣ 2000 - ΘΕΜΑ 3
! ===============================================================================================
! Μια οικογένεια κατανάλωσε Χ Kwh (κιλοβατώρες) ημερήσιου ρεύματος και Υ Kwh νυχτερινού ρεύματος.
! Το κόστος ημερήσιου ρεύματος είναι 30 δρχ. ανά Kwh και του νυχτερινού 15 δρχ. ανά Kwh.
! Να αναπτύξετε έναν αλγόριθμο ο οποίος :
!   α. να διαβάζει τα Χ, Y
!   β. να υπολογίζει και να εμφανίζει το συνολικό κόστος της κατανάλωσης ρεύματος της οικογένειας
!   γ. να εμφανίζει το μήνυμα ΥΠΕΡΒΟΛΙΚΗ ΚΑΤΑΝΑΛΩΣΗ, αν το συνολικό κόστος είναι μεγαλύτερο από
!      100.000 δραχμές.
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ ΗΜ_2000_09_3
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: X , Y , Kostos
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε τις κιλοβατώρες της ημερήσιας κατανάλωσης.'
  ΔΙΑΒΑΣΕ X
  ΓΡΑΨΕ 'Δώσε τις κιλοβατώρες της νυχτερινής κατανάλωσης.'
  ΔΙΑΒΑΣΕ Y
  Kostos <-- X*30 + Y*15
  ΓΡΑΨΕ 'Το κόστος του ρεύματος που καταναλώθηκε είναι συνολικά : ', Kostos
  ΑΝ Kostos > 100000 ΤΟΤΕ
    ΓΡΑΨΕ 'ΥΠΕΡΒΟΛΙΚΗ ΚΑΤΑΝΑΛΩΣΗ'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters