Τώρα είναι Δευτ 18 Φεβ 2019 11:46 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Τρί 10 Απρ 2007 09:24 am 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΗΜΕΡΗΣΙΟ - ΣΕΠΤΕΜΒΡΙΟΣ 2000 - ΘΕΜΑ 4
! ===============================================================================================
! Ο τελικός βαθμός ενός μαθητή σ' ένα μάθημα υπολογίζεταιμε βάση την προφορική και τη γραπτή
! βαθμολογία του με την ακόλουθη διαδικασία :
!   Αν η διαφορά των δύο βαθμών είναι μεγαλύτερη από πέντε μονάδες, τότε ο προφορικός βαθμός
!  προσαρμόζεται (δηλαδή αυξάνεται ή μειώνεται) έτσι, ώστε η αντίστοιχη διαφορά να μειωθεί στις
!  τρεις (3) μονάδες, αλλιώς ο προφορικός βαθμός παραμένει αμετάβλητος.
!  Ο τελικός βαθμός είναι ο μέσος όρος των δύο βαθμών.
!
! Παράδειγμα προσαρμογής προφορικού βαθμού :
!   Αν ο γραπτός βαθμός είναι 18 και ο προφορικός 11, τότε ο προφορικός γίνεται 15, ενώ,
!   αν ο γραπτός είναι 10 και ο προφορικός 19, τότε ο προφορικός γίνεται 13.
!
! Να αναπτύξετε έναν αλγόριθμο ο οποίος:
!    α. να διαβάζει τους δύο βαθμούς.
!    β. να υπολογίζει τον τελικό βαθμό σύμφωνα με την παραπάνω διαδικασία
!    γ. να εμφανίζει τον τελικό βαθμό και, αν αυτός είναι μεγαλύτερος ή ίσος του 10,
!       το μήνυμα ΠΡΟΑΓΕΤΑΙ, αλλιώς το μήνυμα ΑΠΟΡΡΙΠΤΕΤΑΙ.
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ ΗΜ_2000_09_4
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: Prof , Grapt , Mesos
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε το προφορικό βαθμό.'
  ΔΙΑΒΑΣΕ Prof
  ΓΡΑΨΕ 'Δώσε το βαθμό του γραπτού.'
  ΔΙΑΒΑΣΕ Grapt
  ΑΝ Grapt - Prof > 5 ΤΟΤΕ
    Prof <-- Grapt - 3
  ΤΕΛΟΣ_ΑΝ
  ΑΝ Prof - Grapt > 5 ΤΟΤΕ
    Prof <-- Grapt + 3
  ΤΕΛΟΣ_ΑΝ
  Mesos <-- ( Prof + Grapt ) / 2
  ΓΡΑΨΕ 'O τελικός μέσος όρος είναι :', Mesos
  ΑΝ Mesos < 10 ΤΟΤΕ
    ΓΡΑΨΕ 'ΑΠΟΡΡΙΠΤΕΤΑΙ'
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'ΠΡΟΑΓΕΤΑΙ'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters