Τώρα είναι Δευτ 23 Σεπ 2019 08:24 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Εσπερινό - Θέμα 3
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 17 Μαρ 2003 12:26 am 
Χωρίς σύνδεση
Διαχειριστής

Εγγραφή: Παρ 28 Φεβ 2003 06:10 pm
Δημοσιεύσεις: 84
Syntax: [ Download ] [ Hide ]
! =====================================================================
! Ένας μαθητής που τελείωσε το Γυμνάσιο με άριστα ζήτησε από τους
! γονείς του να του αγοράσουν ένα υπολογιστικό σύστημα αξίας 600.000
! δραχμών. Οι γονείς του δήλωσαν ότι μπορούν να του διαθέσουν σταδιακά
! το ποσό, δίνοντάς του κάθε εβδομάδα ποσό διπλάσιο από την
! προηγούμενη, αρχίζοντας την πρώτη εβδομάδα με 5.000 δραχμές.
! Να γίνει πρόγραμμα που:
!   1. Να υπολογίζει και να εμφανίζει μετά από πόσες εβδομάδες θα
!      μπορέσει να αγοραστεί το υπολογιστικό σύστημα.
!                                                          [Μονάδες 10]
!   2. Να υπολογίζει, να ελέγχει και να εμφανίζει πιθανό περίσσευμα
!      χρημάτων.
!                                                          [Μονάδες 10]
! =====================================================================


ΠΡΟΓΡΑΜΜΑ Πανελλήνιες_2000_Εσπερινά__Θέμα_3ο

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: συνολικό_ποσό, επόμενη_δόση, εβδομάδες

ΑΡΧΗ

  εβδομάδες <-- 1
  συνολικό_ποσό <-- 5000
  επόμενη_δόση <-- 2*5000

  ΟΣΟ συνολικό_ποσό<600000 ΕΠΑΝΑΛΑΒΕ
    συνολικό_πόσο <-- συνολικό_ποσό + επόμενη_δόση
    εβδομάδες <-- εβδομάδες + 1
    επόμενη_δόση <2>600000 ΤΟΤΕ
    ΓΡΑΨΕ 'θα περισσέψουν ', συνολικό_ποσό-600000, ' δραχμές.'
  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Πανελλήνιες_2000_Εσπερινά__Θέμα_3ο

 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters