Τώρα είναι Δευτ 18 Φεβ 2019 12:00 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 5 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Ημερήσιο - Θέμα 3
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 16 Μαρ 2003 11:21 pm 
Χωρίς σύνδεση
Διαχειριστής

Εγγραφή: Παρ 28 Φεβ 2003 06:10 pm
Δημοσιεύσεις: 84
Syntax: [ Download ] [ Hide ]
! ==========================================
! Σε τρεις διαφορετικούς αγώνες πρόκρισης
! για την Ολυμπιάδα του Σίδνεϋ στο άλμα εις
! μήκος ένας αθλητής πέτυχε τις επιδόσεις a,
! b, c. Να γίνει πρόγραμμα το οποίο:
!   Α) Να διαβάζει τις τιμές των επιδόσεων
!      a, b, c.
!                                [Μονάδες 3]
!   Β) Να υπολογίζει και να εμφανίζει τη
!      μέση τιμή των παραπάνω τιμών.
!                                [Μονάδες 7]
!   Γ) Να εμφανίζει το μήνυμα "Προκρίθηκε",
!      αν η παραπάνω μέση τιμή είναι
!      μεγαλύτερη των 8 μέτρων.
!                               [Μονάδες 10]
! ==========================================


ΠΡΟΓΡΑΜΜΑ Πανελλήνιες_2000__Θέμα_3ο

ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: a, b, c, μέσος_όρος

ΑΡΧΗ

  ΓΡΑΨΕ 'Δώσε την πρώτη επίδοση:'
  ΔΙΑΒΑΣΕ a
  ΓΡΑΨΕ 'Δώσε τη δεύτερη επίδοση:'
  ΔΙΑΒΑΣΕ b
  ΓΡΑΨΕ 'Δώσε την τρίτη επίδοση:'
  ΔΙΑΒΑΣΕ c

  μέσος_όρος <-- (a+b+c)/3
  ΑΝ μέσος_όρος>8 ΤΟΤΕ
    ΓΡΑΨΕ 'Προκρίθηκε'
  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Πανελλήνιες_2000__Θέμα_3ο

 

Σωστά με διόρθωσε ο παρακάτω "Επισκέπτης". Είχα ξεχάσει την εντολή "ΓΡΑΨΕ μέσος_όρος".


Τελευταία επεξεργασία από SpiN και Τρί 17 Απρ 2007 07:19 pm, έχει επεξεργασθεί 7 φορά/ες συνολικά

Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Πανελλήνιες 2000 - Θέμα 3ο
ΔημοσίευσηΔημοσιεύτηκε: Παρ 28 Μαρ 2003 12:08 am 
SpiN έγραψε:
Syntax: [ Download ] [ Hide ]
! ==========================================
! Σε τρεις διαφορετικούς αγώνες πρόκρισης
! για την Ολυμπιάδα του Σίδνεϋ στο άλμα εις
! μήκος ένας αθλητής πέτυχε τις επιδόσεις a,
! b, c. Να γίνει πρόγραμμα το οποίο:
!   Α) Να διαβάζει τις τιμές των επιδόσεων
!      a, b, c.
!                                [Μονάδες 3]
!   Β) Να υπολογίζει και να εμφανίζει τη
!      μέση τιμή των παραπάνω τιμών.
!                                [Μονάδες 7]
!   Γ) Να εμφανίζει το μήνυμα "Προκρίθηκε",
!      αν η παραπάνω μέση τιμή είναι
!      μεγαλύτερη των 8 μέτρων.
!                               [Μονάδες 10]
! ==========================================


ΠΡΟΓΡΑΜΜΑ Πανελλήνιες_2000__Θέμα_3ο

ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: a, b, c, μέσος_όρος

ΑΡΧΗ
! 1ο ερώτημα
  ΓΡΑΨΕ 'Δώσε την πρώτη επίδοση:'
  ΔΙΑΒΑΣΕ a
  ΓΡΑΨΕ 'Δώσε τη δεύτερη επίδοση:'
  ΔΙΑΒΑΣΕ b
  ΓΡΑΨΕ 'Δώσε την τρίτη επίδοση:'
  ΔΙΑΒΑΣΕ c

! 2ο ερώτημα
  μέσος_όρος <-- (a+b+c)/3
                    ΓΡΑΨΕ μέσος_όρος

! 3ο ερώτημα
  ΑΝ μέσος_όρος>8 ΤΟΤΕ
    ΓΡΑΨΕ 'Προκρίθηκε'
  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Πανελλήνιες_2000__Θέμα_3ο

 


Κορυφή
  
 
 Θέμα δημοσίευσης: Re: Πανελλήνιες 2000 - Θέμα 3ο
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 01 Μάιος 2003 11:18 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 01 Μάιος 2003 10:25 pm
Δημοσιεύσεις: 38
Τοποθεσία: Πρέβεζα
Θα πρότεινα μια μετατροπή της άσκησης παραπάνω ως εξής:
Μια τιμή στα a, b, c ίση με μηδέν θα σημαίνει **άκυρο πήδημα**
Οπότε τώρα δυσκολεύουν τα πράγματα και θα πρέπει να βγεί μέσος όρος μόνο από τα έγκυρα δηλαδή αυτά που έδωσαν μετρήσεις (>0)

_________________
Γλώσσα προγραμματισμού M2000


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Παρ 02 Μάιος 2003 01:47 am 
Χωρίς σύνδεση
Διαχειριστής

Εγγραφή: Παρ 28 Φεβ 2003 06:10 pm
Δημοσιεύσεις: 84
Ωραία ιδέα!
Και αφού ο bugman δεν έδωσε την απάντηση, τη δίνω εγώ.
Επειδή ουσιαστικά πρόκειται για ΑΛΛΗ άσκηση την έβαλα σε άλλο topic: Πανελλήνιες 2000 - Θέμα 3ο (εμπλουτισμένο)


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 23 Σεπ 2006 11:12 am 
Wraio kai to emploutismeno. Bebaia kai ayto mou fanhke ligo eykolo gia pannelhnies opws dothike, enw an dinotan to emploutismeno pisteyw tha htan ok.


Κορυφή
  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 5 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters