Τώρα είναι Πέμ 27 Ιουν 2019 03:48 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Game
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 19 Ιουν 2010 04:12 pm 
Χωρίς σύνδεση

Εγγραφή: Τρί 22 Απρ 2008 11:05 am
Δημοσιεύσεις: 21
Παράθεση:
To κλασικό παιχνιδάκι που βρήσκεις τα ζευγάρια των όμοιων συμβόλων.Δεν είναι και το φοβερό αλλά περνάς την ώρα σου :D

Κώδικας:
ΑΡΧΗ
  ΚΑΛΕΣΕ μενού
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
ΔΙΑΔΙΚΑΣΙΑ μενού
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: απα
  ΑΚΕΡΑΙΕΣ: ι
ΑΡΧΗ
  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ

  ΠΗΓΑΙΝΕ_ΧΥ 0,8
  ΓΡΑΨΕ '|'
  ΓΡΑΨΕ '|'

  ΠΗΓΑΙΝΕ_ΧΥ 79,8
  ΓΡΑΨΕ '|'
  ΠΗΓΑΙΝΕ_ΧΥ 79,9
  ΓΡΑΨΕ '|'

  ΠΗΓΑΙΝΕ_ΧΥ 18,5
  ΓΡΑΨΕ 'Καλωσήρθατε.Κάντε παρακάτω την επιλογή σας.'
  ΠΗΓΑΙΝΕ_ΧΥ 0,7
  ΓΡΑΨΕ '==============================================================================='
  ΠΗΓΑΙΝΕ_ΧΥ 20,8
  ΓΡΑΨΕ '1.Για νέο παιχνίδι.'
  ΠΗΓΑΙΝΕ_ΧΥ 20,9
  ΓΡΑΨΕ '2.Για έξοδο από το παιχνίδι.'
  ΠΗΓΑΙΝΕ_ΧΥ 0,10
  ΓΡΑΨΕ '==============================================================================='

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΠΗΓΑΙΝΕ_ΧΥ 1,11
    ΓΡΑΨΕ 'Δώσε την απάντησή σου:'
    διαβασε_ απα
  ΜΕΧΡΙΣ_ΟΤΟΥ απα=1 ή απα=2

  ΑΝ απα=1 τότε
    ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
    ΚΑΛΕΣΕ παιχνίδι
  ΑΛΛΙΩΣ_ΑΝ απα=2 τότε
    ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
    ΠΗΓΑΙΝΕ_ΧΥ 35,12
    γράψε'Αντίο....'
    ΓΙΑ ι από 1 μέχρι 19999999
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΚΛΕΙΣΕ_ΠΑΡΑΘΥΡΟ

  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
ΔΙΑΔΙΚΑΣΙΑ παιχνίδι

ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: συμβ[36],επισυ[2],κατ
  ΑΚΕΡΑΙΕΣ: χ,ψ,ζ,θχ[36],θψ[36],θε_συ_χ[36],θε_συ_ψ[36],ζευγ,σκορ
  ΑΚΕΡΑΙΕΣ: επιλχ[4],επιλψ[4],επιτχ[36],επιτψ[36],κτχ[3],κτψ[3],γ,κιν
  ΛΟΓΙΚΕΣ: προ,αλλ ,υπαρχ

  ΑΡΧΕΙΑ ΑΚΕΡΑΙΩΝ: κινήσεις

ΑΡΧΗ

  υπαρχ <-- ΨΕΥΔΗΣ


  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ κινήσεις ,'C:\Moves.dll'


  ΑΝ ΥΠΑΡΧΕΙ_ΑΡΧΕΙΟ('C:\Moves.dll')= ΨΕΥΔΗΣ τότε
    ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ κινήσεις
    ΚΛΕΙΣΕ_ΑΡΧΕΙΟ κινήσεις
  ΑΛΛΙΩΣ
    ΑΝΟΙΞΕ_ΑΡΧΕΙΟ κινήσεις
    ΑΝ ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ (κινήσεις)>0 τοτε
      υπαρχ <-- ΑΛΗΘΗΣ
    ΤΕΛΟΣ_ΑΝ
    αν υπαρχ= ΑΛΗΘΗΣ τότε
      ΟΣΟ ΤΕΛΟΣ_ΑΡΧΕΙΟΥ(κινήσεις)= ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
        ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ κινήσεις,σκορ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΑΝ

    ΚΛΕΙΣΕ_ΑΡΧΕΙΟ κινήσεις
  ΤΕΛΟΣ_ΑΝ


  χ <-- 0
  ζευγ <-- 0
  ζ <-- 0
  γ <-- 0
  κιν <-- 0

  ΚΑΛΕΣΕ ταμπλό

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ          !Στησιμο συμβόλων
    χ <-- χ+1
    συμβ[χ] <-- ΧΑΡ(32+χ)

    χ <-- χ+1
    συμβ[χ] <-- συμβ[χ-1]

    ζευγ <-- ζευγ+1
  ΜΕΧΡΙΣ_ΟΤΟΥ χ=36

  για χ από 1 μέχρι 36
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        θχ[χ] <-- ΤΥΧΑΙΟΣ(7)
        θψ[χ] <-- ΤΥΧΑΙΟΣ(7)
      ΜΕΧΡΙΣ_ΟΤΟΥ θχ[χ]>0 και θψ[χ]>0

      αν χ>1 τότε
        ψ <-- 1
        προ <-- ΨΕΥΔΗΣ
        αλλ <-- ΨΕΥΔΗΣ
        ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
          αν θχ[χ]<>θχ[χ-ψ] ή θψ[χ]<>θψ[χ-ψ] τότε
            προ <-- ΑΛΗΘΗΣ
          ΑΛΛΙΩΣ
            αλλ <-- ΑΛΗΘΗΣ
          ΤΕΛΟΣ_ΑΝ
          ψ <-- ψ+1
        ΜΕΧΡΙΣ_ΟΤΟΥ χ=ψ
      ΤΕΛΟΣ_ΑΝ

    ΜΕΧΡΙΣ_ΟΤΟΥ προ= ΑΛΗΘΗΣ και αλλ= ΨΕΥΔΗΣ ή χ=1

    θε_συ_χ[χ] <-- θχ[χ]*5
    θε_συ_ψ[χ] <-- (θψ[χ]*2)+2

  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
  γ <-- 1
  ζ <-- 0
  χ <-- 1

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΠΗΓΑΙΝΕ_ΧΥ 50,3
      ΓΡΑΨΕ 'Απομένουν:',ζευγ,'ζεύγη'
      ΠΗΓΑΙΝΕ_ΧΥ 50,4
      ΓΡΑΨΕ 'Πραγματοποίησες',κιν,'κινήσεις'
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
          ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
          ΠΗΓΑΙΝΕ_ΧΥ 0,18
          ΓΡΑΨΕ '                                                                                           '
          ΠΗΓΑΙΝΕ_ΧΥ 0,18
          ΓΡΑΨΕ_ 'Δώσε τις συντεταγμένες (x,y):( , )'
          ΠΗΓΑΙΝΕ_ΧΥ 31,18
          ΔΙΑΒΑΣΕ_ επιλχ[χ]
          ΠΗΓΑΙΝΕ_ΧΥ 33,18
          ΔΙΑΒΑΣΕ επιλψ[χ]
        ΜΕΧΡΙΣ_ΟΤΟΥ επιλχ[χ]>0 και επιλχ[χ]<7 και επιλψ[χ]>0 και επιλψ[χ]<7   
     
        προ <-- ΨΕΥΔΗΣ
        αλλ <-- ΨΕΥΔΗΣ

        ΑΝ ζ>0 τότε
          ψ <-- ζ

          ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
            αν επιτχ[ψ]<> επιλχ[χ]*5 ή επιτψ[ψ]<>(επιλψ[χ]*2)+2  τοτε
              προ <-- ΑΛΗΘΗΣ
            ΑΛΛΙΩΣ
              αλλ <-- ΑΛΗΘΗΣ
            ΤΕΛΟΣ_ΑΝ
            ψ <-- ψ-1

          ΜΕΧΡΙΣ_ΟΤΟΥ ψ=0

        ΤΕΛΟΣ_ΑΝ

      ΜΕΧΡΙΣ_ΟΤΟΥ προ= ΑΛΗΘΗΣ και αλλ= ΨΕΥΔΗΣ  ή ζ=0

      προ <-- ΨΕΥΔΗΣ
      αλλ <-- ΨΕΥΔΗΣ

      αν χ=2 τότε
        αν επιλχ[χ-1]<>επιλχ[χ] ή επιλψ[χ-1]<>επιλψ[χ] τότε
          προ <-- ΑΛΗΘΗΣ
        ΑΛΛΙΩΣ
          αλλ <-- ΑΛΗΘΗΣ
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΑΝ
    ΜΕΧΡΙΣ_ΟΤΟΥ προ= ΑΛΗΘΗΣ και αλλ= ΨΕΥΔΗΣ ή χ=1

    κτχ[χ] <-- επιλχ[χ]*5
    κτψ[χ] <-- (επιλψ[χ]*2)+2

    ΓΙΑ ψ από 1 μέχρι 36
      ΑΝ κτχ[χ]=θε_συ_χ[ψ] και κτψ[χ]=θε_συ_ψ[ψ] τότε
        ΠΗΓΑΙΝΕ_ΧΥ  κτχ[χ],κτψ[χ]
        ΓΡΑΨΕ συμβ[ψ]
        επισυ[γ] <-- συμβ[ψ]
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

    αν χ=2 τοτε
      αν επισυ[γ-1]=επισυ[γ] τοτε
        ΓΡΑΨΕ_ χαρ(7)
        ζευγ <-- ζευγ-1
        ζ <-- ζ+1
        επιτχ[ζ] <-- κτχ[χ-1]
        επιτψ[ζ] <-- κτψ[χ-1]
        ζ <-- ζ+1
        επιτχ[ζ] <-- κτχ[χ]
        επιτψ[ζ] <-- κτψ[χ]
      ΑΛΛΙΩΣ
        ΓΙΑ ψ από 1 μεχρι 19999999
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

        για χ από 1 μέχρι 2
          ΠΗΓΑΙΝΕ_ΧΥ  κτχ[χ],κτψ[χ]
          ΓΡΑΨΕ ' '
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΤΕΛΟΣ_ΑΝ
      χ <-- 1
      γ <-- 1
    ΑΛΛΙΩΣ

      χ <-- 2
      γ <-- 2
    ΤΕΛΟΣ_ΑΝ

    κιν <-- κιν+1
  ΜΕΧΡΙΣ_ΟΤΟΥ ζευγ=0

  ΓΙΑ ψ από 1 μεχρι 19999999
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  αν κιν<σκορ  τότε
    κατ <-- 'Νέο ρεκόρ!!!'
  ΑΛΛΙΩΣ
    κατ <-- ''
  ΤΕΛΟΣ_ΑΝ

  χ <-- 0
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
    ΠΗΓΑΙΝΕ_ΧΥ 20,8
    ΓΡΑΨΕ '==========================================='
    ΠΗΓΑΙΝΕ_ΧΥ 20,9
    ΓΡΑΨΕ '|   /\         The Game is over!          |'
    ΠΗΓΑΙΝΕ_ΧΥ 20,10
    ΓΡΑΨΕ '|  /! \                                   |'
    ΠΗΓΑΙΝΕ_ΧΥ 20,11
    ΓΡΑΨΕ '| ------  Για συνέχεια πάτα [1].          |'
    ΠΗΓΑΙΝΕ_ΧΥ 20,12
    ΓΡΑΨΕ '==========================================='
    ΠΗΓΑΙΝΕ_ΧΥ 20,14
    ΓΡΑΨΕ 'Πραγματοποίησες',κιν,'κινήσεις...',κατ
    ΠΗΓΑΙΝΕ_ΧΥ 53,11
    ΔΙΑΒΑΣΕ_ χ
  ΜΕΧΡΙΣ_ΟΤΟΥ χ=1
  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ

  ΑΝ κατ= 'Νέο ρεκόρ!!!' τοτε
    ΚΑΛΕΣΕ ρεκόρ(κατ,κιν)
  ΤΕΛΟΣ_ΑΝ

  ΚΑΛΕΣΕ μενού
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

ΔΙΑΔΙΚΑΣΙΑ ταμπλό
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: αχ,αψ,β,γ,θ_ψ[10],ψ,χ,επα
  ΧΑΡΑΚΤΗΡΕΣ:θ_χ[10]
ΑΡΧΗ
  θ_χ[1] <-- 'A'
  θ_χ[2] <-- 'B'
  θ_χ[3] <-- 'C'
  θ_χ[4] <-- 'D'
  θ_χ[5] <-- 'E'
  θ_χ[6] <-- 'F'
  β <-- 2
  χ <-- 1
  ΓΙΑ αχ από 1 μέχρι 7
    ΓΙΑ αψ από 3 μέχρι 15
      ΑΝ αχ=1 τοτε
        αν αψ MOD 2=0 τότε
          ΠΗΓΑΙΝΕ_ΧΥ β-2,αψ
          ΓΡΑΨΕ  θ_χ[χ]
          ΠΗΓΑΙΝΕ_ΧΥ β,αψ
          ΓΡΑΨΕ '|'
          χ <-- χ+1
        ΤΕΛΟΣ_ΑΝ
      ΑΛΛΙΩΣ
        ΠΗΓΑΙΝΕ_ΧΥ β,αψ
        ΓΡΑΨΕ '|'
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    β <-- β+5
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ψ <-- 1
  β <-- 2
  γ <-- 3
  για αχ από 1 μέχρι 6
    ΓΙΑ αψ από 1 μέχρι 7
      αν αψ=7 τοτε
        ΠΗΓΑΙΝΕ_ΧΥ β,γ
        ΓΡΑΨΕ ' ----'
        ΠΗΓΑΙΝΕ_ΧΥ β,γ+1
        ΓΡΑΨΕ '' , ψ
        ψ <-- ψ+1
      ΑΛΛΙΩΣ
        ΠΗΓΑΙΝΕ_ΧΥ β,γ
        ΓΡΑΨΕ ' ----'
      ΤΕΛΟΣ_ΑΝ
      γ <-- γ+2
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    β <-- β+5
    γ <-- 3
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

ΔΙΑΔΙΚΑΣΙΑ ρεκόρ(κατασταση,κινηση)
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: κατασταση
  ΑΚΕΡΑΙΕΣ: κινηση,χ

  ΑΡΧΕΙΑ ΑΚΕΡΑΙΩΝ: κινήσεις

ΑΡΧΗ


  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ

  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ κινήσεις ,'C:\Moves.dll'


  ΠΗΓΑΙΝΕ_ΧΥ 25,5
  ΓΡΑΨΕ 'Συνχαρητήρια.',κατασταση
  ΓΡΑΨΕ '*************************************************************'



  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ κινήσεις
  ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ κινήσεις, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(κινήσεις)+1
  ΓΡΑΨΕ_ΑΡΧΕΙΟ κινήσεις,κινηση
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ κινήσεις


  χ <-- 1

  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ κινήσεις

  ΟΣΟ ΤΕΛΟΣ_ΑΡΧΕΙΟΥ(κινήσεις)= ΨΕΥΔΗΣ επανάλαβε
    αν χ=5 ή χ=1 τότε
      ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
      ΠΗΓΑΙΝΕ_ΧΥ 25,2

      ΓΡΑΨΕ 'High Scores...'

    ΤΕΛΟΣ_ΑΝ
    ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ κινήσεις,κινηση
    ΓΡΑΨΕ χ,κινηση
    ΓΡΑΨΕ '**************************************'
    χ <-- χ+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ


  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ κινήσεις

  για χ από 1 μέχρι 30
    ΓΙΑ χ από 1 μέχρι 100000000
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
  κάλεσε μενού

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters