Τώρα είναι Τρί 18 Ιουν 2019 12:45 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Battleships2 (lan)
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 13 Ιουν 2010 04:31 pm 
Χωρίς σύνδεση

Εγγραφή: Τρί 22 Απρ 2008 11:05 am
Δημοσιεύσεις: 21
Παράθεση:
Να τη και η 2η εκδοση ελπιίζω να σας αρέσει.Να πως δουλεύει. Τον παρακάτω κώδικα τον αντιγράφετε δυο φορές μια για τον κάθε παίκτη αυτος ο κώδικας είναι για τον παίκτη 1 απλα για τον δύο αντικατστήστε το 1 με το δυο όπου αυτό υπάρχει. Και για παίκτη 2 αλλαξτε την αμυνα με την επίθεση οπως γραφω στα σχόλια. Ελπίζς να δουλεύει γιατι δεν το δοκίμασα σε ομάδα υπολογιστών αφου δεν έχω αλλα απο κατι λίγα που ξέρω κάπως έτσι γίνεται.Ο,τι λάθη έχει να μου τα αναφέρετε.Καλή διασκέδαση.


Κώδικας:
!Αυτό είναι του παίκτη 1 Απλα για τον 2 αντικαταστήστε το κάθε ένα[1] με δυο[2] π.χ. π1<--ονομ1 π2<---ονομ2
!Ο,τι προβλημα αντιμετωπήσετε αναφέρετέ το μου...

ΠΡΟΓΡΑΜΜΑ Battleships
ΑΡΧΗ
  κάλεσε παιχνίδι
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
ΔΙΑΔΙΚΑΣΙΑ ταμπλό
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: αχ,αψ,β,γ,θ_ψ[10],ψ,χ,επα
  ΧΑΡΑΚΤΗΡΕΣ:θ_χ[10]
ΑΡΧΗ
  θ_χ[1] <-- 'A'
  θ_χ[2] <-- 'B'
  θ_χ[3] <-- 'C'
  θ_χ[4] <-- 'D'
  θ_χ[5] <-- 'E'
  θ_χ[6] <-- 'F'
  θ_χ[7] <-- 'G'
  θ_χ[8] <-- 'H'
  θ_χ[9] <-- 'I'
  θ_χ[10] <-- 'J'

  επα <-- 0                   
  β <-- 2
  χ <-- 1
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΙΑ αχ από 1 μέχρι 11
      ΓΙΑ αψ από 2 μέχρι 21
        ΑΝ αχ=1 τοτε
          αν αψ MOD 2=0 τότε
            ΠΗΓΑΙΝΕ_ΧΥ β-2,αψ
            ΓΡΑΨΕ  θ_χ[χ]
            ΠΗΓΑΙΝΕ_ΧΥ β,αψ
            ΓΡΑΨΕ '|'
            χ <-- χ+1
          ΤΕΛΟΣ_ΑΝ
        ΑΛΛΙΩΣ
          ΠΗΓΑΙΝΕ_ΧΥ β,αψ
          ΓΡΑΨΕ '|'
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      β <-- β+3
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    β <-- 43
    χ <-- 1
    επα <-- επα+1
  ΜΕΧΡΙΣ_ΟΤΟΥ επα=2

  ψ <-- 1
  β <-- 2
  γ <-- 1
  για αχ από 1 μέχρι 11
    ΓΙΑ αψ από 1 μέχρι 10
      αν αχ=11 τοτε
        ΠΗΓΑΙΝΕ_ΧΥ β,γ
        ΓΡΑΨΕ ' --'
        ΠΗΓΑΙΝΕ_ΧΥ β,γ+1
        ΓΡΑΨΕ '',ψ
        ψ <-- ψ+1
      ΑΛΛΙΩΣ
        ΠΗΓΑΙΝΕ_ΧΥ β,γ
        ΓΡΑΨΕ ' --'
      ΤΕΛΟΣ_ΑΝ
      β <-- β+3
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    β <-- 2
    γ <-- γ+2
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ψ <-- 1
  β <-- 43
  γ <-- 1
  για αχ από 1 μέχρι 11
    ΓΙΑ αψ από 1 μέχρι 10
      αν αχ=11 τοτε
        ΠΗΓΑΙΝΕ_ΧΥ β,γ
        ΓΡΑΨΕ ' --'
        ΠΗΓΑΙΝΕ_ΧΥ β,γ+1
        ΓΡΑΨΕ '',ψ
        ψ <-- ψ+1
      ΑΛΛΙΩΣ
        ΠΗΓΑΙΝΕ_ΧΥ β,γ
        ΓΡΑΨΕ ' --'
      ΤΕΛΟΣ_ΑΝ
      β <-- β+3
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    β <-- 43                               
    γ <-- γ+2
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

ΔΙΑΔΙΚΑΣΙΑ παιχνίδι                 

ΜΕΤΑΒΛΗΤΕΣ

  ΠΡΑΓΜΑΤΙΚΕΣ: κ_π1,απα,κ_π2,υπολ
  ΑΚΕΡΑΙΕΣ: χ,επιλ_χ[101],επιλ_ψ[101],θεσ_πλ_χ_π[17],θεσ_πλ_ψ_π[17],θεσ_πλ_χ_π2[17],θεσ_πλ_ψ_π2[17]
  ΑΚΕΡΑΙΕΣ:θ_χ,θ_ψ,απαντ,κ,λ,επιλχ,επιλψ,θεση,προ[300],δ,μεγεθ,ψ
  ΛΟΓΙΚΕΣ: προτο,αλλαγη,υπαρχ,στοχος
  ΧΑΡΑΚΤΗΡΕΣ:ονομ1,ονομ2,κατ,εγγ

  ΑΡΧΕΙΑ ΧΑΡΑΚΤΗΡΩΝ: π1,π2
  ΑΡΧΕΙΑ ΑΚΕΡΑΙΩΝ: Θεση_κ,θ1,θ2

ΑΡΧΗ

  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ Θεση_κ ,'C:\POSITION.dll'
  ΑΝ ΥΠΑΡΧΕΙ_ΑΡΧΕΙΟ('C:\POSITION.dll')=ΨΕΥΔΗΣ ΤΟΤΕ
    ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ Θεση_κ
    ΚΛΕΙΣΕ_ΑΡΧΕΙΟ Θεση_κ
  ΤΕΛΟΣ_ΑΝ


  ΠΗΓΑΙΝΕ_ΧΥ 0,8
  ΓΡΑΨΕ '|'
  ΓΡΑΨΕ '|'

  ΠΗΓΑΙΝΕ_ΧΥ 79,8
  ΓΡΑΨΕ '|'
  ΠΗΓΑΙΝΕ_ΧΥ 79,9
  ΓΡΑΨΕ '|'

  ΠΗΓΑΙΝΕ_ΧΥ 18,3
  ΓΡΑΨΕ 'Καλωσήρθατε στο BattleShips v2.(lan).'
  ΠΗΓΑΙΝΕ_ΧΥ 0,6
  ΓΡΑΨΕ 'Ακολουθήστε τα παρακάτω βήματα.'
  ΠΗΓΑΙΝΕ_ΧΥ 0,7
  ΓΡΑΨΕ '==============================================================================='
  ΠΗΓΑΙΝΕ_ΧΥ 3,8
  ΓΡΑΨΕ_ '1.Δώσε το όνομά σου (μικρότερο από 7 γράμματα):'
  ΠΗΓΑΙΝΕ_ΧΥ 3,9
  ΓΡΑΨΕ_ '3.Πάτα [3] αν είσαι έτοιμος για την αρχή του παιχνιδιού ή [4] για έξοδο.( )'
  ΠΗΓΑΙΝΕ_ΧΥ 0,10
  ΓΡΑΨΕ '==============================================================================='


  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΠΗΓΑΙΝΕ_ΧΥ 51,8
    ΓΡΑΨΕ '                           '
    ΠΗΓΑΙΝΕ_ΧΥ 51,8
    ΔΙΑΒΑΣΕ  ονομ1
  ΜΕΧΡΙΣ_ΟΤΟΥ ονομ1[ ΜΗΚΟΣ_ΧΑΡ(ονομ1)] <>' ' και ΜΗΚΟΣ_ΧΑΡ(ονομ1)<7


  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΠΗΓΑΙΝΕ_ΧΥ 76,9
    ΓΡΑΨΕ ''
    ΠΗΓΑΙΝΕ_ΧΥ 76,9
    ΔΙΑΒΑΣΕ απα
  ΜΕΧΡΙΣ_ΟΤΟΥ απα=3 ή απα =4

  ΑΝ απα=4 τοτε
    ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
    ΠΗΓΑΙΝΕ_ΧΥ 35,12
    γράψε'Αντίο....'
    ΓΙΑ χ από 1 μέχρι 19999999
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΚΛΕΙΣΕ_ΠΑΡΑΘΥΡΟ
  ΤΕΛΟΣ_ΑΝ

  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ π1 ,'C:\Documents and Settings\All Users\Documents\P1.dll'    !Διορθώστε την θέση του κοινόχροιστου αν είναι λάθος
  ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ π1
  ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ π1, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(π1)+1
  ΓΡΑΨΕ_ΑΡΧΕΙΟ π1,ονομ1
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ π1

  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ θ1 ,'C:\Documents and Settings\All Users\Documents\81.dll'    !Διορθώστε την θέση του κοινόχροιστου αν είναι λάθος
  ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ θ1
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ θ1


  υπαρχ <-- ΨΕΥΔΗΣ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
    ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ θ2 ,'C:\Documents and Settings\All Users\Documents\82.dll'    !Διορθώστε την θέση του κοινόχροιστου αν είναι λάθος
    ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ π2 ,'C:\Documents and Settings\All Users\Documents\P2.dll'    !Διορθώστε την θέση του κοινόχροιστου αν είναι λάθος
    ΑΝ ΥΠΑΡΧΕΙ_ΑΡΧΕΙΟ('C:\Documents and Settings\All Users\Documents\P2.dll')= ΑΛΗΘΗΣ και ΥΠΑΡΧΕΙ_ΑΡΧΕΙΟ('C:\Documents and Settings\All Users\Documents\82.dll')= ΑΛΗΘΗΣ ΤΟΤΕ
      υπαρχ <-- ΑΛΗΘΗΣ
    ΑΛΛΙΩΣ
      κατ <-- 'Περιμένετε μέχρις ότου να συνδεθεί και ο άλλος παίκτης...'
      ΚΑΛΕΣΕ μπαρα(κατ)
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ υπαρχ= ΑΛΗΘΗΣ

  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
  ΚΑΛΕΣΕ ταμπλό

  κ_π1 <-- 0
  χ <-- 1
  ψ <-- 1
  δ <-- 1
  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ π2
  ΟΣΟ ΤΕΛΟΣ_ΑΡΧΕΙΟΥ(π2)= ΨΕΥΔΗΣ επανάλαβε
    ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ π2,εγγ
    αν δ=1 τοτε
      ονομ2 <-- εγγ
    ΤΕΛΟΣ_ΑΝ
    δ <-- δ+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ π2

 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ θεση_κ                       !Ανοιγμα έτοιμων θέσεων
  αν ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(Θεση_κ)>0 τότε
    ΠΗΓΑΙΝΕ_ΧΥ 0,23
    ΓΡΑΨΕ_ 'Φαίνεται ότι υπάρχουν διαθέσιμες θέσεις για τα καράβια.Για να τα φορτώσεις πάτα [1] αλλιώς αλλο για συνέχεια:'
    ΔΙΑΒΑΣΕ_ απαντ
    ΠΗΓΑΙΝΕ_ΧΥ 0,23
    ΓΡΑΨΕ '                                                                                                                       '
  ΤΕΛΟΣ_ΑΝ
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ  θεση_κ


  ΟΣΟ κ_π1<17 επανάλαβε

    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΠΗΓΑΙΝΕ_ΧΥ 34,2
      ΓΡΑΨΕ ονομ1
      ΠΗΓΑΙΝΕ_ΧΥ 34,3
      ΓΡΑΨΕ κ_π1,'χ @'


      ΠΗΓΑΙΝΕ_ΧΥ 74,2
      ΓΡΑΨΕ ονομ2

      ΑΝΟΙΞΕ_ΑΡΧΕΙΟ π2
      ΟΣΟ ΤΕΛΟΣ_ΑΡΧΕΙΟΥ(π2)= ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
        ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ π2,εγγ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΚΛΕΙΣΕ_ΑΡΧΕΙΟ π2
      ΠΗΓΑΙΝΕ_ΧΥ 74,3

      αν εγγ=ονομ2 τοτε
        ΓΡΑΨΕ 'Θέσεις'
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ εγγ
      ΤΕΛΟΣ_ΑΝ



      ΑΝΟΙΞΕ_ΑΡΧΕΙΟ θ1
      αν απαντ=1 τότε  ! !Στησιμο καραβιών παίχτη από τις έτοιμες θέσεις

        ΑΝΟΙΞΕ_ΑΡΧΕΙΟ Θεση_κ
        χ <-- 1
        ΟΣΟ ΤΕΛΟΣ_ΑΡΧΕΙΟΥ(Θεση_κ)=ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
          ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ Θεση_κ, θ_χ
          θεσ_πλ_χ_π[χ] <-- θ_χ

          ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ θ1, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(θ1)+1
          ΓΡΑΨΕ_ΑΡΧΕΙΟ θ1,θ_χ

          ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ Θεση_κ, θ_ψ
          θεσ_πλ_ψ_π[χ] <-- θ_ψ

          ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ θ1, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(θ1)+1
          ΓΡΑΨΕ_ΑΡΧΕΙΟ θ1,θ_ψ

          ΠΗΓΑΙΝΕ_ΧΥ  θεσ_πλ_χ_π[χ], θεσ_πλ_ψ_π[χ]
          ΓΡΑΨΕ '@'
          χ <-- χ+1
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
        κ_π1 <-- 17
        ΠΗΓΑΙΝΕ_ΧΥ 34,3
        ΓΡΑΨΕ κ_π1,'χ @'
        απα <-- 1
        ΚΛΕΙΣΕ_ΑΡΧΕΙΟ Θεση_κ

      ΑΛΛΙΩΣ                !Στησιμο καραβιών παίχτη
        ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
          ΠΗΓΑΙΝΕ_ΧΥ 0,23
          ΓΡΑΨΕ '                                                                                        '
          ΠΗΓΑΙΝΕ_ΧΥ 0,23
          ΓΡΑΨΕ_ 'Δώσε συντεταγμένες για το στήσιμο των καραβιών σου (χ,ψ):'
          ΔΙΑΒΑΣΕ_ επιλ_χ[χ],επιλ_ψ[χ]
          ΠΗΓΑΙΝΕ_ΧΥ 40,23
          ΓΡΑΨΕ '                    '
        ΜΕΧΡΙΣ_ΟΤΟΥ επιλ_χ[χ]>0 και επιλ_χ[χ]<11 και επιλ_ψ[χ]>0 και επιλ_ψ[χ]<11
        προτο <-- ΨΕΥΔΗΣ
        αλλαγη <-- ΨΕΥΔΗΣ
        αν χ>1 τότε                      !έλενγχος γνησιότητας των θέσεων
          ψ <-- 1
          ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
            αν  επιλ_χ[χ]<>επιλ_χ[χ-ψ] ή επιλ_ψ[χ]<>επιλ_ψ[χ-ψ] τότε
              προτο <-- ΑΛΗΘΗΣ
            ΑΛΛΙΩΣ
              αλλαγη <-- ΑΛΗΘΗΣ
            ΤΕΛΟΣ_ΑΝ
            ψ <-- ψ+1
          μέχρις_ότου ψ=χ
        ΤΕΛΟΣ_ΑΝ

        αν προτο=ΑΛΗΘΗΣ και αλλαγη= ΨΕΥΔΗΣ ή χ=1 τοτε

          θεσ_πλ_χ_π[χ] <-- επιλ_χ[χ]*3
          θεσ_πλ_ψ_π[χ] <-- επιλ_ψ[χ]*2


          ΠΗΓΑΙΝΕ_ΧΥ 0,23
          ΓΡΑΨΕ '                                                                                         '
          ΠΗΓΑΙΝΕ_ΧΥ θεσ_πλ_χ_π[χ],θεσ_πλ_ψ_π[χ]
          ΓΡΑΨΕ '@'
          ΠΗΓΑΙΝΕ_ΧΥ 0,23
          ΓΡΑΨΕ_ 'Είστε ικανοποιημένος με αυτήν σου τη θέση? Αν όχι πάτα 11 αλλιώς αλλο.'         !Επαλήθευση θέσης
          ΔΙΑΒΑΣΕ απα
          αν απα=11 τότε
            ΠΗΓΑΙΝΕ_ΧΥ 0,23
            ΓΡΑΨΕ '                                                                                         '
            ΠΗΓΑΙΝΕ_ΧΥ θεσ_πλ_χ_π[χ],θεσ_πλ_ψ_π[χ]
            ΓΡΑΨΕ ' '
          ΑΛΛΙΩΣ
            ΠΗΓΑΙΝΕ_ΧΥ θεσ_πλ_χ_π[χ],θεσ_πλ_ψ_π[χ]
            ΓΡΑΨΕ '@'

            ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ θ1, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(θ1)+1
            ΓΡΑΨΕ_ΑΡΧΕΙΟ θ1, θεσ_πλ_χ_π[χ]

            ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ θ1, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(θ1)+1
            ΓΡΑΨΕ_ΑΡΧΕΙΟ θ1,θεσ_πλ_ψ_π[χ]

            ΠΗΓΑΙΝΕ_ΧΥ 0,23
            ΓΡΑΨΕ '                                                                                         '
            κ_π1 <-- κ_π1+1
          ΤΕΛΟΣ_ΑΝ
        ΑΛΛΙΩΣ
          αν χ>1 τότε
            απα <-- 11
          ΤΕΛΟΣ_ΑΝ
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΑΝ

    ΜΕΧΡΙΣ_ΟΤΟΥ απα<>11
    χ <-- χ+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ θ1

  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ π1
  κατ <-- 'Έτοιμος'
  ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ π1, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(π1)+1
  ΓΡΑΨΕ_ΑΡΧΕΙΟ π1,κατ
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ π1

  κατ <-- κατ+'.Αναμαίνετε να συνδεθεί ο\η αλλος παίκτης...'

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΠΗΓΑΙΝΕ_ΧΥ 0,23
    ΓΡΑΨΕ '                                                                                         '
    ΠΗΓΑΙΝΕ_ΧΥ 0,23
    ΓΡΑΨΕ κατ
    ΓΙΑ δ από 1 μέχρι 10
      ΠΗΓΑΙΝΕ_ΧΥ 52+δ ,23
      ΓΡΑΨΕ_ ΧΑΡ(396)
      ΓΙΑ ψ από 1 μέχρι 10000000
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

    ΑΝΟΙΞΕ_ΑΡΧΕΙΟ π2
    ΟΣΟ ΤΕΛΟΣ_ΑΡΧΕΙΟΥ(π2)= ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
      ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ π2,εγγ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΚΛΕΙΣΕ_ΑΡΧΕΙΟ π2

  ΜΕΧΡΙΣ_ΟΤΟΥ εγγ='Έτοιμος'
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!  αναγνωση θέσεων π2
  χ <-- 1
  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ θ2
  ΟΣΟ ΤΕΛΟΣ_ΑΡΧΕΙΟΥ(θ2)= ΨΕΥΔΗΣ επανάλαβε
    ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ θ2,θ_χ
    θεσ_πλ_χ_π2[χ] <-- θ_χ
    ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ θ2,θ_ψ
    θεσ_πλ_ψ_π2[χ] <-- θ_ψ
    χ <-- χ+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  μεγεθ <-- ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(θ2)
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ θ2
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!1

  υπολ <-- 100

  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ θ2
  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ θ1
  κ_π2 <-- 17
  κ <-- 1
  λ <-- 1
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!εδώ να αντιστρέψετε την επίθεση με την άμυνα για τον παίκτη 2

    ΠΗΓΑΙΝΕ_ΧΥ 74,2
    ΓΡΑΨΕ ονομ2                                !αρχή επίθεσης παίκτη
    ΠΗΓΑΙΝΕ_ΧΥ 74,3
    ΓΡΑΨΕ κ_π2,'χ @'
    στοχος <-- ΨΕΥΔΗΣ

    ΠΗΓΑΙΝΕ_ΧΥ 0,23
    ΓΡΑΨΕ '                                                                                    '
    ΠΗΓΑΙΝΕ_ΧΥ 34,2
    ΓΡΑΨΕ  ονομ1
    ΠΗΓΑΙΝΕ_ΧΥ 34,3
    ΓΡΑΨΕ κ_π1,'χ @'

    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΠΗΓΑΙΝΕ_ΧΥ 0,23
        ΓΡΑΨΕ '                                                                                              '
        ΠΗΓΑΙΝΕ_ΧΥ 0,23
        ΓΡΑΨΕ_ 'Δώσε (χ,ψ) κτυπήματος για την επίθεσή σου: '
        ΔΙΑΒΑΣΕ_ επιλ_χ[κ],επιλ_ψ[κ]
      ΜΕΧΡΙΣ_ΟΤΟΥ επιλ_χ[κ]<11 και επιλ_χ[κ]>0 και επιλ_ψ[κ]<11 και επιλ_ψ[κ]>0

      προτο <-- ΨΕΥΔΗΣ
      αλλαγη <-- ΨΕΥΔΗΣ

      αν κ>1 τότε
        ψ <-- 1
        ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
          αν  επιλ_χ[κ]<>επιλ_χ[κ-ψ] ή επιλ_ψ[κ]<>επιλ_ψ[κ-ψ] τότε
            προτο <-- ΑΛΗΘΗΣ
          ΑΛΛΙΩΣ
            αλλαγη <-- ΑΛΗΘΗΣ
          ΤΕΛΟΣ_ΑΝ
          ψ <-- ψ+1
        μέχρις_ότου ψ=κ
      ΤΕΛΟΣ_ΑΝ

    ΜΕΧΡΙΣ_ΟΤΟΥ προτο= ΑΛΗΘΗΣ και αλλαγη= ΨΕΥΔΗΣ ή κ=1

    επιλχ <-- επιλ_χ[κ]*3
    επιλψ <-- επιλ_ψ[κ]*2
    στοχος <-- ΨΕΥΔΗΣ
    κ <-- κ+1
    χ <-- 1
    ΟΣΟ χ<18 επαναλαβε
      αν επιλχ=θεσ_πλ_χ_π2[χ] και επιλψ=θεσ_πλ_ψ_π2[χ] τότε
        στοχος <-- ΑΛΗΘΗΣ
        θεση <-- χ

      ΤΕΛΟΣ_ΑΝ
      χ <-- χ+1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

    ΑΝ στοχος=ΑΛΗΘΗΣ τοτε

      ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ θ1,  ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(θ1)+1
      ΓΡΑΨΕ_ΑΡΧΕΙΟ θ1,θεση

      κάλεσε ήχο
      ΠΗΓΑΙΝΕ_ΧΥ επιλχ+41,επιλψ
      ΓΡΑΨΕ '!'
      ΠΗΓΑΙΝΕ_ΧΥ 0,23
      ΓΡΑΨΕ '                                                                                            '
      ΠΗΓΑΙΝΕ_ΧΥ 0,23
      ΓΡΑΨΕ 'Εβγε...'

      ΓΙΑ ψ από 1 μέχρι 4
        ΚΑΛΕΣΕ καθ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      κ_π2 <-- κ_π2-1
    ΑΛΛΙΩΣ

      θεση <-- 0
      ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ θ1,  ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(θ1)+1
      ΓΡΑΨΕ_ΑΡΧΕΙΟ θ1,επιλχ
      ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ θ1,  ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(θ1)+1
      ΓΡΑΨΕ_ΑΡΧΕΙΟ θ1,επιλψ
      ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ θ1,  ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(θ1)+1
      ΓΡΑΨΕ_ΑΡΧΕΙΟ θ1,θεση

      ΠΗΓΑΙΝΕ_ΧΥ  επιλχ+41,επιλψ
      ΓΡΑΨΕ '0'

      ΠΗΓΑΙΝΕ_ΧΥ 0,23
      ΓΡΑΨΕ '                                                                                            '
      ΠΗΓΑΙΝΕ_ΧΥ 0,23
      ΓΡΑΨΕ 'Αστόχησες....'
      ΓΙΑ ψ από 1 μέχρι 4
        ΚΑΛΕΣΕ καθ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΑΝ

!τέλος επίθεσης
!!!!!!!!!!!!!!!!!!!!!!!!!!!!1!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!11
!Αρχή άμυνας
!εδώ θα πάει η επίθεση για τον παίκτη 2

    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

      ΠΗΓΑΙΝΕ_ΧΥ 0,23
      ΓΡΑΨΕ '                                                                                         '
      ΠΗΓΑΙΝΕ_ΧΥ 0,23
      ΓΡΑΨΕ 'Η σειρά του\της ',ονομ2,' τώρα...'
      ΓΙΑ δ από 1 μέχρι 10
        ΠΗΓΑΙΝΕ_ΧΥ 52+δ ,23
        ΓΡΑΨΕ_ ΧΑΡ(396)
        ΓΙΑ ψ από 1 μέχρι 10000000
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΜΕΧΡΙΣ_ΟΤΟΥ  μεγεθ< ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(θ2)

    μεγεθ <-- ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(θ2)

    λ <-- 0
    ΟΣΟ ΤΕΛΟΣ_ΑΡΧΕΙΟΥ(θ2)= ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
      λ <-- λ+1
      ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ θ2,προ[λ]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ


    αν προ[λ]<>0 τότε     
      κάλεσε ήχο
      ΠΗΓΑΙΝΕ_ΧΥ θεσ_πλ_χ_π[προ[λ]],θεσ_πλ_ψ_π[προ[λ]]
      ΓΡΑΨΕ '!'
      ΠΗΓΑΙΝΕ_ΧΥ 0,23
      ΓΡΑΨΕ '                                                                                                   '
      ΠΗΓΑΙΝΕ_ΧΥ 0,23
      ΓΡΑΨΕ 'Κτυπήθηκες'                       
      ΓΙΑ ψ από 1 μέχρι 4
        ΚΑΛΕΣΕ καθ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      κ_π1 <-- κ_π1-1

    ΑΛΛΙΩΣ

      επιλχ <-- προ[λ-2]
      επιλψ <-- προ[λ-1]

      ΠΗΓΑΙΝΕ_ΧΥ  επιλχ,επιλψ
      ΓΡΑΨΕ '0'
      ΠΗΓΑΙΝΕ_ΧΥ 0,23
      ΓΡΑΨΕ '                                                                                                    '
      ΠΗΓΑΙΝΕ_ΧΥ 0,23
      ΓΡΑΨΕ 'Ουφ....'
      ΓΙΑ ψ από 1 μέχρι 4
        ΚΑΛΕΣΕ καθ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΑΝ

    υπολ <-- υπολ-1

!Τελος άμυνας
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! :mrgreen:  :mrgreen:  :mrgreen:  :mrgreen:  :mrgreen:
  ΜΕΧΡΙΣ_ΟΤΟΥ κ_π1=0 ή υπολ=0 ή κ_π2=0
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ θ1
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ θ2


  αν κ_π1>κ_π2  τότε
    κατ <-- 'Συνγχαρητήρια, νίκησες !'
  ΑΛΛΙΩΣ_ΑΝ κ_π1=κ_π2  τότε
    κατ <-- '   Ισοπαλία...'
  ΑΛΛΙΩΣ
    κατ <-- 'Δυστυχώς ,έχασες...'
  ΤΕΛΟΣ_ΑΝ
  απα <-- 0
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
    ΠΗΓΑΙΝΕ_ΧΥ 20,8
    ΓΡΑΨΕ '==========================================='
    ΠΗΓΑΙΝΕ_ΧΥ 20,9
    ΓΡΑΨΕ '|   /\         The Game is over!          |'
    ΠΗΓΑΙΝΕ_ΧΥ 20,10
    ΓΡΑΨΕ '|  /! \   ',κατ
    ΠΗΓΑΙΝΕ_ΧΥ 20,11
    ΓΡΑΨΕ '| ------  Για συνέχεια πάτα [1].          |'
    ΠΗΓΑΙΝΕ_ΧΥ 20,12
    ΓΡΑΨΕ '==========================================='
    ΠΗΓΑΙΝΕ_ΧΥ 62,10
    ΓΡΑΨΕ '|'
    ΠΗΓΑΙΝΕ_ΧΥ 53,11
    ΔΙΑΒΑΣΕ_ απα
  ΜΕΧΡΙΣ_ΟΤΟΥ απα=1
  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ

  ΔΙΑΓΡΑΨΕ_ΑΡΧΕΙΟ θ1
  ΔΙΑΓΡΑΨΕ_ΑΡΧΕΙΟ π1

  ΚΑΛΕΣΕ παιχνίδι
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
ΔΙΑΔΙΚΑΣΙΑ καθ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: α
ΑΡΧΗ
  ΓΙΑ α από 1 μέχρι 10000000
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
ΔΙΑΔΙΚΑΣΙΑ ήχο
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: α
ΑΡΧΗ
  ΓΙΑ α από 1 μέχρι 5
    ΓΡΑΨΕ_ χαρ(7)
    κάλεσε καθ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!11
ΔΙΑΔΙΚΑΣΙΑ μπαρα(κατασταση)
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: κατασταση
  ΑΚΕΡΑΙΕΣ: α,β
ΑΡΧΗ
  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ

  ΠΗΓΑΙΝΕ_ΧΥ 15,3
  ΓΡΑΨΕ κατασταση
  ΓΙΑ β από 1 μέχρι 20
    ΠΗΓΑΙΝΕ_ΧΥ 25+β,6
    ΓΡΑΨΕ_ ΧΑΡ(396)
    ΓΙΑ α από 1 μέχρι 1000000
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters