Τώρα είναι Πέμ 18 Ιούλ 2019 04:15 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 11 Απρ 2010 06:49 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 11 Απρ 2010 06:28 pm
Δημοσιεύσεις: 2
Καλησπερα παιδια, εχω ενα προβλημα με την Γλωσσομαθεια
εχω γραψει ενα προγραμμα, ετσι απλα για να περασει η ωρα, του οποιου η λογικη ειναι οτι σε ρωταει τι ειδους μουσικης θελεις να ακουσεις και αναλογα με το τι απαντησεις σου ανοιγει ενα αρχειο (mp3).
το προβλημα ειναι ομως πως μου βγαζει ενα σφαλμα:
"Γραμμή 25 - Αναμενόταν βαθμωτή παράσταση"

δεν εχω ιδεα τι εννοει μιας και ειμαι αρχαριος
μπορει να με βοηθησει καποιος??
εδω το προγραμμα:

Κώδικας:
 1.  ΠΡΟΓΡΑΜΜΑ JukeBox
 2.  ΜΕΤΑΒΛΗΤΕΣ
 3.    ΧΑΡΑΚΤΗΡΕΣ: Ειδος, Απαντ_1
 4.    ΛΟΓΙΚΕΣ: Κιαλο
 5.  ΑΡΧΗ
 6.    Κιαλο <-- ΑΛΗΘΗΣ
 7.    ΓΡΑΨΕ 'ΚΑΛΩΣ ΗΡΘΕΣ ΣΤΟ JukeBox v1.0'
 8.    ΓΡΑΨΕ 'Υπολειπεται ενα βήμα ακομη για την εγκατασταση του JukeBox'
 9.    ΓΡΑΨΕ 'Ακολουθησε τις οδηγιες'
 10.    ΓΡΑΨΕ 'Ο Φακελος JukeBox βρισκεται στην θεση C:\Program Files\ ? YES/NO?'
 11.    ΔΙΑΒΑΣΕ Απαντ_1
 12.    ΟΣΟ Απαντ_1<>'YES' ΚΑΙ Απαντ_1<>'NO' ΕΠΑΝΑΛΑΒΕ
 13.      ΓΡΑΨΕ 'Μη εγκηρη απαντηση, απαντησε με YES η NO'
 14.      ΔΙΑΒΑΣΕ Απαντ_1
 15.    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 16.    ΑΝ Απαντ_1='YES' ΤΟΤΕ
 17.      ΓΡΑΨΕ 'Το πρόγραμμα ειναι ετοιμο για χρηση, καλη διασκεδαση!'
 18.    ΑΛΛΙΩΣ
 19.      ΓΡΑΨΕ 'Παρακαλω μετεφερε τον φακελο Jukebox στην θεση C:\Program Files\ και επανεκκινησε το προγραμμα '
 20.    ΤΕΛΟΣ_ΑΝ
 21.    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
 22.      ΓΡΑΨΕ 'Ποιο ειδος μουσικης θελεις να ακουσεις? (εισαγωγη με λατινικους χαρακτηρες)'
 23.      ΓΡΑΨΕ 'Πληκτρολογησε "list" για να δεις την λιστα των δiαθεσιμων ειδων μουσικης'
 24.      ΔΙΑΒΑΣΕ Ειδος
 25.      ΕΠΙΛΕΞΕ Ειδος
 26.        ΠΕΡΙΠΤΩΣΗ list
 27.          ΓΡΑΨΕ 'Λιστα των ειδων: rock,reggae,pop,rap,metal,rnb,club,trance,new_age,trip_hop,instrumental'
 28.        ΠΕΡΙΠΤΩΣΗ trance
 29.          ΕΚΤΕΛΕΣΕ C:\Program Files\Jukebox\Silence.mp3
 30.        ΠΕΡΙΠΤΩΣΗ reggae
 31.          ΕΚΤΕΛΕΣΕ C:\Program Files\Jukebox\Pound Power.mp3
 32.        ΠΕΡΙΠΤΩΣΗ rock
 33.          ΕΚΤΕΛΕΣΕ C:\Program Files\Jukebox\Time of Dying.mp3
 34.        ΠΕΡΙΠΤΩΣΗ pop
 35.          ΕΚΤΕΛΕΣΕ C:\Program Files\Jukebox\Circus.mp3
 36.        ΠΕΡΙΠΤΩΣΗ metal
 37.          ΕΚΤΕΛΕΣΕ C:\Program Files\Jukebox\All These Things I Hate.mp3
 38.        ΠΕΡΙΠΤΩΣΗ rap
 39.          ΕΚΤΕΛΕΣΕ C:\Program Files\Jukebox\Go To Sleep.mp3
 40.        ΠΕΡΙΠΤΩΣΗ new_age
 41.          ΕΚΤΕΛΕΣΕ C:\Program Files\Jukebox\I Love You - I ll Kill You.mp3
 42.        ΠΕΡΙΠΤΩΣΗ rnb
 43.          ΕΚΤΕΛΕΣΕ C:\Program Files\Jukebox\Trick Me.mp3
 44.        ΠΕΡΙΠΤΩΣΗ club
 45.          ΕΚΤΕΛΕΣΕ C:\Program Files\Jukebox\Who Wants To Be Alone.mp3
 46.        ΠΕΡΙΠΤΩΣΗ trip_hop
 47.          ΕΚΤΕΛΕΣΕ C:\Program Files\Jukebox\Black coffee.mp3
 48.        ΠΕΡΙΠΤΩΣΗ instrumental
 49.          ΕΚΤΕΛΕΣΕ C:\Program Files\Jukebox\Les Djins - Trentemoller rmx.mp3
 50.        ΑΛΛΙΩΣ
 51.          ΓΡΑΨΕ 'Μη εγκηρη απαντηση'
 52.      ΤΕΛΟΣ_ΕΠΙΛΟΓΩΝ
 53.      ΓΡΑΨΕ 'Θελεις να ακουσεις κι αλλο κομματι? YES/NO?'
 54.      ΔΙΑΒΑΣΕ Απαντ_2
 55.      ΟΣΟ Απαντ_2<>'YES' ΚΑΙ Απαντ_2<>'NO' ΕΠΑΝΑΛΑΒΕ
 56.        ΓΡΑΨΕ 'Μη εγκηρη απαντηση, απαντησε με YES η NO'
 57.        ΔΙΑΒΑΣΕ Απαντ_2
 58.      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ                     
 59.      ΑΝ Απαντ_2='NO' ΤΟΤΕ
 60.        Κιαλο <-- ΨΕΥΔΗΣ
 61.      ΤΕΛΟΣ_ΑΝ
 62.    ΜΕΧΡΙΣ_ΟΤΟΥ Κιαλο=ΨΕΥΔΗΣ
 63.    ΚΛΕΙΣΕ_ΠΑΡΑΘΥΡΟ
 64.  ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Κορυφή
 Προφίλ  
 
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 11 Απρ 2010 10:54 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 30 Μάιος 2008 09:46 pm
Δημοσιεύσεις: 49
Παράθεση:
ΣΤΟΙΧΕΙΟ: Δομή επιλογής "ΕΠΙΛΕΞΕ"
ΣΥΝΤΑΞΗ: ΕΠΙΛΕΞΕ ΟΝΟΜΑ_ΜΕΤΑΒΛΗΤΗΣ_Η_ΟΝΟΜΑ_ΠΑΡΑΣΤΑΣΗΣ

ΠΕΡΙΠΤΩΣΗ ΤΙΜΗ_Α1, ΤΙΜΗ_Α2, ... , ΤΙΜΗ_Αn

[ΕΝΤΟΛΕΣ]

ΠΕΡΙΠΤΩΣΗ ΤΙΜΗ_Β1, ΤΙΜΗ_Β2, ... , ΤΙΜΗ_Βn

[ΕΝΤΟΛΕΣ]

: :

ΠΕΡΙΠΤΩΣΗ ΤΙΜΗ_Ν1, ΤΙΜΗ_Ν2, ... , ΤΙΜΗ_Νn

[ΕΝΤΟΛΕΣ]

ΠΕΡΙΠΤΩΣΗ ΑΛΛΙΩΣ

[ΕΝΤΟΛΕΣ]

ΤΕΛΟΣ_ΕΠΙΛΟΓΩΝ

ή

ΕΠΙΛΕΞΕ ΟΝΟΜΑ_ΜΕΤΑΒΛΗΤΗΣ_Η_ΟΝΟΜΑ_ΠΑΡΑΣΤΑΣΗΣ

ΠΕΡΙΠΤΩΣΗ ΤΙΜΗ_Α1, ΤΙΜΗ_Α2, ... , ΤΙΜΗ_Αn

[ΕΝΤΟΛΕΣ]

ΠΕΡΙΠΤΩΣΗ ΤΙΜΗ_Β1, ΤΙΜΗ_Β2, ... , ΤΙΜΗ_Βn

[ΕΝΤΟΛΕΣ]

: :

ΠΕΡΙΠΤΩΣΗ ΤΙΜΗ_Ν1, ΤΙΜΗ_Ν2, ... , ΤΙΜΗ_Νn

[ΕΝΤΟΛΕΣ]

ΤΕΛΟΣ_ΕΠΙΛΟΓΩΝ


ΠΑΡΑΔΕΙΓΜΑ: ΕΠΙΛΕΞΕ x
ΠΕΡΙΠΤΩΣΗ 1
ΓΡΑΨΕ 'Ένα'
ΠΕΡΙΠΤΩΣΗ 2
ΓΡΑΨΕ 'Δύο'
ΠΕΡΙΠΤΩΣΗ ΑΛΛΙΩΣ
ΓΡΑΨΕ 'Ούτε ένα ούτε δύο'
ΤΕΛΟΣ_ΕΠΙΛΟΓΩΝ

ΕΠΙΛΕΞΕ 5*α-2
ΠΕΡΙΠΤΩΣΗ 1..9
ΓΡΑΨΕ 'Μονοψήφιος'
ΠΕΡΙΠΤΩΣΗ 10..99
ΓΡΑΨΕ 'Διψήφιος'
ΠΕΡΙΠΤΩΣΗ 100..999, 50000
ΓΡΑΨΕ 'Τριψήφιος ή 50000'
ΤΕΛΟΣ_ΕΠΙΛΟΓΩΝ

ΣΧΟΛΙΑ: Η ΕΠΙΛΕΞΕ μπορεί να ελέγξει τις τιμές μόνο βαθμωτών μεταβλητών/παραστάσεων (δηλ. ΑΚΕΡΑΙΕΣ & ΛΟΓΙΚΕΣ).

Όπως λέει και η βοήθεια για την επίλεξε (από πάνω) δεν μπορείς να βάλεις ΕΠΙΛΕΞΕ αβ όπου αβ είναι μια μεταβλητή χαρακτήρων. Μπορείς να αλλάξεις όλη την επίλεξε με μια Αν για να κάνεις την δουλειά σου.
ΥΓ. Επίσης πρέπει να βάλεις ' γύρω από τα paths στην εκτέλεσε.

_________________
"Δύο πράγματα είναι ατελείωτα (άπειρα), το σύμπαν και η ανθρώπινη βλακεία, για το 1ο δεν είμαι σίγουρος." Einstein
"Τα πάντα ρει" (Τα πάντα ρέουν/αλλάζουν) Ηράκλειτος
"Μη μου τους κύκλους τάραττε" Αρχιμήδης


Κορυφή
 Προφίλ  
 
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 12 Απρ 2010 12:21 am 
Χωρίς σύνδεση

Εγγραφή: Κυρ 11 Απρ 2010 06:28 pm
Δημοσιεύσεις: 2
Ευχαριστο πολυ :D !!
...αυτο δεν το ηξερα...


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters