Τώρα είναι Παρ 18 Οκτ 2019 08:52 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 29 Απρ 2010 11:42 am 
Χωρίς σύνδεση

Εγγραφή: Τρί 22 Απρ 2008 11:05 am
Δημοσιεύσεις: 21
Παράθεση:
Κύριο προγραμμα.Θα σας βγαλει λίγο το λάδι μεχρι να το εκσφαλματώσει αλλά όποιος έχει πρόταση για να το κοντίνω είναι ευπρόσδεκτος.


Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ Battleships
ΑΡΧΗ
  κάλεσε μενού
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
ΔΙΑΔΙΚΑΣΙΑ μενού
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: απα
  ΑΚΕΡΑΙΕΣ: ι
ΑΡΧΗ
  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ

  ΠΗΓΑΙΝΕ_ΧΥ 0,8
  ΓΡΑΨΕ '|'                                        
  ΓΡΑΨΕ '|'
  ΓΡΑΨΕ '|'
  ΓΡΑΨΕ '|'
  ΠΗΓΑΙΝΕ_ΧΥ 79,8
  ΓΡΑΨΕ '|'
  ΠΗΓΑΙΝΕ_ΧΥ 79,9
  ΓΡΑΨΕ '|'
  ΠΗΓΑΙΝΕ_ΧΥ 79,10
  ΓΡΑΨΕ '|'
  ΠΗΓΑΙΝΕ_ΧΥ 79,11
  ΓΡΑΨΕ '|'
  ΠΗΓΑΙΝΕ_ΧΥ 23,5
  ΓΡΑΨΕ 'Καλωσήρθατε στο BattleShips.'
  ΠΗΓΑΙΝΕ_ΧΥ 0,7
  ΓΡΑΨΕ '==============================================================================='
  ΠΗΓΑΙΝΕ_ΧΥ 20,8
  ΓΡΑΨΕ '1.Για νέο παιχνίδι.'
  ΠΗΓΑΙΝΕ_ΧΥ 20,9
  ΓΡΑΨΕ '2.Για πληροφορίες για αυτό το παιχνίδι.'
  ΠΗΓΑΙΝΕ_ΧΥ 20,10
  ΓΡΑΨΕ '3.Για προβολή των σκορ.'
  ΠΗΓΑΙΝΕ_ΧΥ 20,11
  ΓΡΑΨΕ '4.Για έξοδο από το παιχνίδι.'
  ΠΗΓΑΙΝΕ_ΧΥ 0,12
  ΓΡΑΨΕ '==============================================================================='

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΠΗΓΑΙΝΕ_ΧΥ 1,15
    ΓΡΑΨΕ 'Δώσε την απάντησή σου:'
    διαβασε_ απα
  ΜΕΧΡΙΣ_ΟΤΟΥ απα=1 ή απα=2 ή απα=3 ή απα=4

  ΑΝ απα=1 τότε
    ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
    ΚΑΛΕΣΕ παιχνίδι
  ΑΛΛΙΩΣ_ΑΝ απα=2 τότε
    ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
    ΚΑΛΕΣΕ πληροφορίες
  ΑΛΛΙΩΣ_ΑΝ απα=3 τότε
    ΚΑΛΕΣΕ σκορ
  ΑΛΛΙΩΣ
    ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
    ΠΗΓΑΙΝΕ_ΧΥ 35,12
    γράψε'Αντίο....'
    ΓΙΑ ι από 1 μέχρι 19999999
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΚΛΕΙΣΕ_ΠΑΡΑΘΥΡΟ

  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
ΔΙΑΔΙΚΑΣΙΑ ταμπλό
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: αχ,αψ,β,γ,θ_ψ[10],ψ,χ,επα
  ΧΑΡΑΚΤΗΡΕΣ:θ_χ[10]
ΑΡΧΗ
  θ_χ[1] <-- 'A'
  θ_χ[2] <-- 'B'
  θ_χ[3] <-- 'C'
  θ_χ[4] <-- 'D'
  θ_χ[5] <-- 'E'
  θ_χ[6] <-- 'F'
  θ_χ[7] <-- 'G'
  θ_χ[8] <-- 'H'
  θ_χ[9] <-- 'I'
  θ_χ[10] <-- 'J'

  επα <-- 0
  β <-- 2
  χ <-- 1
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΙΑ αχ από 1 μέχρι 11
      ΓΙΑ αψ από 2 μέχρι 21
        ΑΝ αχ=1 τοτε
          αν αψ MOD 2=0 τότε
            ΠΗΓΑΙΝΕ_ΧΥ β-2,αψ
            ΓΡΑΨΕ  θ_χ[χ]
            ΠΗΓΑΙΝΕ_ΧΥ β,αψ
            ΓΡΑΨΕ '|'
            χ <-- χ+1
          ΤΕΛΟΣ_ΑΝ
        ΑΛΛΙΩΣ
          ΠΗΓΑΙΝΕ_ΧΥ β,αψ
          ΓΡΑΨΕ '|'
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      β <-- β+3
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    β <-- 43
    χ <-- 1
    επα <-- επα+1
  ΜΕΧΡΙΣ_ΟΤΟΥ επα=2

  ψ <-- 1
  β <-- 2
  γ <-- 1
  για αχ από 1 μέχρι 11
    ΓΙΑ αψ από 1 μέχρι 10
      αν αχ=11 τοτε
        ΠΗΓΑΙΝΕ_ΧΥ β,γ
        ΓΡΑΨΕ ' --'
        ΠΗΓΑΙΝΕ_ΧΥ β,γ+1
        ΓΡΑΨΕ ''
        ψ <-- ψ+1
      ΑΛΛΙΩΣ
        ΠΗΓΑΙΝΕ_ΧΥ β,γ
        ΓΡΑΨΕ ' --'
      ΤΕΛΟΣ_ΑΝ
      β <-- β+3
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    β <-- 2
    γ <-- γ+2
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ψ <-- 1
  β <-- 43
  γ <-- 1
  για αχ από 1 μέχρι 11
    ΓΙΑ αψ από 1 μέχρι 10
      αν αχ=11 τοτε
        ΠΗΓΑΙΝΕ_ΧΥ β,γ
        ΓΡΑΨΕ ' --'
        ΠΗΓΑΙΝΕ_ΧΥ β,γ+1
        ΓΡΑΨΕ ''
        ψ <-- ψ+1
      ΑΛΛΙΩΣ
        ΠΗΓΑΙΝΕ_ΧΥ β,γ
        ΓΡΑΨΕ ' --'
      ΤΕΛΟΣ_ΑΝ
      β <-- β+3
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    β <-- 43
    γ <-- γ+2
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

ΔΙΑΔΙΚΑΣΙΑ παιχνίδι                  

ΜΕΤΑΒΛΗΤΕΣ

  ΠΡΑΓΜΑΤΙΚΕΣ: δυσκ,απα,κ_π,κ_υ,υπολ_π,ζωή_π ,σκορ
  ΑΚΕΡΑΙΕΣ:χ,επιλ_χ[17],επιλ_ψ[17],θεσ_πλ_χ_π[17],θεσ_πλ_ψ_π[17],θεσ_πλ_χ_υ[17],θεσ_πλ_ψ_υ[17]
  ΑΚΕΡΑΙΕΣ: επιχ[80],επιψ[80],επιχ2[81],επιψ2[81],ψ,επιλχ,επιλψ,κ,λ,θ_χ,θ_ψ,απαντ
  ΛΟΓΙΚΕΣ: προτο,στοχος,αλλαγη,υπα
  ΧΑΡΑΚΤΗΡΕΣ: κατάσταση

  ΑΡΧΕΙΑ ΠΡΑΓΜΑΤΙΚΩΝ: ΒΑΘΜΟΙ
  ΑΡΧΕΙΑ ΑΚΕΡΑΙΩΝ: Θεση_κ

ΑΡΧΗ

  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ ΒΑΘΜΟΙ, 'C:\SCOR.dll'
  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ Θεση_κ ,'C:\POSITION.dll'
  ΑΝ ΥΠΑΡΧΕΙ_ΑΡΧΕΙΟ('C:\SCOR.dll')=ΨΕΥΔΗΣ ΤΟΤΕ
    ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ ΒΑΘΜΟΙ
    ΚΛΕΙΣΕ_ΑΡΧΕΙΟ ΒΑΘΜΟΙ
  ΤΕΛΟΣ_ΑΝ
  ΑΝ ΥΠΑΡΧΕΙ_ΑΡΧΕΙΟ('C:\POSITION.dll')=ΨΕΥΔΗΣ ΤΟΤΕ
    ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ Θεση_κ
    ΚΛΕΙΣΕ_ΑΡΧΕΙΟ Θεση_κ
  ΤΕΛΟΣ_ΑΝ


  ΠΗΓΑΙΝΕ_ΧΥ 0,8
  ΓΡΑΨΕ '|'
  ΓΡΑΨΕ '|'

  ΠΗΓΑΙΝΕ_ΧΥ 79,8
  ΓΡΑΨΕ '|'
  ΠΗΓΑΙΝΕ_ΧΥ 79,9
  ΓΡΑΨΕ '|'

  ΠΗΓΑΙΝΕ_ΧΥ 15,5
  ΓΡΑΨΕ 'Για νεό παιχνίδι ακολουθήστε τα παρακάτω βήματα.'
  ΠΗΓΑΙΝΕ_ΧΥ 0,7
  ΓΡΑΨΕ '==============================================================================='
  ΠΗΓΑΙΝΕ_ΧΥ 3,8
  ΓΡΑΨΕ_ '1.Το επίπεδο δυσκολίας "1 για εύκολο,2 για μέτριο και 3 για δύσκολο".( )'
  ΠΗΓΑΙΝΕ_ΧΥ 3,9
  ΓΡΑΨΕ_ '2.Πάτα 3 για την αρχή του παιχνιδιού.( )'
  ΠΗΓΑΙΝΕ_ΧΥ 0,10
  ΓΡΑΨΕ '==============================================================================='

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΠΗΓΑΙΝΕ_ΧΥ 73,8
    ΔΙΑΒΑΣΕ_ δυσκ
    ΠΗΓΑΙΝΕ_ΧΥ 73,8
    ΓΡΑΨΕ_ ''
  ΜΕΧΡΙΣ_ΟΤΟΥ δυσκ=1 ή δυσκ=2 ή δυσκ=3
  ΠΗΓΑΙΝΕ_ΧΥ 41,9
  ΔΙΑΒΑΣΕ_ απα

  αν δυσκ=1 τότε
    ζωή_π <-- 80
  ΑΛΛΙΩΣ_ΑΝ δυσκ=2 τότε
    ζωή_π <-- 40
  ΑΛΛΙΩΣ
    ζωή_π <-- 25
  ΤΕΛΟΣ_ΑΝ

  αν απα=3 τότε
    ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
    ΚΑΛΕΣΕ ταμπλό

    υπολ_π <-- ζωή_π
    κ_π <-- 0
    χ <-- 1
    κ_υ <-- 0
    ψ <-- 1
 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!



    ΑΝΟΙΞΕ_ΑΡΧΕΙΟ θεση_κ
    αν ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(Θεση_κ)>0 τότε
      ΠΗΓΑΙΝΕ_ΧΥ 0,23
      ΓΡΑΨΕ_ 'Φαίνεται ότι υπάρχουν διαθέσιμες θέσεις για τα καράβια.Για να τα φορτώσεις πάτα [1] αλλιώς αλλο για συνέχεια:'
      ΔΙΑΒΑΣΕ_ απαντ
      ΠΗΓΑΙΝΕ_ΧΥ 0,23
      ΓΡΑΨΕ '                                                                                                                       '
    ΤΕΛΟΣ_ΑΝ
    ΚΛΕΙΣΕ_ΑΡΧΕΙΟ  θεση_κ


    ΟΣΟ κ_π<17 επανάλαβε                    !Στησιμο καραβιών παίχτη

      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΠΗΓΑΙΝΕ_ΧΥ 34,2
        ΓΡΑΨΕ 'Player'
        ΠΗΓΑΙΝΕ_ΧΥ 34,3
        ΓΡΑΨΕ κ_π,'χ @'
        ΠΗΓΑΙΝΕ_ΧΥ 34,4
        ΓΡΑΨΕ ' Ζωή!'
        ΠΗΓΑΙΝΕ_ΧΥ 34,5
        ΓΡΑΨΕ υπολ_π,'\',ζωή_π
        ΑΝΟΙΞΕ_ΑΡΧΕΙΟ Θεση_κ

        αν απαντ=1 τότε
          χ <-- 1
          ΟΣΟ ΤΕΛΟΣ_ΑΡΧΕΙΟΥ(Θεση_κ)=ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
            ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ Θεση_κ, θ_χ
            θεσ_πλ_χ_π[χ] <-- θ_χ
            ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ Θεση_κ, θ_ψ
            θεσ_πλ_ψ_π[χ] <-- θ_ψ
            ΠΗΓΑΙΝΕ_ΧΥ  θεσ_πλ_χ_π[χ], θεσ_πλ_ψ_π[χ]
            ΓΡΑΨΕ '@'
            χ <-- χ+1
          ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
          κ_π <-- 17
          απα <-- 1
        ΑΛΛΙΩΣ
          ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
            ΠΗΓΑΙΝΕ_ΧΥ 0,23
            ΓΡΑΨΕ '                                                                                        '
            ΠΗΓΑΙΝΕ_ΧΥ 0,23
            ΓΡΑΨΕ_ 'Δώσε συντεταγμένες για το στήσιμο των καραβιών σου (χ,ψ):'
            ΔΙΑΒΑΣΕ_ επιλ_χ[χ],επιλ_ψ[χ]
            ΠΗΓΑΙΝΕ_ΧΥ 40,23
            ΓΡΑΨΕ '                    '
          ΜΕΧΡΙΣ_ΟΤΟΥ επιλ_χ[χ]>0 και επιλ_χ[χ]<11 και επιλ_ψ[χ]>0 και επιλ_ψ[χ]<11
          προτο <-- ΨΕΥΔΗΣ
          αλλαγη <-- ΨΕΥΔΗΣ
          αν χ>1 τότε
            ψ <-- 1                                                  
            ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
              αν  επιλ_χ[χ]<>επιλ_χ[χ-ψ] ή επιλ_ψ[χ]<>επιλ_ψ[χ-ψ] τότε
                προτο <-- ΑΛΗΘΗΣ
              ΑΛΛΙΩΣ
                αλλαγη <-- ΑΛΗΘΗΣ
              ΤΕΛΟΣ_ΑΝ
              ψ <-- ψ+1
            μέχρις_ότου ψ=χ
          ΤΕΛΟΣ_ΑΝ

          αν προτο=ΑΛΗΘΗΣ και αλλαγη= ΨΕΥΔΗΣ ή χ=1 τοτε
            θεσ_πλ_χ_π[χ] <-- επιλ_χ[χ]*3
            θεσ_πλ_ψ_π[χ] <-- επιλ_ψ[χ]*2

            ΠΗΓΑΙΝΕ_ΧΥ 0,23
            ΓΡΑΨΕ '                                                                                         '
            ΠΗΓΑΙΝΕ_ΧΥ θεσ_πλ_χ_π[χ],θεσ_πλ_ψ_π[χ]
            ΓΡΑΨΕ '@'
            ΠΗΓΑΙΝΕ_ΧΥ 0,23
            ΓΡΑΨΕ_ 'Είστε ικανοποιημένος με αυτήν σου τη θέση? Αν όχι πάτα 11 αλλιώς αλλο.'
            ΔΙΑΒΑΣΕ απα
            αν απα=11 τότε
              ΠΗΓΑΙΝΕ_ΧΥ 0,23
              ΓΡΑΨΕ '                                                                                         '
              ΠΗΓΑΙΝΕ_ΧΥ θεσ_πλ_χ_π[χ],θεσ_πλ_ψ_π[χ]
              ΓΡΑΨΕ ' '
            ΑΛΛΙΩΣ
              ΠΗΓΑΙΝΕ_ΧΥ 0,23
              ΓΡΑΨΕ '                                                                                         '
              κ_π <-- κ_π+1
            ΤΕΛΟΣ_ΑΝ
          ΑΛΛΙΩΣ
            αν χ>1 τότε
              απα <-- 11
            ΤΕΛΟΣ_ΑΝ
          ΤΕΛΟΣ_ΑΝ
        ΤΕΛΟΣ_ΑΝ

      ΜΕΧΡΙΣ_ΟΤΟΥ απα<>11
      χ <-- χ+1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΚΛΕΙΣΕ_ΑΡΧΕΙΟ Θεση_κ
 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    χ <-- 1
    ΟΣΟ κ_υ<17 επανάλαβε
                                                    !Στήσιμο καραβιών υπολογιστή
      προτο <-- ΨΕΥΔΗΣ
      αλλαγη <-- ΨΕΥΔΗΣ

      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        επιλ_χ[χ] <--  ΤΥΧΑΙΟΣ(11)
        επιλ_ψ[χ] <-- ΤΥΧΑΙΟΣ(11)
      ΜΕΧΡΙΣ_ΟΤΟΥ  επιλ_χ[χ]>0 και επιλ_ψ[χ]>0

      αν χ>1 τότε
        ψ <-- 1
        αρχή_επανάληψης
          αν  επιλ_χ[χ]<>επιλ_χ[χ-ψ] ή επιλ_ψ[χ]<>επιλ_ψ[χ-ψ] τότε
            προτο <-- ΑΛΗΘΗΣ
          ΑΛΛΙΩΣ
            αλλαγη <-- ΑΛΗΘΗΣ
          ΤΕΛΟΣ_ΑΝ
          ψ <-- ψ+1
        μέχρις_ότου ψ=χ
      ΤΕΛΟΣ_ΑΝ


      αν προτο=ΑΛΗΘΗΣ και αλλαγη= ΨΕΥΔΗΣ ή χ=1 τοτε

        θεσ_πλ_χ_υ[χ] <-- (επιλ_χ[χ]*3)+41
        θεσ_πλ_ψ_υ[χ] <-- επιλ_ψ[χ]*2

        ΠΗΓΑΙΝΕ_ΧΥ 74,2
        ΓΡΑΨΕ 'CPU'
        ΠΗΓΑΙΝΕ_ΧΥ 74,3
        ΓΡΑΨΕ κ_υ,'χ @'
        κ_υ <-- κ_υ+1
        χ <-- χ+1
      ΤΕΛΟΣ_ΑΝ

    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!1!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    κ_υ <-- 17
    κ <-- 1
    λ <-- 1
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

      ΠΗΓΑΙΝΕ_ΧΥ 74,2
      ΓΡΑΨΕ 'CPU'                                !επίθεση παίκτη
      ΠΗΓΑΙΝΕ_ΧΥ 74,3
      ΓΡΑΨΕ κ_υ,'χ @'
      στοχος <-- ΨΕΥΔΗΣ

      ΠΗΓΑΙΝΕ_ΧΥ 0,23
      ΓΡΑΨΕ '                                                                                    '
      ΠΗΓΑΙΝΕ_ΧΥ 34,2
      ΓΡΑΨΕ 'Player'
      ΠΗΓΑΙΝΕ_ΧΥ 34,3
      ΓΡΑΨΕ κ_π,'χ @'
      ΠΗΓΑΙΝΕ_ΧΥ 34,4
      ΓΡΑΨΕ ' Ζωή!'
      ΠΗΓΑΙΝΕ_ΧΥ 34,5
      ΓΡΑΨΕ υπολ_π,'\',ζωή_π
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
          ΠΗΓΑΙΝΕ_ΧΥ 0,23
          ΓΡΑΨΕ '                                                                                              '
          ΠΗΓΑΙΝΕ_ΧΥ 0,23
          ΓΡΑΨΕ_ 'Δώσε (χ,ψ) κτυπήματος για την επίθεσή σου: '
          ΔΙΑΒΑΣΕ_ επιχ[κ],επιψ[κ]
        ΜΕΧΡΙΣ_ΟΤΟΥ επιχ[κ]<11 και επιχ[κ]>0 και επιψ[κ]<11 και επιψ[κ]>0

        προτο <-- ΨΕΥΔΗΣ
        αλλαγη <-- ΨΕΥΔΗΣ

        αν κ>1 τότε
          ψ <-- 1
          ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
            αν  επιχ[κ]<>επιχ[κ-ψ] ή επιψ[κ]<>επιψ[κ-ψ] τότε
              προτο <-- ΑΛΗΘΗΣ
            ΑΛΛΙΩΣ
              αλλαγη <-- ΑΛΗΘΗΣ
            ΤΕΛΟΣ_ΑΝ
            ψ <-- ψ+1
          μέχρις_ότου ψ=κ
        ΤΕΛΟΣ_ΑΝ

      ΜΕΧΡΙΣ_ΟΤΟΥ προτο= ΑΛΗΘΗΣ και αλλαγη= ΨΕΥΔΗΣ ή κ=1

      επιλχ <-- (επιχ[κ]*3)+41
      επιλψ <-- επιψ[κ]*2
      στοχος <-- ΨΕΥΔΗΣ
      κ <-- κ+1
      χ <-- 1
      ΟΣΟ χ<18 επαναλαβε
        αν επιλχ=θεσ_πλ_χ_υ[χ] και επιλψ=θεσ_πλ_ψ_υ[χ] τότε
          στοχος <-- ΑΛΗΘΗΣ
        ΤΕΛΟΣ_ΑΝ
        χ <-- χ+1
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

      ΑΝ στοχος=ΑΛΗΘΗΣ τοτε
        κάλεσε ήχο
        ΠΗΓΑΙΝΕ_ΧΥ επιλχ,επιλψ
        ΓΡΑΨΕ '!'
        ΠΗΓΑΙΝΕ_ΧΥ 0,23
        ΓΡΑΨΕ '                                                                                            '
        ΠΗΓΑΙΝΕ_ΧΥ 0,23
        ΓΡΑΨΕ 'Εβγε...'
        ΓΙΑ ψ από 1 μέχρι 4
          ΚΑΛΕΣΕ καθ
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
        κ_υ <-- κ_υ-1
      ΑΛΛΙΩΣ
        ΠΗΓΑΙΝΕ_ΧΥ  επιλχ,επιλψ
        ΓΡΑΨΕ '0'

        ΠΗΓΑΙΝΕ_ΧΥ 0,23
        ΓΡΑΨΕ '                                                                                            '
        ΠΗΓΑΙΝΕ_ΧΥ 0,23
        ΓΡΑΨΕ 'Αστόχησες....'
        ΓΙΑ ψ από 1 μέχρι 4
          ΚΑΛΕΣΕ καθ
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΤΕΛΟΣ_ΑΝ

      υπολ_π <-- υπολ_π-1

!!!!!!!!!!!!!!!!!!!!!!!!!!!!1!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!11
!Επίθεση υπολογιστή

      ΠΗΓΑΙΝΕ_ΧΥ 0,23
      ΓΡΑΨΕ '                                                                                                 '
      ΠΗΓΑΙΝΕ_ΧΥ 0,23
      ΓΡΑΨΕ 'Η σειρά μου τώρα...'
      ΓΙΑ ψ από 1 μέχρι 4
        ΚΑΛΕΣΕ καθ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
          επιχ2[λ] <--  ΤΥΧΑΙΟΣ(11)                   !!!τοποθεσία τυχαία
          επιψ2[λ] <-- ΤΥΧΑΙΟΣ(11)
        ΜΕΧΡΙΣ_ΟΤΟΥ  επιχ2[λ]>0 και επιψ2[λ]>0
        προτο <-- ΨΕΥΔΗΣ
        αλλαγη <-- ΨΕΥΔΗΣ

        αν λ>1 τότε
          ψ <-- 1
          ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
            αν  επιχ2[λ]<>επιχ2[λ-ψ] ή επιψ2[λ]<>επιψ2[λ-ψ] τότε
              προτο <-- ΑΛΗΘΗΣ
            ΑΛΛΙΩΣ
              αλλαγη <-- ΑΛΗΘΗΣ
            ΤΕΛΟΣ_ΑΝ
            ψ <-- ψ+1
          μέχρις_ότου ψ=λ
        ΤΕΛΟΣ_ΑΝ
      ΜΕΧΡΙΣ_ΟΤΟΥ  προτο=ΑΛΗΘΗΣ και  αλλαγη= ΨΕΥΔΗΣ ή λ=1
      !!!!!!!!
      επιλχ <-- επιχ2[λ]*3
      επιλψ <-- επιψ2[λ]*2
      !!!!!!

      στοχος <-- ΨΕΥΔΗΣ
      χ <-- 1
      ΟΣΟ χ<18 επαναλαβε
        αν επιλχ=θεσ_πλ_χ_π[χ] και επιλψ=θεσ_πλ_ψ_π[χ] τότε
          στοχος <-- ΑΛΗΘΗΣ
        ΤΕΛΟΣ_ΑΝ
        χ <-- χ+1
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

      ΑΝ στοχος=ΑΛΗΘΗΣ τοτε
        κάλεσε ήχο
        ΠΗΓΑΙΝΕ_ΧΥ επιλχ,επιλψ
        ΓΡΑΨΕ '!'
        ΠΗΓΑΙΝΕ_ΧΥ 0,23
        ΓΡΑΨΕ '                                                                                                   '
        ΠΗΓΑΙΝΕ_ΧΥ 0,23
        ΓΡΑΨΕ 'Κτυπήθηκες'
        ΓΙΑ ψ από 1 μέχρι 4
          ΚΑΛΕΣΕ καθ
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
        κ_π <-- κ_π-1
      ΑΛΛΙΩΣ

        ΠΗΓΑΙΝΕ_ΧΥ  επιλχ,επιλψ
        ΓΡΑΨΕ '0'
        ΠΗΓΑΙΝΕ_ΧΥ 0,23
        ΓΡΑΨΕ '                                                                                                    '
        ΠΗΓΑΙΝΕ_ΧΥ 0,23
        ΓΡΑΨΕ 'Ουφ....'
        ΓΙΑ ψ από 1 μέχρι 4
          ΚΑΛΕΣΕ καθ
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΤΕΛΟΣ_ΑΝ
      λ <-- λ+1


    ΜΕΧΡΙΣ_ΟΤΟΥ κ_υ=0 ή υπολ_π=0 ή κ_π=0


    αν κ_υ=0 και υπολ_π>=1 τότε

      κατάσταση <-- 'Συνγχαρητήρια, νίκησες!'
      σκορ <-- ((100*υπολ_π)/(ζωή_π-17))*100

    ΑΛΛΙΩΣ_ΑΝ κ_υ=κ_π τότε
      κατάσταση <-- '   Ισοπαλία...'
    ΑΛΛΙΩΣ
      κατάσταση <-- 'Δυστυχώς ,έχασες...'
    ΤΕΛΟΣ_ΑΝ
    απα <-- 0
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
      ΠΗΓΑΙΝΕ_ΧΥ 20,8
      ΓΡΑΨΕ '==========================================='
      ΠΗΓΑΙΝΕ_ΧΥ 20,9
      ΓΡΑΨΕ '|   /\         The Game is over!          |'
      ΠΗΓΑΙΝΕ_ΧΥ 20,10
      ΓΡΑΨΕ '|  /! \   ',κατάσταση
      ΠΗΓΑΙΝΕ_ΧΥ 20,11
      ΓΡΑΨΕ '| ------  Για συνέχεια πάτα [1].          |'
      ΠΗΓΑΙΝΕ_ΧΥ 20,12
      ΓΡΑΨΕ '==========================================='
      ΠΗΓΑΙΝΕ_ΧΥ 20,14
      ΓΡΑΨΕ 'Το σκορ σου είναι:',σκορ,'πόντοι!'
      ΠΗΓΑΙΝΕ_ΧΥ 62,10
      ΓΡΑΨΕ '|'
      ΠΗΓΑΙΝΕ_ΧΥ 53,11
      ΔΙΑΒΑΣΕ_ απα
    ΜΕΧΡΙΣ_ΟΤΟΥ απα=1
    ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
  ΤΕΛΟΣ_ΑΝ
  αν σκορ>=1 τότε
    ΑΝΟΙΞΕ_ΑΡΧΕΙΟ ΒΑΘΜΟΙ
    ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ ΒΑΘΜΟΙ, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(ΒΑΘΜΟΙ)+1
    ΓΡΑΨΕ_ΑΡΧΕΙΟ ΒΑΘΜΟΙ, σκορ
    ΚΛΕΙΣΕ_ΑΡΧΕΙΟ ΒΑΘΜΟΙ
  ΤΕΛΟΣ_ΑΝ
  κάλεσε μενού

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
ΔΙΑΔΙΚΑΣΙΑ  πληροφορίες
ΑΡΧΗ
  ΠΑΡΑΛΛΗΛΗ_ΕΚΤΕΛΕΣΗ
  ΕΚΤΕΛΕΣΕ  'Πληροφορίες.exe '
  κάλεσε μενού
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

ΔΙΑΔΙΚΑΣΙΑ καθ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: α
ΑΡΧΗ
  ΓΙΑ α από 1 μέχρι 10000000
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
ΔΙΑΔΙΚΑΣΙΑ ήχο
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: α
ΑΡΧΗ
  ΓΙΑ α από 1 μέχρι 5
    ΓΡΑΨΕ_ χαρ(7)
    κάλεσε καθ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
ΔΙΑΔΙΚΑΣΙΑ σκορ
ΑΡΧΗ
  ΠΑΡΑΛΛΗΛΗ_ΕΚΤΕΛΕΣΗ
  ΕΚΤΕΛΕΣΕ 'Σκορ.exe'
  ΚΑΛΕΣΕ μενού
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Παράθεση:
Για εισαγωγή καραβιών.Είναι ξεχωριστό πρόγραμμα που σε βοηθάει να αποθηκεύεις τις θέσεις των καραβιών σου χωρίς να σου βγαίνει το λάδι καθε φορά που θες να παίξεις.


Syntax: [ Download ] [ Hide ]
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: επιλ_χ[17],επιλ_ψ[17],απα,χ,ι,ψ,κ_π, θεσ_πλ_χ_π[17], θεσ_πλ_ψ_π[17],θ_χ,θ_ψ
  ΛΟΓΙΚΕΣ: προτο,αλλαγη,υπα
  ΑΡΧΕΙΑ ΑΚΕΡΑΙΩΝ: Θεση_κ
ΑΡΧΗ
  υπα <-- ΨΕΥΔΗΣ
  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ Θεση_κ, 'C:\POSITION.dll'
                                                                   
  ΑΝ ΥΠΑΡΧΕΙ_ΑΡΧΕΙΟ('C:\POSITION.dll')= ΑΛΗΘΗΣ  ΤΟΤΕ
    ΑΝΟΙΞΕ_ΑΡΧΕΙΟ Θεση_κ
    ΑΝ ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(Θεση_κ)>0 τοτε
      υπα <-- ΑΛΗΘΗΣ
      ΚΛΕΙΣΕ_ΑΡΧΕΙΟ  Θεση_κ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ

  ΑΝ ΥΠΑΡΧΕΙ_ΑΡΧΕΙΟ('C:\POSITION.dll')=ΨΕΥΔΗΣ ή υπα=ΨΕΥΔΗΣ ΤΟΤΕ
    ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ Θεση_κ
    ΚΛΕΙΣΕ_ΑΡΧΕΙΟ Θεση_κ
  ΑΛΛΙΩΣ
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
      ΠΗΓΑΙΝΕ_ΧΥ 25,3
      ΓΡΑΨΕ 'BATTLESHIPS EDITOR.'
      ΠΗΓΑΙΝΕ_ΧΥ 0,5
      ΓΡΑΨΕ '==============================================================================='
      ΠΗΓΑΙΝΕ_ΧΥ 0,6
      ΓΡΑΨΕ 'Υπάρχει ήδη ένα αρχείο με θέσεις.Για ανανέωση πατήστε 1 αλλιώς άλλο για έξοδο:'
      ΓΡΑΨΕ '==============================================================================='
      ΠΗΓΑΙΝΕ_ΧΥ 0,8
      ΓΡΑΨΕ 'Απάντηση:'
      ΠΗΓΑΙΝΕ_ΧΥ 11,8
      ΔΙΑΒΑΣΕ απα
      αν απα=1 τότε
        ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
        ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ Θεση_κ, 'C:\POSITION.dll'
        ΔΙΑΓΡΑΨΕ_ΑΡΧΕΙΟ Θεση_κ
        ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ Θεση_κ
        ΚΛΕΙΣΕ_ΑΡΧΕΙΟ Θεση_κ
      ΑΛΛΙΩΣ
        ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
        ΠΗΓΑΙΝΕ_ΧΥ 35,12
        γράψε'Αντίο....'
        ΓΙΑ ι από 1 μέχρι 19999999
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
        ΚΛΕΙΣΕ_ΠΑΡΑΘΥΡΟ
      ΤΕΛΟΣ_ΑΝ
    ΜΕΧΡΙΣ_ΟΤΟΥ απα=1
  ΤΕΛΟΣ_ΑΝ
  !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
  κάλεσε ταμπλό
  κ_π <-- 0
  χ <-- 1
  ΟΣΟ κ_π<17 επανάλαβε                    !Στησιμο καραβιών παίχτη

    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΠΗΓΑΙΝΕ_ΧΥ 34,2
      ΓΡΑΨΕ 'Player'
      ΠΗΓΑΙΝΕ_ΧΥ 34,3
      ΓΡΑΨΕ κ_π,'χ @'

      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΠΗΓΑΙΝΕ_ΧΥ 0,23
        ΓΡΑΨΕ '                                                                                        '
        ΠΗΓΑΙΝΕ_ΧΥ 0,23
        ΓΡΑΨΕ_ 'Δώσε συντεταγμένες για το στήσιμο των καραβιών σου (χ,ψ):'
        ΔΙΑΒΑΣΕ_ επιλ_χ[χ],επιλ_ψ[χ]
        ΠΗΓΑΙΝΕ_ΧΥ 40,23
        ΓΡΑΨΕ '                    '
      ΜΕΧΡΙΣ_ΟΤΟΥ επιλ_χ[χ]>0 και επιλ_χ[χ]<11 και επιλ_ψ[χ]>0 και επιλ_ψ[χ]<11
      προτο <-- ΨΕΥΔΗΣ
      αλλαγη <-- ΨΕΥΔΗΣ
      αν χ>1 τότε
        ψ <-- 1
        ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
          αν  επιλ_χ[χ]<>επιλ_χ[χ-ψ] ή επιλ_ψ[χ]<>επιλ_ψ[χ-ψ] τότε
            προτο <-- ΑΛΗΘΗΣ
          ΑΛΛΙΩΣ
            αλλαγη <-- ΑΛΗΘΗΣ
          ΤΕΛΟΣ_ΑΝ
          ψ <-- ψ+1
        μέχρις_ότου ψ=χ
      ΤΕΛΟΣ_ΑΝ

      αν προτο=ΑΛΗΘΗΣ και αλλαγη= ΨΕΥΔΗΣ ή χ=1 τοτε
        θεσ_πλ_χ_π[χ] <-- επιλ_χ[χ]*3
        θεσ_πλ_ψ_π[χ] <-- επιλ_ψ[χ]*2

        ΠΗΓΑΙΝΕ_ΧΥ 0,23
        ΓΡΑΨΕ '                                                                                         '
        ΠΗΓΑΙΝΕ_ΧΥ θεσ_πλ_χ_π[χ],θεσ_πλ_ψ_π[χ]
        ΓΡΑΨΕ '@'
        ΠΗΓΑΙΝΕ_ΧΥ 0,23
        ΓΡΑΨΕ_ 'Είστε ικανοποιημένος με αυτήν σου τη θέση? Αν όχι πάτα 11 αλλιώς αλλο.'
        ΔΙΑΒΑΣΕ απα
        αν απα=11 τότε
          ΠΗΓΑΙΝΕ_ΧΥ 0,23
          ΓΡΑΨΕ '                                                                                         '
          ΠΗΓΑΙΝΕ_ΧΥ θεσ_πλ_χ_π[χ],θεσ_πλ_ψ_π[χ]
          ΓΡΑΨΕ ' '
        ΑΛΛΙΩΣ
          ΠΗΓΑΙΝΕ_ΧΥ 0,23
          ΓΡΑΨΕ '                                                                                         '
          κ_π <-- κ_π+1
        ΤΕΛΟΣ_ΑΝ
      ΑΛΛΙΩΣ
        αν χ>1 τότε
          απα <-- 11
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΑΝ
    ΜΕΧΡΙΣ_ΟΤΟΥ απα<>11
    χ <-- χ+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ

  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ Θεση_κ
  ΓΙΑ χ από 1 μέχρι 17
    ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ Θεση_κ, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(Θεση_κ)+1
    θ_χ <-- θεσ_πλ_χ_π[χ]
    ΓΡΑΨΕ_ΑΡΧΕΙΟ Θεση_κ, θ_χ
    ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ Θεση_κ, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(Θεση_κ)+1
    θ_ψ <-- θεσ_πλ_ψ_π[χ]
    ΓΡΑΨΕ_ΑΡΧΕΙΟ Θεση_κ, θ_ψ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ Θεση_κ

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
    ΠΗΓΑΙΝΕ_ΧΥ 25,3
    ΓΡΑΨΕ 'BATTLESHIPS EDITOR.'
    ΠΗΓΑΙΝΕ_ΧΥ 0,5
    ΓΡΑΨΕ '==============================================================================='
    ΠΗΓΑΙΝΕ_ΧΥ 10,6
    ΓΡΑΨΕ 'Η εγγραφή των θέσεων ολοκληρώθηκε....Πατήστε [1] για έξοδο:'
    ΓΡΑΨΕ '==============================================================================='
    ΠΗΓΑΙΝΕ_ΧΥ 0,8
    ΓΡΑΨΕ 'Απάντηση:'
    ΠΗΓΑΙΝΕ_ΧΥ 11,8
    ΔΙΑΒΑΣΕ απα
  ΜΕΧΡΙΣ_ΟΤΟΥ απα=1
  ΚΛΕΙΣΕ_ΠΑΡΑΘΥΡΟ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΙΑΔΙΚΑΣΙΑ ταμπλό
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: αχ,αψ,β,γ,θ_ψ[10],ψ,χ,επα
  ΧΑΡΑΚΤΗΡΕΣ:θ_χ[10]
ΑΡΧΗ
  θ_χ[1] <-- 'A'
  θ_χ[2] <-- 'B'
  θ_χ[3] <-- 'C'
  θ_χ[4] <-- 'D'
  θ_χ[5] <-- 'E'
  θ_χ[6] <-- 'F'
  θ_χ[7] <-- 'G'
  θ_χ[8] <-- 'H'
  θ_χ[9] <-- 'I'
  θ_χ[10] <-- 'J'


  β <-- 2
  χ <-- 1
  ΓΙΑ αχ από 1 μέχρι 11
    ΓΙΑ αψ από 2 μέχρι 21
      ΑΝ αχ=1 τοτε
        αν αψ MOD 2=0 τότε
          ΠΗΓΑΙΝΕ_ΧΥ β-2,αψ
          ΓΡΑΨΕ  θ_χ[χ]
          ΠΗΓΑΙΝΕ_ΧΥ β,αψ
          ΓΡΑΨΕ '|'
          χ <-- χ+1
        ΤΕΛΟΣ_ΑΝ
      ΑΛΛΙΩΣ
        ΠΗΓΑΙΝΕ_ΧΥ β,αψ
        ΓΡΑΨΕ '|'
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    β <-- β+3
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ψ <-- 1
  β <-- 2
  γ <-- 1
  για αχ από 1 μέχρι 11
    ΓΙΑ αψ από 1 μέχρι 10
      αν αχ=11 τοτε
        ΠΗΓΑΙΝΕ_ΧΥ β,γ
        ΓΡΑΨΕ ' --'
        ΠΗΓΑΙΝΕ_ΧΥ β,γ+1
        ΓΡΑΨΕ ''
        ψ <-- ψ+1
      ΑΛΛΙΩΣ
        ΠΗΓΑΙΝΕ_ΧΥ β,γ
        ΓΡΑΨΕ ' --'
      ΤΕΛΟΣ_ΑΝ
      β <-- β+3
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    β <-- 2
    γ <-- γ+2
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Παράθεση:
Ονομαστε το Πληροφορίες.Ειναι το πρόγραμμα για τη βοήθεια και τα περί.... του προγράμματος.


Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ Πληροφορίες
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ:  απα
  ΑΚΕΡΑΙΕΣ: α

ΑΡΧΗ

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
    ΠΗΓΑΙΝΕ_ΧΥ 25,3
    ΓΡΑΨΕ 'Περι Battleships...'

    ΠΗΓΑΙΝΕ_ΧΥ 0,5
    ΓΡΑΨΕ '******************************************************************************'
    ΓΡΑΨΕ 'Αυτό το παιχνίδι είναι μία αναπαράσταση του κλασικού παιχνιδιού Battleships.'
    ΓΡΑΨΕ 'Σκοπός του παιχνιδιού είναι  μέσα σε περιορισμένες κινήσεις να καταστρέψεις '
    ΓΡΑΨΕ 'όλα τα καράβια του υπολογιστή. Στο κύριο παιχνίδι απλά εισάγεις τις συντεταγμένες (χ,ψ) για να πραγματοποιήσεις κάποιο χτύπημα.'
    ΓΡΑΨΕ 'Αν το χτύπημά σου ήταν επιτυχές τότε ο υπολογιστής χάνει ένα πλοίο "@" και το επιτυχές κτύπημα παριστάνεται με ενα "!" αλλιώς το κενό παριστάνεται με ένα "0".'
    ΓΡΑΨΕ 'Βέβαια μπορει να χάσεις και εσυ ένα καράβι με τον ίδιο τρόπο. Στο τέλος το σκορ βγαίνει ανάλογα με το πόσο γρήγορα, δηλαδή σε πόσες κινήσεις νίκησες.'
    ΓΡΑΨΕ 'Στο παιχνίδι υπάρχουν δύο ταμπλό το αριστερό είναι δικό σου και εκεί παριστάνονται τα πλοία σου και το δεξιό είναι αυτό,'
    ΓΡΑΨΕ 'που πραγματοποιείς τις δικές σου επιθέσεις.'
    ΓΡΑΨΕ
    ΓΡΑΨΕ 'Ελπίζω να σας ευχαριστεί...Made by Memas;-)'
    ΓΡΑΨΕ '******************************************************************************'
    ΓΡΑΨΕ
    ΓΡΑΨΕ 'Πάτα 1 για τέλος.'
    ΔΙΑΒΑΣΕ απα
  ΜΕΧΡΙΣ_ΟΤΟΥ απα='1'
  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
  κάλεσε λεζάντα
  ΠΗΓΑΙΝΕ_ΧΥ 35,12
  ΓΡΑΨΕ 'ΑΝΤΙΟ'
  ΓΙΑ α από 1 μέχρι 10000000
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΚΛΕΙΣΕ_ΠΑΡΑΘΥΡΟ


ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
ΔΙΑΔΙΚΑΣΙΑ λεζάντα
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: κειμ
  ΑΚΕΡΑΙΕΣ: χ,ι,τ

ΑΡΧΗ
  κειμ <-- ' Created by the Lazy Programmer;-)'
  !!!!!!!!!!!!!!!!
  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
  χ <-- 0
  ΓΙΑ ι από 1 μέχρι 79
    ΠΗΓΑΙΝΕ_ΧΥ 0+χ,22
    ΓΡΑΨΕ_ '='
    χ <-- χ+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  χ <-- 0
  ΓΙΑ ι από 1 μέχρι 79
    ΠΗΓΑΙΝΕ_ΧΥ 0+χ,24
    ΓΡΑΨΕ_ '='
    χ <-- χ+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  χ <-- 0
  !!!!!!!!!!!!!!!!!

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    χ <-- μήκος_χαρ(κειμ)
    ΓΙΑ ι από 1 μέχρι 80
      ΠΗΓΑΙΝΕ_ΧΥ 80-χ,23
      ΓΡΑΨΕ_ κειμ
      κάλεσε καθ
      χ <-- χ+1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

    χ <-- 0
    ΓΙΑ ι από 80- μηκος_χαρ(κειμ) μέχρι 0 με Βήμα -1
      ΠΗΓΑΙΝΕ_ΧΥ χ,23
      ΓΡΑΨΕ_ κειμ
      κάλεσε καθ
      χ <-- χ+1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    τ <-- τ+1
  ΜΕΧΡΙΣ_ΟΤΟΥ τ>=1


ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
ΔΙΑΔΙΚΑΣΙΑ καθ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: α
ΑΡΧΗ
  ΓΙΑ α από 1 μέχρι 1000000
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ



Παράθεση:
Ονομάστε το Σκορ.Είναι το πρόγραμμα που αποθηκεύει τα σκόρ σου κάθε φορά .Βέβαια αφού εχεις νικήσει.

Syntax: [ Download ] [ Hide ]
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ι,κ,ζ
  ΧΑΡΑΚΤΗΡΕΣ:τ
  ΠΡΑΓΜΑΤΙΚΕΣ: σκ[1000]

  ΑΡΧΕΙΑ ΠΡΑΓΜΑΤΙΚΩΝ: ΒΑΘΜΟΙ


ΑΡΧΗ

  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ ΒΑΘΜΟΙ, 'C:\SCOR.dll'

  ΑΝ ΥΠΑΡΧΕΙ_ΑΡΧΕΙΟ('C:\SCOR.dll')=ΨΕΥΔΗΣ ΤΟΤΕ
    ΓΡΑΨΕ  'Πρέπει να εκτελεστεί το παιχνίδι πρώτα...'
    ΔΙΑΒΑΣΕ τ
    ΚΛΕΙΣΕ_ΠΑΡΑΘΥΡΟ
  ΤΕΛΟΣ_ΑΝ

  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ ΒΑΘΜΟΙ
  ι <-- 1
  κ <-- 0
  ΓΡΑΨΕ 'Ακολουθεί η προβολή του πίνακα των σκορ...'
  ΓΡΑΨΕ
  ΑΝ ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(ΒΑΘΜΟΙ)=0 ΤΟΤΕ
    ΓΡΑΨΕ '[ΔΕΝ ΥΠΑΡΧΟΥΝ ΕΓΓΡΑΦΕΣ]'
  ΤΕΛΟΣ_ΑΝ

  ΟΣΟ ΤΕΛΟΣ_ΑΡΧΕΙΟΥ(ΒΑΘΜΟΙ)=ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
    ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ ΒΑΘΜΟΙ, σκ[ι]
    ι <-- ι+1
    κ <-- κ+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ ι ΑΠΟ 2 ΜΕΧΡΙ κ
    ΓΙΑ ζ ΑΠΟ κ ΜΕΧΡΙ ι ΜΕ ΒΗΜΑ -1

      ΑΝ σκ[ζ-1]<σκ[ζ] ΤΟΤΕ

        ΚΑΛΕΣΕ Αντιμετάθεσε(σκ[ζ-1],σκ[ζ])

      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'Ακολουθεί η σειρά των σκορ σε φθίνουσα σειρά.'
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ κ
    ΓΡΑΨΕ ι,'ο σκορ:', σκ[ι]
    ΑΝ ι MOD 10=0 και σκ[ι+1]>0 τότε
      ΓΡΑΨΕ 'Πατήστε <Enter> για να δείτε τα υπολοιπα...'
      ΔΙΑΒΑΣΕ τ
      ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
      ΓΡΑΨΕ 'Ακολουθεί η προβολή του πίνακα των σκορ...'
      ΓΡΑΨΕ
      ΓΡΑΨΕ 'Ακολουθεί η σειρά των σκορ σε φθίνουσα σειρά.'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ ΒΑΘΜΟΙ
  ΓΡΑΨΕ
  ΓΡΑΨΕ 'Η προβολή των σκορ ολοκληρώθηκε.Πατήστε <ENTER> για να συνεχίσετε ή [1] για ανανέωση τους.'
  ΔΙΑΒΑΣΕ τ

  αν τ='1' τοτε
    ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ ΒΑΘΜΟΙ, 'C:\SCOR.dll'
    ΔΙΑΓΡΑΨΕ_ΑΡΧΕΙΟ  ΒΑΘΜΟΙ
  ΤΕΛΟΣ_ΑΝ

  ΚΛΕΙΣΕ_ΠΑΡΑΘΥΡΟ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΙΑΔΙΚΑΣΙΑ Αντιμετάθεσε(αριθμός1, αριθμός2)
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ:  αριθμός1, αριθμός2, προσωρινή
ΑΡΧΗ
  προσωρινή <-- αριθμός1
  αριθμός1 <-- αριθμός2
  αριθμός2 <-- προσωρινή
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
!-------------


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters