Τώρα είναι Τρί 15 Οκτ 2019 10:57 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: λεζάντα
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 30 Ιαν 2010 01:17 pm 
Χωρίς σύνδεση

Εγγραφή: Τρί 22 Απρ 2008 11:05 am
Δημοσιεύσεις: 21
Κώδικας:
ΠΡΟΓΡΑΜΜΑ λεζάντα
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: κειμ,ψ
  ΑΚΕΡΑΙΕΣ: ι,χ
ΑΡΧΗ
!αφηστε ένα κενό μπροστά από το κείμενο σας!
  ΓΡΑΨΕ 'Δώσε το κείμενο λεζάντας:'
  ΔΙΑΒΑΣΕ κειμ

  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
  χ <-- 0
  ΓΙΑ ι από 1 μέχρι 79
    ΠΗΓΑΙΝΕ_ΧΥ 0+χ,22
    ΓΡΑΨΕ_ '='
    χ <-- χ+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  χ <-- 0
  ΓΙΑ ι από 1 μέχρι 79
    ΠΗΓΑΙΝΕ_ΧΥ 0+χ,24
    ΓΡΑΨΕ_ '='
    χ <-- χ+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  χ <-- 0


  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    χ <-- μήκος_χαρ(κειμ)
    ΓΙΑ ι από 1 μέχρι 80
      ΠΗΓΑΙΝΕ_ΧΥ 80-χ,23
      ΓΡΑΨΕ_ κειμ
      κάλεσε καθ

      χ <-- χ+1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

    χ <-- 0
    ΓΙΑ ι από 80- μηκος_χαρ(κειμ) μέχρι 0 με Βήμα -1
      ΠΗΓΑΙΝΕ_ΧΥ χ,23
      ΓΡΑΨΕ_ κειμ
      κάλεσε καθ

      χ <-- χ+1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΜΕΧΡΙΣ_ΟΤΟΥ χ=1000

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


ΔΙΑΔΙΚΑΣΙΑ καθ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: α
ΑΡΧΗ
  ΓΙΑ α από 1 μέχρι 10000000
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ                                                                         


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters