Τώρα είναι Δευτ 23 Σεπ 2019 04:06 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 30 Ιαν 2010 01:15 pm 
Χωρίς σύνδεση

Εγγραφή: Τρί 22 Απρ 2008 11:05 am
Δημοσιεύσεις: 21
Κώδικας:
ΠΡΟΓΡΑΜΜΑ ΣΥΣΤΗΜΑ_ΜΕ_ΜΕΘΟΔΟ_ΑΝΤΙΚΑΤΑΣΤΑΣΗΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: α,β,γ,α1,β1,γ1,χ,ψ,τ
ΑΡΧΗ

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Επίλυση συστήματος με 2 αγνώστους με αντικατάσταση.'
    ΓΡΑΨΕ 'Της μορφής αχ+βψ=γ'
    ΓΡΑΨΕ 'Δώσε το α,β,γ:'
    ΔΙΑΒΑΣΕ α,β,γ
    ΓΡΑΨΕ 'α1χ+β1ψ=γ1'
    ΓΡΑΨΕ 'Δώσε το α1,β1,γ1:'
    ΔΙΑΒΑΣΕ α1,β1,γ1

    ΑΝ (α*β1)-(α1*β)<>0 τοτε
      χ <-- ((γ*β1)-(γ1*β))/((α*β1)-(α1*β))
      ψ <-- ((α*γ1)-(α1*γ))/((α*β1)-(α1*β))
      ΓΡΑΨΕ
      ΓΡΑΨΕ 'Το αποτέλεσμα είναι....'
      ΓΡΑΨΕ α,'*',χ,'+(',β,'*',ψ,')=',γ
      ΓΡΑΨΕ α1,'*',χ,'+(',β1,'*',ψ,')=',γ1
      ΓΡΑΨΕ '==============================='
      ΓΡΑΨΕ 'Αρα το σύστημα έχει λύση για...'
      ΓΡΑΨΕ '(χ,ψ)=(',χ,',',ψ,')'
    ΑΛΛΙΩΣ_ΑΝ α=0 και α1=0 και β=0 και β1=0 και γ=0 και γ1=0 τοτε
      ΓΡΑΨΕ 'Το σύστημα είναι αοριστο.Υσχύει για καθε χ και ψ. '
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Το σύστημα αυτό ειναι αδύνατο.'
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ 'Πατα 1 για έξοδο αλλιώς άλλο για συνέχεια.'
    ΔΙΑΒΑΣΕ τ
    ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ

  ΜΕΧΡΙΣ_ΟΤΟΥ τ=1

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters