Τώρα είναι Τρί 18 Ιουν 2019 11:55 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Κώδικας ASCII
ΔημοσίευσηΔημοσιεύτηκε: Παρ 25 Δεκ 2009 04:52 pm 
Χωρίς σύνδεση

Εγγραφή: Τρί 22 Απρ 2008 11:05 am
Δημοσιεύσεις: 21
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ binary

ΜΕΤΑΒΛΗΤΕΣ

  ΠΡΑΓΜΑΤΙΚΕΣ: α

ΑΡΧΗ

  ΓΡΑΨΕ 'Αυτό είναι ένα πρόγραμμα που μας δήχνει την βασική λειτουργεία του κώδικα ASCII.'
  ΓΡΑΨΕ 'Με την βοήθεια της μετατροπής αυτού του κώδικα σε δυαδικό σύστημα ο υπολογιστής,'
  ΓΡΑΨΕ '"καταλαβαίνει" εντολές και μπορούμε ουσιαστικά να "επικοινωνοίσουμε" με αυτόν...'
  ΓΡΑΨΕ 'Για να χρησιμοποιήσεις το πρόγραμμα πάτα 1 :'

  ΔΙΑΒΑΣΕ α

  αν α=1 τότε
    ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
    κάλεσε Μενού
  ΑΛΛΙΩΣ κάλεσε bye

  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

ΔΙΑΔΙΚΑΣΙΑ Μενού
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ:α

ΑΡΧΗ

  ΓΡΑΨΕ  '           ====================================================='
  ΓΡΑΨΕ  '           = Καλωσήρθατε στο μενού...Τι θα θέλατε να κάνετε..? ='
  ΓΡΑΨΕ  '           = *1 Μετατροπή κώδικα Ascii σε δυαδικό σύστημα.     ='
  ΓΡΑΨΕ  '           = *2 Προβολή της ιστορίας του κώδικα ASCII.         ='
  ΓΡΑΨΕ  '           = *3 Προβολή στοιχείων δημιουργίας προ/ματος.       ='
  ΓΡΑΨΕ  '           = *4 Τερματισμός Προγράμματος.                      ='
  ΓΡΑΨΕ  '           = *5 Προβολή της βοήθειας.                          ='
  ΓΡΑΨΕ  '           ====================================================='

  ΔΙΑΒΑΣΕ α
  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ

  αν α=1 τότε
    κάλεσε bit
  ΑΛΛΙΩΣ_ΑΝ α=2 τότε
    κάλεσε history
  ΑΛΛΙΩΣ_ΑΝ α=3 τότε
    κάλεσε credits
  ΑΛΛΙΩΣ_ΑΝ α=4 τότε
    κάλεσε bye
  ΑΛΛΙΩΣ_ΑΝ α=5 τότε
    κάλεσε help
  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!




ΔΙΑΔΙΚΑΣΙΑ history
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: παρ
ΑΡΧΗ

  ΓΡΑΨΕ 'Ο ASCII (American Standar Code for Information Interchange)δημιουργήθηκε χάρη   στην υποστήριξη του Εθνικού Αμερικανικού Ινστιτούτου Προτύπων (American National Standard Institute),σε μία προσπάθεια να υπάρξει ένας κοινός κώδικας'
  ΓΡΑΨΕ 'για την ανταλλαγή δεδομένων μεταξύ υπολογιστών καθώς και για την αποθήκευσή τους.Γι αυτό τον λόγο έχει υιοθετηθεί σχεδόν από όλους τους κατασκευαστές μικροϋπολογιστών, και χρησιμοποιείται ευρύτατα. Αρχικά στον κώδικα ASCII χρησι'
  ΓΡΑΨΕ 'μοποιούνταν 7 bit για την παράσταση των χαρακτήρων και ένα bit , το 8, για έλεγχο ορθότητας κατα τη Μεταφορά αρχείων. Το bit αυτο οναομάστηκε ψηφίο ισοτημίας (parity bit).Με την κωδικοποιήση αυτή δίνεταιη δυνατότητα να παραστή'
  ΓΡΑΨΕ 'σουμε 128 (=2^7) διαφορετικούς χαρακτήρες, ως αποτέλεσμα των 128 διαφορετικών συνδιασμών από 0 και 1.Με την πάροδο του χρόνου και εξαιτίας της διεύρυνσης της χρήσης των υπολογιστών που δημιούργησε την ανάγκη για περισσότερα σύμ'
  ΓΡΑΨΕ 'βολα, χρησιμοποιήθηκε και το 8ο bit για την παράσταση χαρακτήρων,οπότε έγινε δυνατό να παρασταθούν 256(=2^8) διαφορετικοί χαρακτήρες. Οι διάφοροι κατασκευαστές χρησιμοποίησαν τη νέα περιοχή (128-255) για την κωδικοποίηση ειδικων'
  ΓΡΑΨΕ 'συμβόλων και γραφικών χαρακτήρων καθώς και την αναπαράσταση διαφορετικών γλωσσών διαγορετικών του λατινικού όπως π.χ. του Ελληνικού. Ο νέος κώδικας που προέκυψε ονομάστηκε επεκταμένος κώδικας ASCII (Extended ASCII)ή ASCII-8)'
  ΓΡΑΨΕ 'Για επιστροφή στο Μενού πάτα 1 αλλίως για τερματισμό 2.'
  ΔΙΑΒΑΣΕ παρ

  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ

  ΑΝ παρ=1 τότε
    κάλεσε Μενού
  ΑΛΛΙΩΣ_ΑΝ παρ=2 τότε
    ΚΑΛΕΣΕ bye
  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!


ΔΙΑΔΙΚΑΣΙΑ credits
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: παρ
ΑΡΧΗ

  ΓΡΑΨΕ 'Αυτό το πρόγραμμα δημιουργήθηκε σε περιβάλλον της Γλωσσομάθειας από τον Μάκη (Lazy programmer)'
  ΓΡΑΨΕ 'Βιβλιογραφία από Εφαρμογές Πληροφορικής Υπολογιστών Ά,΄Β,΄Γ ΛΥΚΕΊΟΥ.'
  ΠΗΓΑΙΝΕ_ΧΥ 60,20
  ΓΡΑΨΕ 'Εκδοση(Version)1,0.'
  ΓΡΑΨΕ 'Για επιστροφή στο Μενού πάτα 1 αλλίως για τερματισμό 2.'
  ΔΙΑΒΑΣΕ παρ

  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ

  ΑΝ παρ=1 τότε
    κάλεσε Μενού
  ΑΛΛΙΩΣ_ΑΝ παρ=2 τότε
    ΚΑΛΕΣΕ bye
  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ



!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!


ΔΙΑΔΙΚΑΣΙΑ  bye

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: καθ
ΑΡΧΗ

  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ

  ΠΗΓΑΙΝΕ_ΧΥ 15,15
  ΓΡΑΨΕ 'Ήταν άλλη μία εφαρμογή του Lazy Programmer '
  ΓΡΑΨΕ '    Ευχαριστώ και αντίο...ή μάλλον 01000001 01001110 01010100 01001111 '
  ΓΙΑ καθ από 1 μέχρι 90000000
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΚΛΕΙΣΕ_ΠΑΡΑΘΥΡΟ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ



!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!



ΔΙΑΔΙΚΑΣΙΑ help

ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: α

ΑΡΧΗ

  ΓΡΑΨΕ 'Απλά πληκτρολόγεισε ένα κείμενο με χαρακτήρες ή και αριθμούς από το 1-10.'
  ΓΡΑΨΕ 'Το πρόγγραμμα αμέσως θα στο μετατρέψει σε δυαδικό σύστημα...Τόσο εύκολα.'
  ΓΡΑΨΕ 'Για επιστροφή στο Μενού πάτα 1 αλλιώς 2 για τερματισμό.....'
  ΔΙΑΒΑΣΕ α
  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ

  αν α=1 τότε
    κάλεσε Μενού

  ΑΛΛΙΩΣ_ΑΝ α=2 τότε
    κάλεσε bye
  ΤΕΛΟΣ_ΑΝ

  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ


ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

ΔΙΑΔΙΚΑΣΙΑ bit

ΜΕΤΑΒΛΗΤΕΣ

  ΧΑΡΑΚΤΗΡΕΣ: αρκμ[100] , τελκμ[100],κειμ
  ΑΚΕΡΑΙΕΣ: μετρ,i,α

ΑΡΧΗ

  ΓΡΑΨΕ 'Δώσε το κείμενο στα Αγγλικά με κεφαλαία γράμματα.Χαρακτήρες δεν περιέχονται.'

  ΔΙΑΒΑΣΕ κειμ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100
    αρκμ[i] <-- κειμ[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100

    ΑΝ αρκμ[i]='A' ΤΟΤΕ


      τελκμ[i] <-- ('01000001')

    ΑΛΛΙΩΣ_ΑΝ αρκμ[i]='B' ΤΟΤΕ

      τελκμ[i] <-- ('01000010')

    ΑΛΛΙΩΣ_ΑΝ αρκμ[i]='C' ΤΟΤΕ
      τελκμ[i] <-- ('01000011')

    ΑΛΛΙΩΣ_ΑΝ αρκμ[i]='D' ΤΟΤΕ
      τελκμ[i] <-- ('01000100 ')

    ΑΛΛΙΩΣ_ΑΝ αρκμ[i]='E' ΤΟΤΕ
      τελκμ[i] <-- ( '01000101 ')
    ΑΛΛΙΩΣ_ΑΝ αρκμ[i]='F' ΤΟΤΕ
      τελκμ[i] <-- ('01000110 ')
    ΑΛΛΙΩΣ_ΑΝ αρκμ[i]='G' ΤΟΤΕ
      τελκμ[i] <-- ( '01000111 ')
    ΑΛΛΙΩΣ_ΑΝ αρκμ[i] ='H' ΤΟΤΕ
      τελκμ[i] <-- ('01001000 ')
    ΑΛΛΙΩΣ_ΑΝ αρκμ[i]='I' ΤΟΤΕ
      τελκμ[i] <-- ( '01001001 ')
    ΑΛΛΙΩΣ_ΑΝ αρκμ [i]='J' ΤΟΤΕ
      τελκμ[i] <-- ( '01001010 ')
    ΑΛΛΙΩΣ_ΑΝ αρκμ[i]='K' ΤΟΤΕ
      τελκμ[i] <-- ( '01001011 ')
    ΑΛΛΙΩΣ_ΑΝ αρκμ[i]='L' ΤΟΤΕ
      τελκμ[i] <-- ('01001100 ')
    ΑΛΛΙΩΣ_ΑΝ αρκμ[i]='M' ΤΟΤΕ
      τελκμ[i] <-- ('01001101 ')
    ΑΛΛΙΩΣ_ΑΝ αρκμ[i]='N' ΤΟΤΕ
      τελκμ[i] <-- ('01001110 ')
    ΑΛΛΙΩΣ_ΑΝ αρκμ[i] ='O' ΤΟΤΕ
      τελκμ[i] <-- ('01001111 ')
    ΑΛΛΙΩΣ_ΑΝ αρκμ[i]='P' ΤΟΤΕ
      τελκμ[i] <-- ('01010OOO ')
    ΑΛΛΙΩΣ_ΑΝ αρκμ[i]='Q' ΤΟΤΕ
      τελκμ[i] <-- ( '01010001 ')
    ΑΛΛΙΩΣ_ΑΝ αρκμ[i] ='R' ΤΟΤΕ
      τελκμ[i] <-- ( '01010010 ')
    ΑΛΛΙΩΣ_ΑΝ αρκμ[i]='S' ΤΟΤΕ
      τελκμ[i] <-- ( '01010O11 ')
    ΑΛΛΙΩΣ_ΑΝ αρκμ[i]='T' ΤΟΤΕ
      τελκμ[i] <-- ('01010100 ')
    ΑΛΛΙΩΣ_ΑΝ αρκμ[i]='U' ΤΟΤΕ
      τελκμ[i] <-- ('01010101 ')
    ΑΛΛΙΩΣ_ΑΝ αρκμ[i]='V' ΤΟΤΕ
      τελκμ[i] <-- ( '01010110 ')
    ΑΛΛΙΩΣ_ΑΝ αρκμ[i]='W' ΤΟΤΕ
      τελκμ[i] <-- ( '01010111 ' )
    ΑΛΛΙΩΣ_ΑΝ αρκμ[i]='X' ΤΟΤΕ
      τελκμ[i] <-- ('01011000 ' )
    ΑΛΛΙΩΣ_ΑΝ αρκμ[i]='Y' ΤΟΤΕ
      τελκμ[i] <-- ('01011001 ')
    ΑΛΛΙΩΣ_ΑΝ αρκμ[i]='Z' ΤΟΤΕ
      τελκμ[i] <-- ('01011010 ')
    ΑΛΛΙΩΣ_ΑΝ αρκμ[i]='0' ΤΟΤΕ
      τελκμ[i] <-- ('00110000')
    ΑΛΛΙΩΣ_ΑΝ αρκμ[i]='1' ΤΟΤΕ
      τελκμ[i] <-- ( '00110001')
    ΑΛΛΙΩΣ_ΑΝ αρκμ[i]='2' ΤΟΤΕ
      τελκμ[i] <-- ('00110010')
    ΑΛΛΙΩΣ_ΑΝ αρκμ[i]='3' ΤΟΤΕ
      τελκμ[i] <-- ('00110011')
    ΑΛΛΙΩΣ_ΑΝ αρκμ[i]='4' ΤΟΤΕ
      τελκμ[i] <-- ( '00110100')
    ΑΛΛΙΩΣ_ΑΝ αρκμ[i]='5' ΤΟΤΕ
      τελκμ[i] <-- ( '00110101' )
    ΑΛΛΙΩΣ_ΑΝ αρκμ[i]='6' ΤΟΤΕ
      τελκμ[i] <-- ( '00110110')
    ΑΛΛΙΩΣ_ΑΝ αρκμ[i]='7' ΤΟΤΕ
      τελκμ[i] <-- ( '00110111')
    ΑΛΛΙΩΣ_ΑΝ αρκμ[i]='8' ΤΟΤΕ
      τελκμ[i] <-- ( '00111000')
    ΑΛΛΙΩΣ_ΑΝ αρκμ[i]='9' ΤΟΤΕ
      τελκμ[i] <-- (  '00111001')
    ΑΛΛΙΩΣ_ΑΝ αρκμ[i]='10' ΤΟΤΕ
      τελκμ[i] <-- ( '1010')
    ΑΛΛΙΩΣ
      τελκμ[i] <-- (' ')
    ΤΕΛΟΣ_ΑΝ

    ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ

  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100
    ΑΝ τελκμ[i]<>' ' τότε
      μετρ <-- (μετρ+1)
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ μετρ
    ΓΡΑΨΕ_ τελκμ[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ
  ΓΡΑΨΕ 'Για επιστροφή στο Μενού πάτα 1 αλλιώς 2 για τερματισμό.....'
  ΔΙΑΒΑΣΕ α
  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ

  αν α=1 τότε
    κάλεσε Μενού

  ΑΛΛΙΩΣ_ΑΝ α=2 τότε
    κάλεσε bye
  ΤΕΛΟΣ_ΑΝ

  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ


ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters