Τώρα είναι Πέμ 27 Φεβ 2020 08:46 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: ΧΩΡΙΣΜΟΣ ΓΡΑΜΜΑΤΩΝ
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 05 Μαρ 2009 12:12 am 
Χωρίς σύνδεση

Εγγραφή: Τετ 04 Μαρ 2009 10:46 pm
Δημοσιεύσεις: 5
ΠΩΣ ΜΠΟΡΩ ΝΑ ΚΑΝΩ ΤΟ ΠΡΟΓΡΑΜΜΑ ΝΑ ΜΟΥ ΔΩΣΕΙ ΤΑ ΓΡΑΜΜΑΤΑ ΜΙΑΣ ΛΕΞΗΣ;

Π.Χ ΑΝ ΕΧΩ ΤΗΝ ΛΕΞΗ ΓΡΑΦΩ ΝΑ ΜΟΥ ΓΡΑΨΕΙ ΤΟ ΠΡΟΓΡΑΜΜΑ ΟΤΙ Ι ΛΕΞΗ ΕΧΕΙ ΤΑ ΓΡΑΜΜΑΤΑ Γ,Ρ,Α,Φ,Ω


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: ΧΩΡΙΣΜΟΣ ΓΡΑΜΜΑΤΩΝ
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 07 Μαρ 2009 01:22 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 30 Μάιος 2008 09:46 pm
Δημοσιεύσεις: 49
Παράθεση:
ΣΥΝΤΑΞΗ: 1) ΜΗΚΟΣ_ΧΑΡ(μεταβλητή_ή_σταθερά_χαρακτήρων)
ΠΑΡΑΔΕΙΓΜΑ: α <-- 'Καλημέρα σας!'
ΓΡΑΨΕ ΜΗΚΟΣ_ΧΑΡ(α)
ΣΧΟΛΙΑ: 1) Η συνάρτηση ΜΗΚΟΣ_ΧΑΡ επιστρέφει το μέγεθος (σε χαρακτήρες) μιας
μεταβλητής χαρακτήρων. Για παράδειγμα: ΜΗΚΟΣ_ΧΑΡ('ΑΒΓ') = 3.

Παράθεση:
Η ΓλωσσοΜάθεια υλοποιεί εσωτερικά τις μεταβλητές
χαρακτήρων σαν πίνακες από μεμονωμένους χαρακτήρες (με μέγιστο
μήκος 255).
Άρα, αν θεωρήσουμε τη μεταβλητή χαρακτήρων Λ = 'ΠΑΡΑΔΕΙΓΜΑ',
τότε το Λ[3] είναι μια μεταβλητή μεμονωμένου χαρακτήρα και έχει τιμή
Λ[3] = 'Ρ'.

Τα 2 παραπάνω είναι από το εμπλουτισμένο συντακτικό της γλωσσομάθειας έκδοση 8.5 .
Τώρα για τον συνδυασμό τους :
ΓΙΑ Α ΑΠΟ 1 ΜΕΧΡΙ ΜΗΚΟΣ_ΧΑΡ(Χ)
ΓΡΑΨΕ Χ[Α]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Αυτό θα σου γράφει 1-1 τους χαρακτήρες της λέξης. Το χ είναι μια μεταβλητή στην οποία βάζεις την λέξη της οποίας τους χαρακτήρες θες να σου γράψει το πρόγραμμα ή μπορείς να βάλεις και την ίδια την λέξη όπου υπάρχει το χ. Το Α είναι μια μεταβλητή που χρησιμοποιείται για να δείχνει πιο κελί του πίνακα Χ θα γράψει το πρόγραμμα, δηλαδή ποιον χαρακτήρα της χ θα γράψει αφού η χ είναι μεταβλητή χαρακτήρων.
Π.χ.
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ χαρακτήρε
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: Γ
  ΑΚΕΡΑΙΕΣ: Β
ΑΡΧΗ
  ΔΙΑΒΑΣΕ Γ
  ΓΙΑ Β ΑΠΟ 1 ΜΕΧΡΙ ΜΗΚΟΣ_ΧΑΡ(Γ)
    ΓΡΑΨΕ Γ[Β]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ χαρακτήρε
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: Γ[10]
  ΑΚΕΡΑΙΕΣ: Β, Α
ΑΡΧΗ
  ΓΙΑ Β ΑΠΟ 1 ΜΕΧΡΙ 10
    ΔΙΑΒΑΣΕ Γ[Β]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Α ΑΠΟ 1 ΜΕΧΡΙ 10
    ΓΙΑ Β ΑΠΟ 1 ΜΕΧΡΙ ΜΗΚΟΣ_ΧΑΡ(Γ[Α])
      ΓΡΑΨΕ Γ[Α][Β]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Το 2ο παράδειγμα είναι για την περίπτωση που η λέξη είναι σε πίνακα.
Υγ. όλα αυτά ισχύουν στην έκδοση μεταγλωττιστή μόνο

_________________
"Δύο πράγματα είναι ατελείωτα (άπειρα), το σύμπαν και η ανθρώπινη βλακεία, για το 1ο δεν είμαι σίγουρος." Einstein
"Τα πάντα ρει" (Τα πάντα ρέουν/αλλάζουν) Ηράκλειτος
"Μη μου τους κύκλους τάραττε" Αρχιμήδης


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters